Inconsistent paragraph formatting

I’m having an issue with an inconsistency in how Scrivener is handling tabs after paragraphs. I’d like a tab after all paragraphs (including the initial), and thought I’d set it up that way, But after compiling, several paragraphs begin with tabs but most of them have been removed. Formatting for all the paragraphs is the same. Can you please tell me how I can fix it?

Are you using tabs to have first line indent? Don’t!
Indention in the final output is best handled by during Compile.
Scrivener is not wysiwyg.

Thanks for your reply. No, I don’t have any leading tabs. On the screen, the lines are all left justified, it’s only after compiling that random tabs show up.

In the attached, there should be a tab before “You’re,” “Did,” “When,” “Silence” and “I squeezed.”

Before compiling:

Please turn on View -> Text Editing -> Show Invisibles, so we can see what you’ve actually specified in the Scrivener editor.

Also, what format are you compiling to, and what tool are you using to inspect the output file?


I’m not sure I understand your problem. Is it that you have set “first line indent” when you compile, in the Section Layout window as shown in the screen shot, and some of them are removed during compile?

Thanks for your responses. Here is my text, with Show Invisibles, and my Section Layout screen. (I’m not sure I understand why my Layout titles are different, since I didn’t change them. Do I need to adjust the Foreword option?):

Katherine, I’m using Word for compiling and viewing.

No invisibles are showing, like paragraph marks and new line symbols.

Oh yes, if I zoom in to your text screenshot and squint I CAN see the line endings.

The reason your paragraph formatting is inconsistent is that some of your “paragraph” breaks (¶) are actually line breaks (:leftwards_arrow_with_hook:︎). Line breaks are a forced line ending in the same paragraph. Scrivener doesn’t indent it like a paragraph because it isn’t a paragraph. If you want those to all be new paragraphs you’ll need to run a find and replace. Just select and copy one of the :leftwards_arrow_with_hook: symbols and paste it into the Find field, then do the same with ¶ and the Replace field. Proceed with finding and replacing.

Hope this helps!

Thank you so much! Gosh, I didn’t even know that was a thing…(I really wonder how that happened so many times throughout my document.)

So helpful, thank you!

I’m glad I was able to help! To help keep this from happening again, if I may suggest:

Place your cursor inside a paragraph. Then use the menu item Format->Paragraph->Line and paragraph spacing… . You should get a small dialog box. Down in the paragraph spacing, increase your “before” spacing – 6 points is probably plenty.

Now you will get a small but visible gap before that paragraph, but the lines inside it will be as tight as before. That will make a line break obvious – because it’s part of the paragraph, there won’t be a gap before it.

To make all your new documents have the new paragraph spacing: With your cursor still in your paragraph with its new spacing, go to Scrivener->Preferences. Click on the Editing button, then on the Formatting button inside the Editing pane. Click on the “Use Formatting in Current Editor” button. You’ll see the sample text below shift to show your new spacing.

To update all your current documents to the new spacing: Select all documents you want to have the new spacing in the Binder at once. Use the menu item Documents->Convert->Text to Default Formatting… . You’ll get a small dialog box asking you what you want to change/preserve. Be sure the Line Spacing box is NOT ticked! (Usually the only thing I preserve is alignment, and I leave my styles alone.)

Hope this helps!