Increase contrast of binder arrows

I don’t really understand why the beta install is different, but I will investigate. The path to the Scrivener executable seems irrelevant to me. It’s all about the relative path from the QSS-stylesheet to the icons in the Icons Folder.

On testing, I find the current version with the relative paths: “./icons/branch_open_white.svg” and “./icons/branch_closed_white.svg” works in beta 3.1.5.0:

The Theme has be to imported and loaded, instead of loaded from file. After importing, you’ll have to select the theme from the menu and restart Scrivener to make the Theme show, otherwise you’re still looking at the old version of the Theme. Make sure you’ve restarted the beta version by checking its version number.

(Actually, the Theme with a hard-coded username in the QSS, and the forward slashes in the path , also works as expected.)

But… hold your horses. I’m getting mixed results, I don’t understand yet. The jury is still out…

The icons referencing the Resource Library are not the open and close icons for the branches. Only the last two rules in the QSS are addressing those. The icons use a relative path from the QSS-stylesheet to the Icons folder.

Hi Antoni, well, I thought I had done that import, and that the result was to put the theme renamed-zip in the folder accessed from the menu to show imported themes. I worked on my variants by editing the css-actually file in there, which is is readily done via 7-zip, which can let you edit and save changes, not altering the zip type. This was proper enough, as results showed, but I wasn’t re-importing actually, so…

You’re probably aware that there are many more permutations possible in real-programming-land than we’re discussing, so all bets are off on any assumptions without seeing that internal code.

I saw a much cleaner solution if we have to have a hard path, but let’s see if I can simply get your ./ path version to work first. If it would, then it should also for the Program Files destined install of ordinary Scrivener as well.

I’m away from the laptop of experiments, but will let you know how it comes out – just wanted to gain you a little peace on your later Sunday hours :slight_smile:

Clive

I’ve posted the issue as a bug, as I’ve gotten a result one time, but could never repeat it.

Both the relative path and an absolute path in the QSS work in 3.1.4.1, but not in 3.1.5.1 B3.
It may be connected to the SVG-files, resolving URLs or rights to access files in the imported themes folder.

I do hope this issue will be resolved.

Going to watch a movie now. :grinning:

2 Likes

Following @tiho_d’s help, I’ve corrected the Theme and the Readme.txt file.
Following the instructions in the Readme, this should now work for everyone.
If you’re using the 3.1.5.1 Beta, you should still just follow the instructions in the Readme file. :slight_smile:
Download the zip-file in the original post of the Theme.

Antoni,
Thanks so much for this theme. Best I’ve seen for someone who turns screen intensity down. (Like me.)

I can now see toolbar icons much better but how can I tweak the size of the arrow-icons? They look great in the screenshot you provided but when I install it, the arrows show up about 1/2 that size.

Oh, play with the extra spacing and line height of the Binder in the Appearance Options for the Binder.
There should be a setting the gives the SVG icons enough room to grow. :wink:

I have set the “Binder item extra indent” at 5 px… You could go up to twenty. See what works best for you.

Hope this Helps

Oh, crap!
Didn’t even think about it being a setting in Options. I messed with numbers in the QSS file and didn’t see any change except an occasional error message from Scrivener.
Perfect.
Thanks