Indentations change on compiling

I use a lot of indentations in my poetry . I have set a half inch indentation in 6x9 format but when I compile the book the indentation s are one inch. What am I doing wrong?

If you use Editor Styles for these Indents, be sure to Import them in the Styles pane of the Compile Format Designer using the button in the top right area of the Compile Styles Screen. Double-Click your Compile Format in the left column of the Compile Overview window to reach the Compile Format Designer.

If you’ve set them by hand for each line, it’s perhaps best to Compile “As-is”, to keep the formatting in the Editor while Compiling. Click the Assign Compile Layouts button in the center column of the Compile Overview window to select this option for your Compile Types.

If you created your indents by using the Tab key, rather than setting the ruler, that may well be your problem; the compile format will probably already have the indent set, hence the ‘double indent’.

Thank you both. I have had a look at your comments/suggestions and things are looking better