Indents and zooming in Scrivener vs. Ulysseus

I just wanted to share my little experience with Ulysses in using indents and zooming the text. By no means, my intention is not to criticize Ulysseus with bad intentions. Just letting out few remarks.

I fell in love with Ulysseus, but the honeymoon was soon over when two things occurred:

  1. I had problems of making the first line indents. When making them in iPad and opening the sheets in iPhone, indents were all wrong and there were extra line breaks in the first lines of the paragraphs. And as you can imagine, it would be insane to write with iPhone when you first have to set all the indents again and remove line breaks. And when you sync the sheets back to iPad, they are ok (because you just set them again in iPhone), but when you open 'em again iPhone, they are all messed up again. So, pretty frustrating. When I’m supposed to write when all of my time goes with tweaking the indents and removing extra line breaks?

Their customer support has been really helpful and awesome, they’re doing great job. But when I reported about this problem, they asked me why I am using indents in the paragraphs because in any case they are not exported? Umm, what? Why I am using indents? And they are not exported? Wow, I was like what the…

  1. Another big problem for me was zooming the text. If I zoomed the text in iPad and iPhone, all indents went totally crazy and the text looked nuts, whether I zoomed out or in. The only good zoom setting was 0.9 when the text looked normal. And when I turned my iPhone into vertical position, kaboom, the text exploded again and everything went bats*it crazy.

With Scrivener, I have never had these kind of problems. I’ve been using Scrivener iOS since it was released and I have never encountered problems, not a single one. The idea of Ulysseus is really great, it’s easy and fast, minimalistic and all, but for me at least, those two bugs scared me away. But after trying it out, I have realized that Scrivener is, after all, as fast, easy and minimalistic as Ulysseys. Plus the sync between devices is reliable and I don’t never have to worry about layout or formatting changes between devices. I have to be able to trust the software because I pour thousands of hours and years into writing with it.

Maybe the Ulysses wasn’t just working correctly with my devices and the problem were my iPad and iPhone. But the Scrivener has worked with zero issues. After this Ulysseus crisis I even tested Scrivener with different scenarios, formattings and settings between iPad and iPhone and there were zero issues.

Any thoughts about this, fellow writers?

Hi David,

It sounds like the root cause of your challenges with Ulysses had to do with first line indents.

I have never owned or used Ulysses, but my guess is you were using a Ulysses style that doesn’t support first line indents, or your editor options were not set to show first line indents.

It works the same in Scrivener. If the editor was set to not show first line indents, you wouldn’t see them either.

What the customer support person said makes sense to me. You don’t want to manually insert indents in Scrivener, you set them up from style or the editor options and let the software add them while you’re editing or when you compile, and it makes sense that Ulysses works the same way.

It also makes sense that manually inserted indents would not be exported – Ulysses is a text markup tool, after all.

So my thoughts are: Wouldn’t it be better to post this on a Ulysses forum? Have you taken any Ulysses tutorials or consulted the manual?


Thanks for the reply! I did insert indents in the same way like I insert them in all word processors, through the editor and the software inserts the first line indents for me automatically. I don’t use Tab or spaces or anything like that, I don’t insert indents manually. In Scrivener iOS I insert them through the editor, indents etc.

I was just so amazed what happened that I wanted to share my experience. I’m not actually sure why the customer support asked why I need the indents because they are not exported? Maybe I’m naive, but I thought the indents are there that I can use them. But if I can’t export my sheets with indents… well, the software is then pretty useless. Maybe I’m just missing something but if the processor gives me an option to use something and it shows in the text, but it’s not in the export file… why should I write with that processor in the first place if I have to use other processor to insert indents?

Just comparing these two editors and why I’m sticking with Scrivener.

Hi David,

Respectfully, Ulysses is a popular tool for bloggers, novelists, etc. Distraction-free elegance and portability across the Apple realm are its main features and reasons for existence. If it couldn’t handle formatting consistently across devices, then nobody would use it.

Also respectfully, this sounds to me like a learning curve/user error/training issue/RTFM situation. I suspect you’re giving up a little too quickly. If I were in your shoes I’d spend more time with the app.

But as I said, I’ve got no experience with Ulysses, so I could be 100% wrong. Perhaps you’ve discovered Ulysses’ Heel. :mrgreen: But I can confidently state that you’d be more likely to get specific guidance on how to accomplish what you want from a Ulysses forum.

Or ping David Hewson (or buy his book!) and ask him how he does it. :smiley:


I have experience in both. I use Ulysses for blogging and Scrivener for almost everything else.

The problem lies in the fact that Ulysses is a Markdown editor. If you’ve never heard of this, please do some Internet research. The settings under Layout are strictly for your visual convenience, are not shared between devices (so must be set up separately for iPhone and iPad), and most importantly are not stored in the underlying files.

The only way to make a real paragraph break in Ulysses is to leave a blank line—two enters in a row. If you don’t, you’re going to be unhappy when it comes time to share your work. It’s the way Markdown ( which actually gets translated into HTML and then formatted into your final output format) works.

PS. I admire Mr. Hewson greatly, and bought his book. I tried to use Ulysses for novel writing, and came running back to Scrivener… :wink:

Ah, thankfully someone with actual expertise has posted. 8)

My general takeaway from reviews/comparisons was that Ulysses was better suited to blogging and Scrivener to novelling, due to the latter’s superior organizational and export capabilities. It seems like that was your experience as well?

I’m curious though, Silverdragon: If you make a “real” paragraph break in your draft by leaving a blank line, is Ulysses’ export functionality capable enough to automagically transform that into an indented, spaced paragraph format appropriate for a novel manuscript? Or are real paragraph breaks not best practice when using a mark down editor?

If you’re using the default Markdown XL, you don’t need to leave a blank line betweeen paragraphs in Ulysses - it will export fine without them. It’s only if you’re using the Markdown format that you need that.

The output is entirely dependent on the export format you choose, of course, but a paragraph in Markdown XL is always a paragraph in the export. The look and format will be different of course, but the unit remains the same.

A couple of the included export formats are suitable for fiction manuscripts and it’s possible to amend them (it’s harder and far less flexible than Scrivenerj but if you’re happy with the defaults, Ulysses’s process is simpler.

Thanks, guys! Now I understand that the Markdown wasn’t for me at all. I thought I understood the basics through Tutorials, but now it’s obvious that I was sooo lost. Call me an old fashioned fart, but I’m gonna stick with the clear world of WYSIWYG.

I understand that Ulysses is great for people who likes to tweak things, use Markdown and write blog posts, but at least for me, it’s too complicated world, although the project management in Ulysses is really easy to use. But I think it’s better in Scrivener and hey, I want to focus purely on writing without the extra hassle. And in Scrivener I can do that, I don’t have to worry about the settings, formatting or syncing between devices. And the bottom line for me is during writing and exporting: What You See Is What You Get.

You are aware that Scrivener is not a WYSIWYG editor either, right? That’s the whole point of the Compile process – to divorce what you see on-screen from what gets output.

Yes, sorry. I used too loosely the word. But at least it’s WYSIWYG for me when I make indents, paragraphs, aligns etc. and I open the project in another device, and behold, all indents and stuff are there and then it’s WYSIWYG enough for me :slight_smile:

When it’s time to export… well, that’s another story but at least then my draft writing is done. Until it starts again with the publisher and editor, but again, then it’s another story.

Ah, but I always use the external folder option, :blush: which eliminates Markdown XL. So a single return for me translates to a line break, not a paragraph break. As others have posted elsewhere, my fear and loathing of the unified iCloud library is vast. If I’m going to use a plain text format, I by heaven want access to my plain text files. In plain text, thank-you-very-much.

I agree with your comments about export. The difficulty of customising fiction export formats was the deal-breaker for me. OTOH, in working with my blog it’s just a translation from Markdown to HTML, which Markdown is designed for. Markdown uploaded to blog, blog uses its formatting to display, all is well.

Fair enough! :slight_smile:

I suspect most people will stay with the defaults though, so won’t have to worry abou the additional line.

I understand what you mean about the Extenal folders thing, but haven’t had any problems so far. I use Ulysses for a blog (Wordpress) and it’s very useful for that.

I’ve tried using Ulysses for fiction but came across a couple of niggles, one of which seems to me to be a serious design flaw—the designers don’t seem to me to be all that bothered, which I find a bit strange.

The design flaw is that Smart Quotes don’t work the same way on the Mac and on iOS for single quotes: essentially on iOS a single quote opening a paragraph is ignored, while on the Mac it is converted correctly. Double quotes work as expected on both platforms.

The reason appears to be that iOS’s smart quotes subsystem works differently from the Mac’s and converts the smart quote immediately, which means that the code (two single quotes) for Code Block is messed up. The designers have chosen to get round this on iOS only by disabling single smart quotes at the beginning of a paragraph.

This is a problem for fiction writers who aren’t American because the normal usage is single quotes for dialogue… and it’s particularly a problem if you’ve moving between iPad and Mac on the same document.

Of course there are workarounds (don’t use Smart Quotes, or switch to the US usage, or create your own custom markup disabling Code Blocks), but there doesn’t seem to be a hint anywhere on their site that this is an issue, leaving people to find it, half way through a manuscript…