Indents lost when compiling to ePub

I have the same problem. Did you ever solve this?

But I’m not reading it on IOS. I’m viewing the ebook from a Mac desktop and have tried a few different ebook reader applications. Is there really no way to keep tab indents a the beginning of paragraphs when exporting to ebook format?

Have you tried using Kindle Previewer though? I cannot speak to the accuracy of the Kindle book reader that runs on a Mac, it may not be working well either these days.

Kindle doesn’t open the epub format that I was working with. Since I’m not trying to produce an ebook for Kindle or Amazon, I’d really like a simpler solution. I just want to be able to view the piece I’m working on, with the formatting displayed properly, in the epub format with the ebook readers I already use (Books, Calibre Ebook Reader, or Adobe Digital Editions). (The original post I replied to wasn’t quite the same issue as this thread, since I’m no asking about mobi files.)

Since you’re not asking about MOBI files but have ended up in the MOBI thread, could you clarify what you’re actually trying to do, please?

That’s the point of confusion I think, since the post you originally responded to was about reading Kindle files, and losing indents only after trying to do so (the ePub was fine). That symptom is what is caused by the explanations given in this thread, which is why I moved the thread.

At this point though, it seems like you aren’t using a Kindle at all, and are only trying to load an ePub into your preferred ebook readers. Is that correct? Happy to move this to its own thread if so.

I didn’t original post here. It sounds like the thread I posted on just got merged with this one and my post moved over here. My problem is: When I export to epub, whatever reader I view it in, all the indents at the beginnings of paragraphs are removed. How can I maintain or restore these paragraph indentations in an ebook export?

I no longer can find the post I replied to, so perhaps I misread it. In any case, yes I’m asking about a different problem. (Though also about indents disappearing.)

Okay! Sorry for the confusion then. :smiley: Yes the original post was specifically about another issue, and yours was just a did-you-figure-it-out, so I moved them both together assuming yours was about Kindle readers as well.

As to the single most common reason indents get lost in ebooks: they aren’t actually indents. Earlier you mentioned tab indents. If you mean that literally, where you pressed tab at the beginning of each paragraph, then ebook readers will tend not to see those at all.

If you aren’t sure, use the View ▸ Text Editing ▸ Show Invisibles menu command in the main editor, and check for little rightward pointing arrows in front of each paragraph. Those will be tabs.

OK, that makes sense. A bit of a pain, but fixable. Thanks.

Yeah, it is a bit of a pain, but it has to do with how ebooks internally treat tabs as part of the “code”. They are considered a way to make the internal formatting look nice rather than something that would print in the web page / ebook.

At least we do have the Edit ▸ Text Tidying ▸ Strip Leading Tabs command to help out. I’d do that on one chapter, see how it looks in Calibre, and if it’s good to go, have at the rest.

You might need to tweak the compile setup if that doesn’t work initially. I’d start with using the provided “Ebook” example, as that has some nice indent settings by default.

It might be a good occasion to think about breaking the tab-indent habit! :grinning:

2 Likes

Amazing how often users forget the ruler and its tab indent function. And then equally ignore the power of Compile to produce the EPUB output they want.

1 Like

And the Ruler’s snap option so you don’t need to faff around with point x of a centimetre or inch.

Kevitec57, could you explain more please? I’m familiar with ‘snap to grid’, but how/where would I find more information about the ruler’s snap option in Scrivener and how it relates to indents?

The Snap to Ruler feature is found under Files > Options > Editing> Options.
Then: Ruler units: Centimetres. Ruler snap every: 0.25 centimetres.
When starting a new page my first paragraph is indented at 0.5 cm, along with all the rest, as per the setting of the First Line Indent (the top left indent marker). There’s no way to set the first paragraph differently to the rest and I wouldn’t want to anyway because I often swap paragraphs around on the go.
The 0.25 is also a convenient and visible distance for dragging around indents when sorting bullets and numbering, although for the most part, I now use Paragraph Styles for three levels of indentation. Bullets and numbering are particularly weird in Tables. There I use a combination of Paragraph Styles and minor adjustments with the Format Copy and Format Paste buttons active.
If I don’t have a Ruler Snap set, I get unwanted results, based on templates generally set up in inches and end up with oddball distances like 1.67 cm.
Working the Ruler saves me fiddling in the menus. I’d love an option to switch the Ruler on permanently in Quick Reference Panels. I know QRP’s aren’t exclusive to text, that’s why I say option.

3 Likes