Indents not doing what I want.

ePub for Apple
I have the entire main body set the same way to the section type “Body scene” default

My problem currently is the indents are not working properly.
The entire document accept for the last three pages are all showing no indent at all.
On the last pages it starts out displaying the incorrect same as the rest of the book no indent.
The rest indents to where I wanted the entire book .

Help please.
Thanks in advance
Body scene .png


You’re showing the way it looks in the Editor, which has nothing to do with how it looks after compile.

Or rather, what we can see here are your compile settings (which look to be close if not identical to the stock “Ebook” format) along with your default settings for editor formatting.

What we can’t see is a small sample of the source text itself, which could be useful, particular with View ▸ Text Editing ▸ Show Invisibles enabled. Some people use old typewriter conventions to “indent” paragraphs, which are not suitable for word processing in general, and are particularly problematic with ebook publishing.

Another thing to be wary of is the overuse of styles in the editor. If you’ve been using a style on most of your body text, that can negatively impact default compile settings, which assume you won’t be.

Duh, to late in the eve for me I guess… you are correct, forgot to put up the output shot

The entire body of the book has the same output as the first 2 paragraphs .
and this page and the next 2, are the only ones producing the indents.

It looks like you have a lot of extra empty line feeds (enter) in the text. Maybe this corrupts the flow of text?

Yup, I bet the extraneous spacing between paragraphs is the problem. It’s not a matter of corruption per se, but default settings for the Ebook format will interpret an empty line in your text as being a scene break, and ordinarily you would want to suppress the first-line indent for the paragraph following such a break. Put a line after every single paragraph like that, and voilà, no indents!

You can easily tell this is the problem by examining the .epub file in something more aimed at production than reading. In Sigil, you’ll see something like this:


…Delm erc yiphras clum, gra srung arka.

Urfa, ju ozlint srung twock kurnap...


And in the stylesheet.css file:

.br + p { text-indent: 0em; }

Whether to solve this in the editor or the compile settings is up to you. For the latter, you would need to go into the Text Layout compile format pane, switch off Remove first line indents: from all paragraphs following other elements, and then once that activates the subsidiary checkboxes, disable From paragraphs after blank lines, at the bottom. You will likely also want to enable From first regular paragraph in each chapter.

If you prefer CSS, you can do all of this directly in the CSS pane as well, of course. These checkboxes just generate default CSS for you.


Seriously… I can see where this becomes easier over time, but this being my first book I am ripping my hair out over editing and formatting.

This community is wonderful… thank you so much for the assistance.

I might ask, I thought the extra spacing made it easier to read.
Does it not have that effect?
Should I strip the extra carriage returns out?

Yes. Remove them.

You can add just a little extra space after each paragraph automatically, both in thr Editor and when you compile. Found under the Format menu.

Hi Lunk,

So just a point for my understanding.
You suggest I remove the carriage returns creating the empty line, extra space.
Then suggest I can put them back.

What is the benefit of removing them if I just add the space again in compile?

And what do I turn on to add the space in compile?


I think what is meant is that using space—as a concept—to denote paragraphs is perfectly fine, but the manner in which you do so is similar to indenting itself. There aren’t actual spaces in the indented area, but a formatting command that tells the first line of text to shift over a bit. A paragraph space can be done similarly (it can be on the top, bottom or both). The advantages of doing things this way are that your output will be much cleaner (no dummy paragraphs like in the above code snippet), and you will have finer control over the amount of space. With a whole empty paragraph generating a space, there is a minimum as to how small it can be—and in most cases the amount of space it produces is borderline excessive (at least for traditional design, we have perhaps as humans grown used to it in plain-text editing, and places like this forum, where empty gaps between paragraphs are the size of lines themselves).

So in your editor you would have no lines between paragraphs, and in your compile settings, you would double-click the Section Layout tile you use for text, and modify its layout with Format ▸ Paragraph ▸ Line and Paragraph Spacing….

It’s worth noting that in most type design circles you will find it strongly recommended to choose one or the other. Having both paragraph spaces and indents is frowned upon as redundant signalling. You should choose one look or another.

That seemed to work for ebook.
Can I do it for word.doc export as well?

I can’t seem to find the location for the paragraph setting for it.