Inline annotations getting compiled as new scene

Here’s what I am doing:

  1. Putting inline annotation as a separate line (see: Describe Vikas Jain in a paragraph with his summary background)

  2. Compiling with Remove Comments and Remove Annotations options ‘On’

  3. But the PDF (or print) considers the line after the inline annotation (See: Sir Vikas Jain laid the page with minute print . . .)

My guess is this: Before and After the inline annotation line, I am pressing ENTER. Of course this would inform Scrivener to take it as a new paragraph.

My question is: can I bypass this? Is there a way (apart from continuing the inline annotation on the same line, without pressing ENTER)?

Cheers – ZG

So the best way to think about an inline annotation is: if you deleted the bubble entirely in your editor, what would be left? In your case, it might also be easier to turn on the View ▸ Text Editing ▸ Show Invisibles menu command. With that enabled, you should see that at the very end of the annotation line is a carriage return, as well as the return from the end of the paragraph above it. The result of two adjacent carriage returns (with the red text deleted) is of course an empty line.

And an empty line, in the proofing Format inserts a scene break.

So you could fix this in one of two ways:

  • Be sure to enclose the unwanted carriage return inside the annotation bubble as well.

This is what I do. See how the annotation actually starts at the end of the previous line? If I delete the entirety of this bubble, the line following this one will directly follow the previous. You could alternatively wrap the carriage return at the end of this line, but I prefer this way because I think it is easier to see what is going on.

You might also note that if I enclose both of the carriage returns in the bubble, the effect of deleting it would be one single paragraph on output. I can thus have long, multi-lines likes (like this one!) even between words in a sentence.

  • Or, if you aren’t making use of that empty-line = scene-break capability in general, then it might be better to just remove it from the format. You’ll find the setting in the Separators pane of the format designer. I recently posted about that pane today. But do note you’ll still get an empty line there, just not filled in with asterisks.

Thanks, A.

Worked like a charm!

On a side note, I really love that font of yours.

May I know the name please?

Cheers! – ZG

That would be Cousine, which is a free font, as recommended by Silverdragon in this post. :slight_smile: