Inline Footnotes Not at Bottom of Page

I must be missing something. When I put my cursor at the end of a sentence, then Insert > In-Line Footnote, nothing happens.

If I write my text anyways, it adds the in-line footnote text RIGHT NEXT TO THE SENTENCE instead of at the bottom of the page. So weird. Any ideas on how to fix this?

In scrivener itself, for the fact that there is actually no page (or rather an infinite one), footnotes are never at the bottom.

In this case: being named “inline …”, it does, as you described it, exactly as intended ; insert it inline.

If you don’t want footnotes intertwined with your body text, use this instead:

In the editor, select the word (or group of words) to which the footnote relates to, then:

2023-04-26 12_45_05-Dictionnaires – Antidote

Note that inline footnotes, just like the “standard” ones (like I just showed you how to do), with the proper setting will in fact compile at the bottom of your pages. It is just not presented like that in the editor, for the technical reason I mentioned right off (no page: no page bottom).

→ There is nothing preventing you from using a combination of both. (I mean a document can have a couple inline, and a few in the panel, it’s fine.) Use whichever is the most convenient, case by case.

Ok, so I definitely want to use in-line footnotes so that they show at the bottom of the page when I print this/export, etc. So you are saying that this “in-line footnote” that shows ON THE LINE in the editor, will, once I export it, show at the bottom of the page instead?

It won’t let me upload a screenshot bc I am not trusted on this platform.

I am wanting footnotes at the bottom of each page like this video shows at 3:09.

Both methods will, given the right setting.
At this point it is only a question of whether you want to see a specific footnote right away or not when editing your text.

So if I can set them as just typical footnotes, but have them show at the bottom of my pages instead at the end of the chapter, how do I set that up?

The short answer is that there’s an option for the Compile command to format either in-line or inspector footnotes (or both) as either endnotes or footnotes.

The slightly more accurate answer is that you might want endnotes or footnotes depending on your output format – ebooks only support endnotes, for instance – and Scrivener can do either.

The definitive answer can be found in the section on Footnotes and Comments in the Scrivener manual. It’s section 24.19 in the Mac manual, not sure about Windows.

For useful background, I’d recommend taking a look at our Interactive Tutorial if you haven’t already. It’s available from the Help menu.

1 Like