Insert footnotes with shortcut can only go up to 15 footnotes

I usually use ctrl+cmd+8 to insert footnotes at the cursor without selecting any text.

With Scrivener 3, I can only add 15 footnotes this way, then the same shortcut will only take me to the previous footnote. I can still insert linked footnotes to selected text, but that’s not what I want.

By the way, any chance to have automatically numbered footnotes in future update?

I’ve just tested this and got up to 37 footnotes (before I got bored…) It seems to be working for me without any problems.

Does the problem happen in every document and every project / in new projects created in v3?

There’s certainly no built-in limitation here, so I can’t imagine what would be causing this. Strange.

There are no plans to add automatically-numbered footnotes because this would be very difficult (and processor-intensive) to calculate in Scrivener. Remember that Scrivener doesn’t know what is going to be compiled into the final document until you go to Compile and tell it. Many documents may be omitted, and the Compile settings might not include the text of all documents. So Scrivener would need to be constantly checking all of those settings to update footnote numbers - it’s not like updating numbers in a word processor where you just have the one text to work with and you know it is all part of the final text for sure.

What you can do, though, is turn on View > Text Editing > Show Compiled Footnote Numbers in Inspector. This will show numbers in footnotes after you Compile, updating them each time you Compile, so that the numbers show what number that footnote had the last time it was compiled for exporting or printing.

All the best,

Actually I just found out what’s really triggering the bug. Did you try to insert following a punctuation , say a comma or period?

Yes, but I’ve just tried again and it works with no problems at all.

If you switch to a different chunk of text in the binder and plop the cursor down in the middle of a paragraph that has no footnotes, you can’t make a sixteenth footnote, is that what you’re saying? Or is this a highly contextual problem that only happens around certain other texts. If it’s the latter, then maybe examine the context you are trying to work within for constraints. For example, you can’t add another footnote to a paragraph where every available word and character is already highlighted by a footnote or comment.

ah… I think I tweaked the insert behavior to automatically add an asterisk then embed the footnote link to it. I don’t recall how I did it, but I think it’s not a default setting.
I tried it in a new project, with the default way of inserting (automatically select the word prior to the insert point as the linked text), and everything seems fine now.
So I think it might has something to do with the automatically added asterisk?

Yes, everything is fine with selected text.
Also now I think it may has nothing to do with the amount of the footnotes, for example, I just created a new document, and the problem occurred with the third one.

I do tend to think it has something to do with the way I use an automatically generated asterisk to carry the footnote link.

Now I remember, it’s the “footnote marker”.

I checked the “Use footnote marker” box in Project Settings – Formatting.

So… I’m here to report that the problem described here hasn’t been repaired in the latest version (3.0.1 (966)), any word on the possible fix in the future?

Can anyone please response to this issue?

I thought the bug had been picked up for the last update, but clearly it’s not the case. Can anyone reproduce the problem? The whole conversation was abruptly ended with no further explanation, I just don’t understand…

Ah-- the official tech support folks are all on holiday break… A couple are hanging out here anyway, but I haven’t seen AmberV or KB on.

Thank you for the reminder, Silverdragon.

And my apology to the moderators.

But please understand that my frustration came from the fact that I’m dealing with a book involving hundreds of footnotes, and the realization that the discussed bug was not being picked up in the latest update. Given Scrivener’s release cycle of the past, it probably means another couple of months of waiting.

I cannot reproduce this, I enabled using * marker in project settings and added 19 footnotes without issue.
What else do I need to enable? Can you reproduce in a new project? If not then try to make a test project where this issue occurs…

As a workaround, why not just footnote words themselves (which I assume doesn’t cause this problem)?

Yes, as I mentioned before, it happens in the new projects, too. And no, I can’t think of any other factors that may trigger the bug.

Here’s a screen capture shows how it’s look like: …

When this happened, I’d have to copy/paste an old linked asterisk, then after a couple of pasted ones, things will go back to normal, and I can use ctrl+cmd+8 to create new footnotes again. Then it will recur. I have no idea how to reproduce it at will.

Yes, I can always give up the asterisk marker, but there’s a catch when you are writing in Chinese, which doesn’t have spaces between words, the footnote will turn the whole sentence into a link. I know it makes no difference for the final compilation, but it’s sure messes things up during the process , especially when you are woking on the scale of an academic book.

You are using the standard macOS Pinyin input method? I suspect this has to be some bug related to Chinese text. Please can you make a test project of a single document where this bug has triggered for you. Lets see if we can also see this with a Chinese text, and a test project makes it easier for Keith when he returns from Holiday to try to debug what is going on…

Hm,I still can’t trigger this (Pinyin Simplified input method and 17 footnotes):

Please try this project and see if it works on your system? (53.5 KB)

Thank you for your help, really appreciate it.

Have you tried adding one to the end of a line that already had a footnote? Here’s my screen record: …

FYI, I was using a U.S. english keyboard in the video, also tried other IMEs, my guess at the moment is it’s irrelevant.

You should be able to select only the parts of text relevant to the footnote and then add the footnote, rather than relying upon the engine to guess.

This report was noted, but we haven’t been able to reproduce it either. I’ve created a project with the asterisk setting on and added around 25 notes to one section without any issues, and some 50 overall to other test documents within the project. We can’t fix something if we can’t see it happen.

I didn’t however try in Chinese, so maybe try seeing if it reproduces in another language?

And that’s probably the missing key to your problem. Everyone else has been doing their testing using English,

I’ll have a go after we’ve got over Christmas itself—today is not the day to spend time on it!—to see if I can reproduce the problem, If I can it’ll be over to Keith.