Inspector tab row icons are missing

I’m working on MacBook Pro 16" with Mac OS 11.1, Scrivener 3.2.2 with german localisation. All my projects are stored in Dropbox.
Some time ago (maybe after the update to 11.1) I discovered that on some projects the icons in the inspector tab row are no longer displayed:
[attachment=1]tab bar tithout icons.png[/attachment]
While in other projects the are visible:
[attachment=0]tab bar with icons.png[/attachment]
Maybe I have unknowingly altered some project preferences. But I don’t know when or where this should have been happened. I have tried several actions to get the icons back, amongst others set Scrivener to english language und set back the app preferences to default values, but without success.
Switching between the inspector tabs with keyboard shortcuts works fine – but I’m a heavy mouse-user.
Thanks for any hints.

I would try:

  1. Uninstalling Scrivener
    support.apple.com/en-us/HT202235

  2. Turning the Mac off

  3. Booting the Mac

  4. Installing a new copy of Scrivener
    literatureandlatte.com/scri … s?os=macOS

Best

L

Thank you Login for this hint.
I followed your instructions and at first there was no change: One project had the icons visible, on the other project the icons were still missing.
Then I tried a step more:

  • Remove Scrivener
  • Reboot Mac
  • Copy Scrivener folder from application support to desktop
  • Remove Scrivener folder from application support
  • Remove preference file
  • Open Scrivener
  • Quit Scrivener
  • Replace new Scrivener folder in application support with copy from desktop
  • Open Scrivener

Now the icons are visible in some more projects, but there are still some projects with missing icons. To me it seems the icons are shown at random. But on the other side there’s one project in which the icons are always visible.
I will investigate further.

Sorry to hear that the problem persists.

Couple of support articles that might offer some ideas:

RESETTING DISPLAY SETTINGS
scrivener.tenderapp.com/help/kb … y-settings

RESETTING PREFERENCES
scrivener.tenderapp.com/help/kb … references

Do you have a project where the problem always occurs? If yes, could you duplicate that project, remove all private information and work, and then share it on the forum so that others can try it on their Macs? If the problem carries over to other Macs, that would suggest a file rather than an installation corruption.

Could also email tech support for help:
mac.support@literatureandlatte.com

One other question: if you have a project where the problem always appears, does it disappear if you copy and then open the file outside of Dropbox? (Wondering if Dropbox is causing the issue by not fully loading a display setting in the project.)

Best

L

I tried it with resetting the display settings. This worked at first, but as soon as I opened three projects the one that made trouble lost its icons. The other projects displayed the icons correctly.
This convinced me that - as you suggested - there must be a problem with one specific project. So I made an empty new project, copied all the stuff to that new project (which was very easy thanks to Scrivener) and now this project behaves normally again.

So, I don’t know where exactly the problem was, but I can say where it was NOT:

  • Dropbox OK
  • Localisation OK
  • Preferences OK

Strange – I find the simple solutions only after trying the complicated ones. But maybe that’s life :slight_smile:

Thanks Login for your help.

Really pleased to hear that you found a solution.

Have a great 2021. All the best with your writing.

L

I have to come back to this again. I have found out what makes the icons disappear.

If I drag a folder into the Project Bookmarks Pane, close Scrivener and open it again then the icons of the inspector tab row disappear:
[attachment=1]Folder.png[/attachment]
If I delete the bookmark, close Scrivener and open it then the icons are shown again.

I got the same problem with Omni Outliner files (v 5.8.1). If I drag an Omni Outliner file to the Project Bookmarks Pane, close Scrivener open it again then the icons are gone:

[attachment=0]OmniOutliner.png[/attachment]
If I there are several bookmarks and once the icons are gone I have to delete all project bookmarks to display the icons again.

This happens in several Projects. It happens also when I use the Add-Bookmark-Dialogue.

Document bookmarks are not affected by this problem and for now only folders and Omni Outliner documents cause this problem.

I like to chime in. Not only I had a similar problem - maybe even caused by the same reason - but now since I ‘fixed’ the issue by copying everything to a new project, now the binder starts misbehaving.

Most of the binder area is grey and the binder is glued to the bottom of the binder column.

Even if this also might be temporarily fixed by making a new project, I just can’t make a new project every odd day. It sucks up time and energy.

Thus please, look into this GUI issues.

This is how the inspector looked for me before I created a new project file:

[attachment=1]Bildschirmfoto 2021-01-16 um 06.43.40.png[/attachment]

The icons are not missing but misplaced.

This is how the binder looks right now:

[attachment=0]Bildschirmfoto 2021-01-19 um 05.57.00.png[/attachment]

Regards,

Mela

Sounds similar to a problem Japanese users were having:

https://forum.literatureandlatte.com/t/3-1-5-for-macos-has-binder-with-a-strange-area-on-japanese-language-setting/48404/1

Think tech support (rather than a user-to-user forum) might be your best option:

mac.support@literatureandlatte.com

Best

L

Mela, your issue looks like a different problem. Make sure you have Scrivener 3.2.2, as that sort of visual anomaly is a known indicator of OS compatibility problems.

Katherine

What do you have showing in the Editor pane when this happens? If you’re in Corkboard or Outline mode with no document selected, the Inspector icons will disappear because there’s no selected document to “inspect.”

Katherine

Thank you Katherine - as you can see in the screenshot I’m in edit mode. I have four projects open in Scrivener. The project bookmarks pane is empty.
[attachment=0]Window without Bookmark.png[/attachment]
Then I add an OmniOutliner document to the project bookmarks pane. I quit Scrivener and open it again. The icons have gone.
[attachment=1]Window with OmniOutline.png[/attachment]
I delete this bookmark, quit Scrivener and open it again. All is normal.
At first I thought it happens only with OmniOutliner documents and folders. But I discovered it happens also with Word documents. It does not happen however with PDF documents.

If I have open only one project then the behaviour is normal besides a slight glitch in the GUI.
[attachment=2]Window one project.png[/attachment]
This happens only in the project bookmarks pane. The document bookmarks pane works fine. Also if I add folders and files with a Hook link everything behaves normal. So I have to possibilities for a workaround :

  1. I have only one project open in Scrivener
  2. I use Hook links in the project bookmarks pane.

So this problem does not prevent me from working.
tinu

Could you open a support ticket, please? Include the screenshots in your last post, plus a link to this thread. That will make it easier to add this into our internal bug tracking system.

literatureandlatte.com/contact-us

Thanks,

Katherine

Thank you Katherine - I sent a bug report to mac.support.

Scrivener was up to date at the day I took the screenshots, so is the OS.

Please check the About Scrivener pane and confirm the actual version. Among other things, there have been some issues with the automatic updater.

Katherine

[attachment=2]Bildschirmfoto 2021-01-27 um 15.05.53.png[/attachment]

[attachment=1]Bildschirmfoto 2021-01-27 um 15.09.02.png[/attachment]

[attachment=0]Bildschirmfoto 2021-01-27 um 15.10.08.png[/attachment]