Install/Uninstall Problem[BUG FIXED]

I installed 1.6 on my XP SP2 system last night, was informed near the end of the installation that installing the Uninstall portion didn’t occur correctly and might not work right.

Scrivener didn’t open - told me I didn’t have appropriate permissions.

Uninstall in the menu didn’t work. Told me it couldn’t find uninstall.exe.

Tried via Add or Remove Programs, appeared to work, because it removed it from the list. Checked Program files to make sure it was all the way gone, and folders remained. Tried to delete them, and was told I didn’t have permissions. Tried to change the name of the Scrivener folder, just to see if I had permissions to do that, and the folder name can be changed, but it still won’t delete.

Am unable to delete any of the files even with Unlocker program. Also have checked everything I can find to give permissions as Admin or even System. Nothing seems to accomplish anything.

Tried the kids’ laptop, running Vista, this morning, and everything went just peachy and works fine. Haven’t had any prior problems installing or uninstalling on the XP system.

Not sure if this is Scrivener or an oddity of my computer, but I’ve installed and uninstalled other programs recently, and uninstalled one tonight just to make sure I could.

Could definitely use some suggestions.

Someone else had problems with their file not downloading completely. Was yours about 45MB? (44.9 or so) If it’s way off, might want to try downloading it again and installing.

Otherwise Lee had this suggestion for someone with a similar issue:

From here: CURRENT BETA DOWNLOAD (RELEASE 1.6 Win + Linux) - #13 by LAP

It’s not just you. Several of us running XP are having this exact same issue.

I too, am a little stumped on this one. I’m not able to duplicate this, and I have tried on several XP machines now?

The only thing that changed on the installer is the granting of read/write/execute control to the ‘Everyone’ role for all the Scrivener folders. This was done to ensure that the Auto-Update function (not yet operational) could do what it needs to when updating.

Scrivener requires Administrator rights by default to install. Which can easily be achieved by right-clicking the installer file and selecting ‘Run as administrator’. However, that doesn’t solve the problem here. There seem to be two issues. Firstly, the install, and secondly on failure the removal of the Scrivener directory.

Let’s tackle the second first.

Next, we need to ensure we have control of the folder we are trying to delete, to do that please follow these instructions:

  1. Log on to the computer with an account that has administrative credentials. If you are running Microsoft Windows XP Home Edition, you must start the computer in safe mode, and then log on with an account that has Administrative rights to have access to the Security tab.
  2. Right-click the folder/file that you want to take ownership of, and then click Properties.
  3. Click the Security tab, and then click OK on the Security message (if one appears).
  4. Click Advanced, and then click the Owner tab.
  5. In the Name list, click your user name, or click Administrator if you are logged in as Administrator, or click the Administrators group. If you want to take ownership of the contents of that folder, select the Replace owner on subcontainers and objects check box.
  6. Click OK, and then click Yes when you receive the following message:
    You do not have permission to read the contents of directory folderName. Do you want to replace the directory permissions with permissions granting you Full Control?
    All permissions will be replaced if you press Yes.
  7. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.

Now you should be able to delete it. Note: The Aspell directory that resides within the Scrivener directory on Windows can’t be deleted if another application (which uses Aspell dlls) is running an example might be Notepad++ - there are lots more. So, close all other applications if you are not sure before attempting to delete. Please back up any .scriv project files that might exist within the Scrivener directory before you try and delete it.

Okay, back to the failing installer due to permissions issue. Firstly, right click on the installer file, go to properties, general tab. It might say “file has come from another computer and is being blocked”. Click the unblock button. Next, go to the Control Panel in XP (From the menu choose , Start, Control
Panel), next choose Add/Remove Programs, then on the left side of the Add/Remove programs window you will see Add/Remove Windows components. Click this and wait a moment, then you can scroll down and locate the IE Enhanced Security component, uncheck it if you can find it and its checked and click next.

Finally, run the installer as admin by right-clicking it and selecting ‘Run as administrator’.

If this doesn’t work then I have absolutely no idea as I can’t reproduce this problem on my plain vanilla XP machines?
Lee
security.PNG

OK, I’ll have to print this out so that I can go through it with everything closed. Some of what you’re suggesting, were things that I tried last night, both as admin and while logged in with the “system” trick.

I’m working on a doozy of a migraine tonight, though, so I think I’ll let it be until tomorrow. Then I should be coherent enough to methodically go through it and document it. (Which is why, if I sound half out of it right now, well, I am.)

Oddly enough, I tried the thing above that garpu mentioned, and it didn’t appear to get me anywhere - the files and program are still not uninstall-able or delete-able, but decided to try and open Scrivener, and now it opens. Haven’t messed with at all to see if it works appropriately or not yet, just discovered that a couple minutes ago.

Oh, and yes, the file was the appropriate size, both times that I downloaded it. After the first install, when I couldn’t get the files in the program folder to go away, I renamed it by adding an “a” on the end, so I could try reinstalling. Second try was a fresh download of the exe, and is what is currently in the Scrivener program file.

And I had reinstalled 1.55 prior to installing, and made sure it was really gone.

Anyways. Headache is getting worse, so I’m giving up for tonight and will follow directions tomorrow.

Unfortuntely, though I was able to remove all the previous installations files, and while I followed the instructions to the letter, upon reinstall I got the same error.

I really think the problem lies in the uninstaller, but I am but a basic user (though after this I do know my Safe Mode much more intimately :smiley: ) and I only base that on being where the installation hangs then errors every single time.

I’m bummed that I won’t be able to use the program now, except on a laptop, especially after it worked so well for so many months. Dare I hope the problem will correct itself before the release?!

Okey dokey. Headache mostly gone, and here are details.

Followed LAP’s instructions 1-7 in safe mode, and got the folders removed that needed to go. It was that last step, 7, the re-applying them again immediately, that I hadn’t done prior - and that was what worked to finally remove them.

Redownloaded on my administrator user. File is the correct size.

Right-clicked on properties, and yes, it was blocked. Unblocked it.

Did not have the IE Security component, so couldn’t do anything with that.

Ran the install as administrator. This time, the install went much faster then before, and actually did part of the installing the uninstaller part.

This is where it got stuck:

So I clicked on ok, and then tried going through the start menu to open Scrivener. This is what I got:

Then I tried going into program files and starting it from there. Got the following:

Tried going in and changing settings under security on the scrivener.exe files, the whole folder, in various combinations, and checking to see if it would work in between. (While I was still on the administrator user.)

[size=200]This is the one that worked.[/size]

It had to have that checkbox (Inherit the parent…) underneath marked and applied. Everything had full control, and it was the only thing I hadn’t tried, and I was hesitant to try it since I didn’t know what it did.

But that when I applied it with that checked, the next time I tried Scrivener, it opened right up. It works from the start menu shortcut, it works from the exe file in the Scrivener folder, and it works even on the other users on the computer.

Seems to be just fine, and my projects are opening and behaving - only thing I haven’t tried is the uninstall. But since I now know they’ll be removable in safe mode, at least I have a way to get them off when it’s time for the next version.

I don’t know enough to guess at what’s wrong, but I sort of suspect that some little file inside there has something weird with its permissions… and that when I finally tried that last checkbox, that was the one that allowed it to be changed.

Now, I’m gonna go try to uninstall, just to see what I get now. Even if I break it, at least I’ll know how to fix it again.

And if there’s something I can do to help you find out just what it’s hanging up on during the install process, let me know. (Is there some program or something that can watch it as it installs and report exactly what it does and where it stops?)

[quote=“vientorose”]
Okey dokey. Headache mostly gone, and here are details.

Tried going in and changing settings under security on the scrivener.exe files, the whole folder, in various combinations, and checking to see if it would work in between. (While I was still on the administrator user.)

It had to have that checkbox (Inherit the parent…) underneath marked and applied. Everything had full control, and it was the only thing I hadn’t tried, and I was hesitant to try it since I didn’t know what it did.

But that when I applied it with that checked, the next time I tried Scrivener, it opened right up. quote]

Glad your headache is gone. Can you tell me exactly which files/folders you applied that permission change on before/when it worked? I tried to follow your instructions, and I know I got close because the Scrivener icon on the desktop and in the folder changed to what it is supposed to look like (before it was just this default Windows .exe icon) but the program still wouldn’t run.

Did you change the permissions on all the files in the scrivener folder or just the folders? Did you change the ownership prior to checking the Inherit Parent box in the Permissions tab?
Thanks for your help!

My icon did the same thing - forgot to mention that.

I unblocked the file per LAP’s instructions before installing.

Then when it still wouldn’t run, I went into Program files, made sure all the owner settings were full control - I think all of mine already were, I don’t think I changed anything there. I can go do it again to doublecheck, but I have an article due today, so it’ll have to wait til after that. Might not be til tonight that I get to it.

It’s possible I changed something in there, because I was making sure that all the “everyone” spots said “full control”.

That was when I discovered that checkbox I showed - it was unchecked, and I ignored it a couple of times, since I wasn’t sure what it did - but it sounded like it forced all the ones under it to do the same. I’d already tried the Scrivener folder with the other full control settings, and it hadn’t worked, and I’d tried it on the Aspell folder, because a couple times when I was trying to delete, I got messages that mentioned it. (Though that was likely because it was the first in alphabetical order, I figure.)

But when it worked, it was just the main Scrivener folder under Program Files - I’d just tried it right before that, and no dice, and then I changed that, and it worked. It was like something down in the folders hadn’t let loose of control, and that one finally got it.

But after I get this article done later today, I’ll go back in and repeat what I did, see if I go straight to that step if it works, etc.

Thanks SO much! Am so hoping I can get mine to work! I’ll wait for your post. Good luck with the article! :smiley:

I have updated a new installer that should behave itself permission wise and not cause any problems. What I changed in this installer is I have allowed ‘generic_all’ permissions to all Scrivener files and folders instead of defining them explicitly i.e. file_read_data file_write_data file_execute etc… I also use a recursive routine to set these permissions now rather than explicitly as well. I also changed from using ‘Everyone’ to a SID setting, principally SID: S-1-2-0 i.e. a group that includes all users who have logged on locally. Apparently, Microsoft prefer this. So, that’s probably a whole bunch of gobbledygook to most of you.

So, I would recommend downloading the new installer. I would try to completely delete the existing Scrivener directory first after you backup any projects files that might be in there?

If you are not able to delete the folder simply install to a new folder i.e. instead of c:\Program Files\Scrivener install to c:\Program Files\ScrivenerBeta

The old directory can be removed later and possibly with a tool as danwdoo suggests:
http://www.revouninstaller.com/ - although I have not tried this myself.

The installer has been compressed a little more and the full download size is approx 40.6MB.

Lee

http://www.literatureandlatte.com/scrivenerforwindows/Scrivener-1.6-installer.exe

Didn’t mean to disappear on you. The migraine came back, then got nailed with deadlines and illness at pretty much the same time.

Thank you. I’d definitely call it solved - that seems to have taken care of the problem - it happily installed and will uninstall properly now.

And I’m back to quietly enjoying Scrivener and getting lots of work done!

Thanks again. Scrivener is right up there at the top 2-3 reasons I’ve been super productive the last couple months, and I’m really appreciating it, more then I can find words to express.

(And given how much I talk and write, that’s saying a lot.) :slight_smile: