iOS Scrivener projects: Recent, Bookmarks -> crash

I was recently fiddling with Scrivener for iOS on my phone, and when I tapped “Recent”, it immediately exited out of Scrivener, back to my home screen. Same for Bookmarks. It seems fine when I select anything from the binder.

The problem doesn’t occur on a brand new project that I just created and synced via dropbox, though I don’t have my Mac at hand to try editing and syncing back.

Specs: iPhone 13 mini, iOS 15.3.1

1 Like

Same here
with one project i am working on my macbook, ipad and iphone: Recent (Aktuell) and Bookmarks (Lesezeichen) kick me out of the app on iphone (6s plus ios 15.3) No problem on the ipad.

Hmm. I haven’t had any trouble with Scrivener on an iPad Air 4 either. That you both are seeing this on iPhones might or not indicate some issue with memory; Apple’s always a bit closed-mouth about RAM sizes, if one would suspect an iPhone 13 would close or the same as current iPad.

What I have noticed, though, is that iOS/iPadOS 15 has not been the most stable. I regularly have troubles with other apps, even or especially Google News.

What I do about this, and what may help you, would be in two methods.

  • you can fully power down and reboot your device. I am not talking about a ‘force quit’, as I have some evidence this doesn’t lead to best health, so that I’ve had to fully clear and restore iPads later. How you power off is different on different phones or iPads, so you can get Apple instructions via Google for this.

It will be simple, and again, just the power-down is what you want. It takes about a minute for the device to start up again after – you I think universallly hold down the power button maybe five seconds, until an applle icon appears on the screen, and then it is busy coming up.

  • the other tactic is to clear your app’s state entirely. You do this by removing the app, and then downloading it again. Clearing all the app’s immediate data and caches is a side effect of removal-restoring, and it shouldn’t affect your files information- the Scrivener projects in this case.

Why should you need to do any of these things? Again, it’s not my impression that the latest iOS family is entirely stable. The problems may have to do with wifi to some extent as I may be experiencing them, or just basis and memory stabilitty, but they do affect apps, causing freezes for example.

It’s a little surprsing, but Apple also in time loses the originators who fully understand things, and needs for fresh programmers to learn enough of what they knew, of which there’s some feeling is happening in these times.

This sounds like this report, which seems to be iPhone specific. We’ve reproduced it and have it on the list, if so.

Edit: the link above is to a different issue.

1 Like

I’m not using any search functions to trigger this bug, so I don’t understand how the crashes could be related. I haven’t even been using Scrivener on iOS for several weeks.

I tried a reboot, and the crash persisted when I used Recent on some of my projects, so I deleted the app and re-downloaded it. Oddly, I didn’t get any prompt about preserving the app settings, but after downloading Scrivener again, it remembered my Dropbox credentials (it did not remember my custom folder, defaulting to Apps/Scrivener).

I thought for a moment that maybe the document histories were too long on my older projects, but then why would tapping on “Bookmarks” cause a crash too? I added one to my test project, and still have no issues navigating it.

Oops, I grabbed the wrong link! The report we have on file was actually sent to the support queue so I can’t link to that. But in reviewing that thread, I see there should be a fairly good workaround if you don’t mind compromising one of the following settings:

  1. Navigate into any folder in the project to access full binder
  2. Tap on the Gear button and disable either:
    • “Compact” at the top level.
    • Or “Show Synopses” in the Binder subsection.

The combination of these two settings is what causes the crash, the last time I tested this. If the situation has changed let me know.

I disabled Show Synopses, and that worked, but I didn’t have Compact enabled in the first place.

Notably, if I have Compact enabled, with Show Synopses also enabled, everything works. But if I disable Compact while I have Show Synopses enabled, the crash occurs.

Also, I just confirmed that a brand new project with only 1 document crashes if I have Compact turned off while I have Show Synopses turned on and try to use the Recents or Bookmarks shortcuts at the top. So it’s nothing to do with the size or age of a project.

1 Like

Great, thanks for the update. I’ll get these notes added to the report as it seems iOS conditions have changed.

And yes, in my testing I could reproduce the problem in a blank project that had not had any content added to it yet.

great troubleshooting, you guys…