iOS sync with Windows Dropbox issues

Here’s what I ran into this morning trying to get things up before I got to work.


  • Upgraded Scrivener on my windows PC to the latest version. My scrivener folder (where the projects are saved, not where it’s installed) on the PC is been {home}/My Dropbox/Scrivener


  • Installed Scrivener on my iPad (WOOHOO)
  • Told it to sync with dropbox. When prompted, I told it to use the Scrivener Folder.
  • Tried to open a project, was told that the project was from an older version of Scrivener and to upgrade it.
  • Opened a few projects on the PC, let them convert the projects.
  • Went back to the ipad, attempted to open the projects again, same error (older version of Scrivener, plz update)
  • Looked on the forums, saw the suggestion to use the Dropbox/apps/Scrivener folder.
  • I changed the settings on the iPad to use that folder.
  • Copied a project directory from the original folder on Dropbox to the Dropbox/apps/Scrivener folder. When I attempted to open the project, same error.


  • Create a new project on the iPad.
  • Open the new project and the project I want to work on on the PC.
  • On windows, drag the contents of the binder from the PC project to the iPad project. At that point, everything worked.

Would it be possible to send in a smaller project that isn’t working, so that we can take a look at it? If you can send one that hasn’t been updated yet, that would be best, so that we can get a full picture from start to finish.

I’m not sure this is exactly the same thing, but I made two projects on iOS yesterday, opened them in Windows this morning, and now they won’t open on iOS. However, the project I made on the Windows machine a while back opens up fine :-/

The argument from the iOS software is that the to projects were created by older version. The same version that made the project it WILL open, btw.

Did you do any actual editing in the project, so they were really converted, updated and saved in the new format?

It looks like these iOS project are missing .scriv files when I look from Windows. But they open from the iPad just fine.

Can I guess that the iOS version doesn’t require the scriv file but the Windows version does?

No, the iOS version reads the exact same files that the Win and Mac versions do.

But have you updated the Win version of Scivener to the latest version? Otherwise it won’t work.

In the Windows file system, a Scrivener project is and appears as a folder (name ending in .scriv), containing subfolders and numerous files (including the project’s index file (name ends in .scrivx)). So there is no .scriv file. One launches/opens a Scrivener project via the .scrivx file found inside the .scriv folder. The same holds true on Mac OS X, though OS X hides the details behind the scenes and presents the project’s .scriv folder and contents to the user as though they are a single thing.

Thank you for spelling that out. My confusion came from the fact that the iOS projects don’t seem to have .scriv or .scrivx anywhere. So I was trying to figure out how they made themselves available to the windows client - since mine aren’t.

But it’s stating to come together. I had to throw a few projects away, but they were either old, and expendable, or new and relatively empty. One important project was for a writing bootcamp I’m in right now, but I was able to reload most of that from iawriter, which I was using the first few days. The other important one was made on Mac, and used on Windows, and had a collection of writing prompts and advice and such. Those pages all seem to be blank, but I think it may have been because I saved it as a template at some point.

It’s all a bit confusing, since I haven’t approached it from a sensible troubleshooting methodology. Two reasons for that: 1) I did that for a living for 30 years and I didn’t feel like doing it this time :wink: and 2) I’m doing this writer’s Bootcamp. Busy. Tired. A little resentful that the quick move from iawriter to scrivener on my iPad didn’t happen magically :wink:

A week from now, I’ll have the time to gather data in a responsible way – or I’ll have a new version of scrivener on my iPad that makes it all go away :slight_smile:

Now to procrastinate from this story I’m supposed to write. I’ll start by trying to find all those writing prompts I lost.


I hope it’s OK to just highjack this thread.
I don’t seem to have the exact same problem, but still a serious syncing issue.

Latest Scrivener WIN version
Latest Scrivener iOS version
Projects are in the new format (WIN).

As long as I don’t open a project in the WIN version syncing works fine (standard settings suggested by iOS app).
As soon as I open a project in win (not even making any changes), I get the following error message in the iOS app:

Sync failed
An error occured when trying to
create a local directory. Error: The file
“Files” doesn’t exist. (The file doesn’t exist.)

Again: This ONLY applies to projects touched under WIN.
And there is no difference, if this project was initially created under the WIN version or the app.
A freshly created project in the WIN version will sync - once. I can open it in the app.
After touching it a second time in the WIN version, though - ERROR.

Any ideas?

Hmm… So I should be opening a new thread? :question:

Not necessarily, but you should explain in detail, step by step, exactly what it is you are doing. All the steps leading up to the screen you have posted.

To be honest, I wouldn’t know what else to explain.
I would have expected that someone phrasing this error message would know under which circumstances it may appear.
I’m a user not a programmer. I installed everything according to the instructions, use both, the app and the windows program as recommended, only use default settings. Dropbox has always been working fine and syncing seems to work well in one direction from the iOS app to the windows computer, but not the other way around.

Which versions of software, as a start.

Secondly, describe exactly what you do and did, not just that you “followed instructions”. A common cause for problems is that people actually don’t follow the instructions, although they think they do.

So which Wn version?
Where do you save the project? Did you only Save or do something else?

On iDevice, did you set up Scrivener to use the same Dropbox folder?
Did you do anything else, out of the ordinary?

Did you wait for the Dropbox app on your PC to upload to the dropbox server? And after having edited on the iDevice, did you wait for the PC to download changes from the dropbox server?

Thanks for the explanation.
I approached it in a different way:
Change one thing at a time and see, what happens.
Turned out that using the default folder “/Apps/Scrivener” doesn’t work and causes this problem for me.
I had to change to “/Scriverener” manually - all works now :smiley:

Good! Happy writing!