Is it possible to have one document between several projects?

(I tried searching but my search-fu might leave much to be desired.)

I have one research paper that is relevant to two projects.

However, I want to be able to update the one paper in one project and have it auto-magically update in the other project.

Is this possible or nah?

The include tag might be what you are looking for…

literatureandlatte.com/foru … 96#p243196

If it’s just research and you’re not trying to compile it, you might try leaving it as an external file and using File > Import > Research Files as Alias… in both projects. That ought to leave you with a single copy on your hard drive (external to BOTH projects) and a link in each project to it.

“If it’s just research and you’re not trying to compile it,”

What do you mean compile it? (That sounds like something beyond what I am trying to do :slight_smile:

Essentially, I have one document that I need to reference on two projects. But I am constantly updating that one document within one project within Scrivener. I would just like it to update it in the other project as well at the same exact time.

I do have both projects open at the same time.

In other words:

Compile is one of the core features of Scrivener - if you haven’t been through the tutorial yet, I recommend you do so, to familiarise yourself with Scrivener’s main features. “Compile” takes everything in the Draft folder and exports or prints it as a single, formatted document.

It is not possible to share a document between projects like this. The only way of using the same text in two projects would be to store it externally, such as in an RTF document, and then use the <$include> tag to include it in your final document when you come to Compile (see Help > List of All Placeholders…). This is what Joro was referring to.

All the best,
Keith

EDIT: Keith has said this much more eloquently.

You say you “reference” it. Is it intended to be part of your final output? Or is it a research document which you cite, as in a footnote, and refer to while writing? My method works for documents which WON’T be part of the final output.

(BTW, “compiling” in Scrivener is the means by which a final, finished document is printed or exported. You’ll find it under the File menu.)

If what you want is for the document to be part of the final output, then the <$include> tag method is what you want, but I’ve never tried to use it between two separate projects. The sections in the manual that deal with this are 10.1.5 Including Text From Other Documents, and 10.1.6, External Links.

Hope this helps!

Thanks for this pointers. Note that <$include:filename> works only when the filename is in draft folder. The hard linking approach by selecting <$include> and pointing to the file works even if the file is in research folder. I use Scrivener for writing but not book writing and all my work is in Research folder. I just compile what want by selecting multiple documents. Worth mentioning in Scrivener manual 10.1.5

-Kasey

My use case requires me to see this <$include> section before compiling. Is there any way to trigger it? Especially, I want to see the expanded text in composition mode. I really need this capability for my use case. I hope that there is a way. Thank you!

Is only one $include allowed per document? I am unable to get more than one $include to work. It picks either the first or the second $include.

my example is:

Lab Metadata:
Hands-on Lab ID = HCC-GCP-Lab-1XXX
Difficulty Level = 65
Version 1.0

Topic:
Operations

Objective:
How to enable serial port based out of band login for a Compute instances in GCP?

<$INCLUDE:inc-lab-approach>

High Level Steps:
• Login to the GCP Console at console.cloud.google.com.

• Well Done!
• Reminder to watch the video of this lab.
• <$INCLUDE:inc-lab-cleanup>

Screenshots for this Lab (if any):

<$INCLUDE:inc-lab-tail>

<$INCLUDE:inc-lab-links>

Waiting on any input to my last question. Appreciate any pointers. Is it a limitation that only one $include:filename can be there in a file? More than one $include: does not seem to work. I tried 40 different combinations and conclude that only one $include: works, generally the first one.

any help?

Looks like this has been reported as a bug, and accepted as such:

[url]https://forum.literatureandlatte.com/t/include-tag-processing/41820/1]

Thank you @Silverdragon.

-Kasey