Is there a way to change the fonts on the entire tree?

I tried merging the docs (by selecting the top one), select all, and change the font, but the changes do not propagate.

Not at my Windows machine at the moment, but you need to get to the Settings/Options panel, then select the Formatting tab of that pop-up window. Change how the sample text is formatted in that window, and all new documents will conform to that setting. Then select each/all of the existing documents in the binder that you want to change, and select Documents->Convert->Formatting to Default Text style.

Thanks, that worked.

surprisingly, this worked on linux.
On windows, if I right-click the draft (top node) it crashes.
Never expected the (paid) windows version to be less stable than linux (free)