Issues with automatic Switching between screenplay elements

When I’m using the Screenplay templet the automatic switching between elements such as Scene Heading to Action or Dialogue to Action by hitting Return or Tab occasionally gets jumbled.

For example: I’m typing dialogue within the Dialogue element and hit return. The cursor is supposed to go to Action according to the settings in the Script Settings box and most of the time it does. But sometimes the cursor goes to Character or some other element instead.

I could hit Tab within the Action element and expect the cursor to go to Character but instead it goes to another Action line. Once it starts picking the wrong element I have to restart Scrivener to set it straight. Note that nothing has been changed in the Script Settings box.

I have also noticed that Scrivener forgets locations in Scene Headings and also Character names. I could be typing a scene with a bunch of characters talking and suddenly one or two character names are missing in the automatic suggestions box. I have to type them manually or restart Scrivener to correct the problem.

My writing sessions are usually four hours and during a session I end up restarting Scrivener five to seven times to fix these issues.

I have Scrivener version 2.1 on a MacBook Pro 2011 running Lion (10.7.2).


I’ve never seen these issues and no one else has ever reported anything like this. Could you please let me know the steps I need to take to reproduce any of the problems? Next time it happens, try and note down anything you can think of that led up to the behaviour. There’s nothing in the code that I can think of that could cause any of this - the next element is determined by a strict set of rules based on formatting and the script settings, so unless you changed the formatting manually, it should always be consistent. So without some way of reproducing this so that I can see where things are going wrong for myself, it’s a little difficult to guess what is going on, I’m afraid.

Thanks and all the best,

Hi Keith,

I’m not doing anything out of the ordinary. I’m just typing away on the screenplay when it happens. Usually it happens when I hit return after a Character name to go to the Dialogue element. Instead the cursor goes to another Character element. If I step back and delete the new Character element and hit return again it still goes to a new Character element. At that point I manually change the element to Dialogue just to get the line out of my head. Then I restart Scrivener and it’s all working fine again. However, if I don’t restart Scrivener the problem will persist and continue to mix up other element switchings as well.

When it comes to forgotten scene headings and character names it goes something like this: I have written several scenes that take place in Helen’s house with these headings


It’s all working well and I’m typing away. Every time I type an “H” after INT. Scrivener automatically suggests the above four alternatives. Then I leave Helen’s house and write scenes that take place somewhere else. Maybe a day or so later I return to Helen’s house and type: INT. H but then Scrivener only suggests these two:


I end up typing the location manually. This problem is far less frequent than the automatic switching issue and only happens once or twice in a seven day period.

I haven’t changed any settings or anything. I’ve only been typing away as usual. It normally happens when Scrivener has been running for awhile and I’ve been typing several pages. But I always shut down the computer at the end of the day so Scrivener is always starting fresh every morning.

This particular project I’m working on is an adaptation of a novel. So I’m working with a split editor with the screenplay in one window and the novel in another window side by side. And I have both the binder and the Inspector open all the time.

Adapting a novel with Scrivener is BTW almost a religious experience. :slight_smile: The author gave me the novel in MS Word format and Scrivener imported it and split it perfectly in chapters and sequences. The broken down novel resides in its own folder outside of the Screenplay folder next to the research folder. I then outlined the screenplay and linked each sequence and scene to its corresponding page in the novel. That way I have access to the right information as I type. I can rearrange the scenes in the Screenplay without losing the connection to the pages in the novel. This is fantastic! Thanks for creating an application like Scrivener.

Lastly, I’m a director who writes so I don’t live in Scrivener every day of the year. I bought it last Christmas because I needed a smart way to restructure a screenplay written in Movie Magic Screenwriter. That worked really well and I was able to do the job twice as fast thanks to Scrivener. After finishing that one in February I haven’t written anything until now. I can’t recall having any issues like these back on that project, though. But then again, most of the work was rearranging scenes and rewriting them not massive typing from scratch like now. Also, it was Scrivener 2.0 on a MacBook Pro 2010 running Snow Leopard opposed to the current configuration of Scrivener 2.1 on a MacBook pro 2011 running Lion.

I installed 2.2 last night. But if you haven’t heard about these issues before I doubt the new version will make a difference. But I will of course report back.

I was reluctant at first to report this because I’m in the middle of writing and don’t really have time to troubleshoot anything. But then it started to become annoying so I figured I had to report it. Since I haven’t changed any settings and it happens intermittently while typing normally I figure it must be a bug. I don’t know what else I can say. I hope this information can help shed some light on the issue.


Hi Jack,

First, thanks for the kind words - it’s great to hear that Scrivener is helping with a project like this.

You’re right that it’s unlikely that 2.2 will make a difference, and I have to admit I’m a bit stumped as I don’t even know where to start with this one. When Scrivener selects which phrases to auto-suggest, for instance, the code doesn’t change, so if the list is there then it should be showing the same thing each time. Next time it happens, try going to Project > Auto-Complete List and see if the items are available there.

With regard to elements suddenly not working, it can occasionally happen that the cursor doesn’t look like it’s in the right place, but as soon as you start typing it snaps to the right place - this is an oddity of the OS X text system - so what happens if you just start typing even though it looks wrong?

One thought that has suddenly occurred to me - could it just be that you are accidentally switching out of script mode, for instance by catching the cmd-8 combination? If you switched out of script mode, then hitting return would cause the formatting to stay as it was for the last line, and the auto-complete list might be different because it would no longer show items set up for scene headings in script mode. That would be the most logical explanation, but then restarting Scrivener shouldn’t bump you back into script mode. It’s worth a try though - next time it happens, double-check that the footer bar is definitely showing the script mode elements (and not the word and character count), if you haven’t already checked this.

Thanks again and all the best,

I’m one hundred percent certain that I’m not being bumped out of screenplay mode. All the elements are still in place and I use the footer bar to change the elements manually when the automatic switching fails. But I will pay close attention from now on and try to log exactly what happens. And if the cursor ends up in the wrong element I will just start typing to see what happens. I will also check the project auto complete list next time I’m missing a scene heading or character name.

Have a great weekend!

Oh well, I was hopeful for a moment at least.
Thanks, and have a great weekend yourself!
All the best,

My latest observations:

It turns out that not all Scene Headings and Character names are automatically saved in the Auto-Complete list. I tested it specifically this weekend. As I worked, I typed six new locations and when I checked the auto-complete list, two were missing.

When it comes to the automatic switching between elements issue, it seems to be isolated to the Character element. When the error reoccurred yesterday I did the following test:

I’m in the Character element and hit return, the cursor goes to a new Character element instead of a Dialogue element. I start typing and it shows that the cursor really is in a new Character element. I delete the new Character element, go back to the end of the original Character element and hit return again. It still goes to a new Character element. So it’s really stuck there.

But instead of changing the element manually and restarting Scrivener as I’ve done before, I delete the new Character element and back-step to the end of the original Character element. This time I hit Tab and the cursor correctly goes to Parenthetical. I delete the Parenthetical element and step back to the end of the Character element and hit return. This time the cursor correctly goes to the Dialogue element and I can continue working without restarting Scrivener.

I have not experienced any Switching errors between other elements in a while so I think those errors only manifested after I manually corrected the error without restarting. In other words, if I don’t restart or go to Parenthetical to get out of the hang, the problem seems to spread to other elements but they never originate in those elements. At least as far as I can tell.

So the error seems to originate exclusively in the Character element and the good news is that I can now get out of the hang without restarting Scrivener which saves time. The bad news is that the issue is still there and I get these hangs several times a day.


Could it be that you are catching the Control key at all while hitting return? That would cause the element not to change.

Have you modified your script settings at all?

I still can’t reproduce any of this, and we have hundreds if not thousands of scriptwriters using Scrivener, and no one else has ever reported anything like this, so I’m still baffled and reaching in the dark, I’m afraid.

Thanks and all the best,

I just tried that and no that’s not what happens. When I press the control key and hit return the cursor does indeed stay in the character element but it only moves to the next line whereas when the problem occurs the cursor jumps down two lines. Also, after having pressed control and hit return I can just back up and hit return again and the cursor will go to the correct dialogue element whereas when the problem occurs the only way to get unstuck is to do the Parenthetical trick or restart.

And, no, I have not modified the script settings.

Could I have hit any other key by mistake that could have caused this type of behavior? I would think, though, that if I accidentally caught another key it wouldn’t get stuck in that behavior and it wouldn’t cause other element switchings to fail either.

I understand that it might be difficult to reproduce this problem unless you sit down and write a screenplay from scratch :slight_smile: and I do not expect you to find a solution for it right away. I can still write and do the Parenthetical trick when the problem occurs. Maybe others have experienced this but not reported it. Who knows…


UPDATE: I just remembered that I actually have changed the script settings. Under Character I changed Tabbing on an empty line to Go to SHOT. I did that when I first set up the project. But that seems irrelevant in this case because the cursor never goes to shot. That is unless the act of changing a setting in the script settings box triggers an underlying problem.

Hi Keith,

I realise that this is a fairly old thread now, but I’ve just started a new screenplay project and I’m having exactly the same problems with the CHARACTER issue as reported by Jack.

I definitely haven’t changed any script settings (I didn’t even know that you could) so I’m using it in “out of the box” mode on a brand new Mac Book Air 13" with Mac OS X 10.7.2.

One thing that I have noticed though is that when I start getting this problem, if I create a new page then the problem does’t occur there (immediately, but may do after a while) but the original page does still have the problem. Restarting Scrivener makes it go away, but after about half an hour or so it starts occurring again.

I haven’t noticed the problem with headings, but I currently only have a couple of locations, but I’ll keep n eye open for it.


Hi Alan,

Turning off Typewriter Scrolling seems to have solved it for me.

Format→Options→Typewriter Scrolling

I say it seems to have solved it because I tried it at the end of working on the project in Scrivener, just as I was migrating the script to Movie Magic Screenwriter, so I never got to do a thorough testing of it. It seems to do the trick, though. Please let me know if it works for you.


Hi Jack,

Thanks for this. I don’t actually have typewriter scrolling turned on, but I’ll try activating it for a while to see if there is any noticeable difference.


Hm… I suppose it can’t be it then. Although I know how frustrating it is I’m still glad you’re experiencing the same thing because I was starting to feel lonely having this issue… It was actually a relief to move the project to MMS where typing became easy and rock solid. I love Scrivener, though, and I hope there will be a solution for this soon.


You’re not alone. I have the same problem. It’s gotten so frustrating, I just write in another text editor where I won’t be interrupted every time I switch from CHARACTER to DIALOGUE, then format in scrivener later. When I emailed a developer last year, they said I was putting an extra space (two) after inputting CHARACTER and to turn on “show formatting” so I could see my spaces. A lot of work for a work around. Fingers crossed that they find and fix this because it’s really a hair-pulling experience to stop and backspace your way back to the CHARACTER ELEMENT when it bumps to something other than DIALOGUE.

The developer, not a developer. :slight_smile: And I recall our conversation. Unfortunately, you seem to be blaming Scrivener for something that you were doing with your typing, so there’s nothing to fix, and I was under the impression from the end of our exchange last year that you were happy with the answers and support you had received, so I’m a little surprised by your comment.

In your case, you had a couple of extra spaces at the end of your CHARACTER line but had the cursor before those spaces. So, if you hit return, you weren’t creating a new line but were pushing those spaces down onto the next line; that is, breaking up the text in an existing line. It is standard in screenwriting software that if you hit return in the middle of a line, the text moved onto the next line uses the current element, and so this is what was happening to you. This is not a bug, and I’m not sure why you would see it as one; it is very unusual to accidentally type two spaces and move the cursor back before them consistently, so I suggested to turn on “Show Invisibles” so that you could spot yourself doing this and work out when and how it was going on. If there were some bug where Scrivener was somehow creating those spaces itself, I could understand your frustration; likewise, if there were some bug here I would be chasing it down. But it seems a little strange to me to expect software to try to work around mistakes you make while typing; that would involve Scrivener somehow reading your mind or having human-level knowledge of intention.

That said, if anyone is having problems with screenplay elements not sticking and it’s not because they have extra characters at the end of the line, do write to us at AT literatureandlatte DOT com so that we can help you find out what is going on.

Thanks and all the best,

Yeah, it’s probably just me…

(odd that I don’t have this problem in other screenwriting apps)

I ran into this problem myself when I first started writing my script in Scrivener. Having found this thread helped fixed the issue for me, but here are my notes on it for anyone else that’s having this problem.

First off, I think all parties happen to be correct about this, meaning there is a slight difference between how Final Draft and Scrivener happen to handle the situation that causes this issue for people – just like there are other differences between the two softwares. If you’re used to writing in FD this will seem like a bug the first time you encounter it. But as soon as you develop Scrivener typing habits as opposed to FD typing habits, the problem goes away. Meaning, as KB described it, if you have a space after your cursor in Character mode, and hit enter, it will go to a Character as opposed to Dialog. It’s true that FD won’t do this, but FD handles text formatting and format tagging differently, and it has its own little quirks that take getting used to. When I first started using FD I used to think the switching between elements were buggy too, until I developed my FD typing habits.

So, my solution is twofold.

  1. Turn on invisibles for the first few pages of your first Scrivener script so that you develop optimal Sciv typing habits (much like you developed optional FD typing habits before)
  2. Once you’re in the script, your auto complete will fill most of your character names anyway, so this problem will disappear, until you use a new character and you happen to have a space after your cursor – I think the space happens due to how we edit, move cursors around, delete actions then going into characters etc. as part of the writing process. However, once you know the cause, it’s a very easy habit to fix.