Italic not preserved after compiling

I have waited to ask this question because I think there must be an easy way to do this. But I have tried for a long time now, and I can’t seem to find the right settings for my manuscript to be compiled and the italic formatting to be preserved.

I use fonts like TNR, Georgia and other popular fonts, but the italic formatting changes to normal font after compiling, both in pdf and word-format.

Does anyoe have a tip og an idea to what I must do to fix this?

I’m using the latest version of Scrivener 3 for Windows.

If it’s only for a few sections of italics then highlight it in the Editor and go to Format ▸ Preserve Formatting. That will prevent the Compiler from changing any of the formatting. You could also use a character style instead of just italicising, that may work, depending on the compile settings.

I don’t understand why, if:

  • no specific styles are defined
  • the text in the editor is in italic
  • the italic is set in the layout panel of the project format with “override text and formatting”
    the pdf still comes out without italic.

The preserve format is not an option for me as I would like the compilation to change the font and line ident…

Thanks for your help :slight_smile:

OK, I’ve managed to see that, if the text in the editor is in italic and that I use “override text and formatting” and also select italic in the layout editor, the italic disappear on compile.
That’s a bit weird, isn’t it?
Is it the correct supposed behavior?

Which compile format are you using under Format As? Some will preserve the italics and some might replace with underling. Try just compiling to preview with a few of the default formats to see which preserve the italics, and then make an changes to create a custom setting from there.

I made a custom one several years ago, which I keep tweaking over time.
Have you got any idea why the italics are preserved with “override” only if I don’t check Italic in the layout format panel?

I think because the software is set to preserve italics as occasional instances, for emphasis. However, if I set the formatting override to italics for all the text I still get italics for everything, so it’s odd that isn’t working for you. If you email with screenshots and exact details of what you are are doing and how your text is formatted then we can go into further detail and perhaps take a look at a copy of the project.

OK, will do asap :slight_smile:

Oh, sorry, I replied to this topic about italics without seeing that it was a Scrivener for Windows post.
I actually work on Mac.
Is there a different address I can send the details of what happens for me?