Italics in MOBI files?

Hi all,

Trying to compile a MOBI file for Kindle and all of my italics go away.
Am I doing something wrong, or does Kindle not do italics?


The Kindle should be handling italics just fine, and there also shouldn’t be a problem getting them from Scrivener into the .mobi file. What is most likely the case is that you’re converting the font to something that doesn’t feature italics, in the Formatting compile option pane. Even though font family specification for most e-readers isn’t practical (most just ignore it and use the reader’s personal font settings), if the font you are using doesn’t have italics, as part of the output process it will result in them being lost. So check the Formatting pane, and click on anything in that top section that has a checkmark in the Text column. For each one, click into the mock text editor and check the font. Make sure it has an italic variant in the font selector. Since it doesn’t really matter what font you choose here, just setting it to Times New Roman is fine.

Thanks AmberV, but…

I haven’t got a clue what most of that meant. LOL

So far, I think that the ‘formatting pane’ is the thing that comes up when I hit the compile button and click ‘formatting’ under ‘compilation options’.

When I do that, I get the screen on the left with the different ‘level’ sections.
On one of those levels there is a ‘text’ column - one of the lines is checked.
When I click on the page icon for the line that’s checked, I get grayed-out text in the lower window.
I can’t find the ‘font selector’ or anything that talks about fonts.

Am I even close?


You’re in the right place, but it doesn’t sound like my guess about what the problem might be is accurate. That checkbox at the top, above the list of levels and icons, sounds like it is off, which means that no format override is happening and the font you have in your editor is the font you are using to compile. If you had that checkbox turned on, then the compiler could change the font for your whole manuscript for you, that is what it is for. It was my guess that it was doing that, but to a font that didn’t have italics.

Obviously, since that is off, and the mock editor area below is grey, that isn’t happening. And obviously you’ve managed to use italics in the editor. If you were using a font that couldn’t express italics then you would have noticed that a long time ago.

So I’m not sure what the problem is. What I would try is make a new blank project on your desktop or somewhere temporary, just type in a test line in the Untitled document, with some italic words. Then compile that to .mobi. Does it work?

figured it out!!!

when I’m editing I use Helvetica light
for some reason the light oblique isn’t recognized.
when I switch to regular Helvetica oblique the problem goes away.

Thanks for the help!

I need to learn how to use this software properly ;o)

Ah, that’s good to know. Oblique is basically a “cheap” form of italics, where the font is just slanted instead of styled to be slanted, if that makes sense. The Kindle devices have true italics, so the oblique declaration wouldn’t be known to them. Glad you got it sorted.