[JH] 2904 under Crossover on Mac and Footnotes

Hi Gang,

I installed the 32-bit and 64-bit versions of 2904 under CrossOver 17. Both installed and opened seemingly without problem. I opened my test project, which contains a chunk of 红楼梦, (The Dream of Red Mansions/Dream of the Red Chamber) with basic footnotes entered on Mac v. 3 using the footnote marker. They appeared correctly. However:

  1. it seems that you have removed the option to use a footnote marker instead of a highlight from 2904; it was there in earlier betas but I can’t find the option in 2904 … pity. There was a problem with it in the earlier versions, because Chinese doesn’t use spaces between characters—on the Mac the solution is to put a space in the marker following the * or whatever glyph one might prefer; the space is removed along with the glyph when the marker is replaced by the footnote number. This works when opened in the Windows betas, but I didn’t get round to trying to set the footnote marker similarly in Windows 3.

  2. The 32-bit version of 2904 exited cleanly, but the 64-bit version threw an exception as soon as I clicked on “Exit”. I attach the backtrace:

20180402 64-bit backtrace.txt (32.4 KB)

Apart from that, I think the whole UI looks much cleaner than before … I hope that’s not just me having a senile moment! :smiley:

Cheers
Mark

Hi Mark - The footnote marker option is still there, under Project Settings > Formatting, but it’s not implemented yet, just in the UI. I’ll put a note in the change list once we have this really working.

Regarding the exit error, is that specific to the particular project or any project with such footnotes, or are you just getting this error every time you close the 64-bit version, regardless of what was open? I think this is still just a Crossover issue, so not something we really can do much about, but it’d be good to know.

Hi MM,

I haven’t opened it since I posted as I was waiting for a reply and have more than enough to keep me out of mischief all the time. :smiley:

I haven’t got time to check today, but will do as soon as I have a moment. As one of the first things I do with new software is spend a good amount of time going through all the menus and any dialogs/panes that open from a menu click, and as I found the “Footnote Marker” option in 2901–3, I was and am surprised that I didn’t find it where I must have looked before … maybe either me or my eyes are going senile!

As for the exit error, I posted that because in previous iterations, if I remember rightly, it had happened in both the 32 and 64-bit versions, but this time the 32-bit was clean. Also, as @garpu, I think it was, had also brought it up as happening under WINE, this was merely an extension to that conversation. But you may well be right about it being a CrossOver problem; CrossOver’s default seems to be 32-bit Windows 7, so using a non-default bottle may be behind it … mind you, I have no real idea of how CrossOver, WINE or even Windows works under the hood, so … :smiley:

I’ll return soon, when I’ve had time to look again.

Mark

Hi MM,

Sorry about taking so long to get back to you on this, life, you know … :slight_smile:

Anyway, you’re absolutely right, of course, about the footnote marker. I was looking under “Options”, not “Project Settings”; the reason being that for years it has been set for all my new projects on the Mac. I’d forgotten that I’d made my own Standard (Blank) Template with that set, so I assumed I must have set it in Preferences/Options. A senile moment.

As for the not exiting cleanly, I’ve only tried that one test project, but when I have a moment, I’ll set up another test project to try.

I’ve also upgraded my version of MacOS since then—now 10.13.4 with the latest security update—so who knows if that will make a difference, though CrossOver is still the same version.

:slight_smile:

Mark

Exit error: seems to be any project, since 3.9.0.2. The only time I have had Scrivener exit cleanly was when it crashed on me. I can’t make it exit cleanly if I kill the process while it’s running, though. I’m using the 64-bit version of Scrivener these days. I was using wine-staging 2.17 when it started, and I’m on wine-staging 3.6. (That is, it started happening when Scrivener was updated to 3.9.0.2 and 64-bit, independently of what version of WINE I was using. I’m using a newer (and more experimental) version than Mr. X, so I’m about 99% sure it’s not a regression in WINE.)

I’ve updated the heading, I hope. Not about footnotes this time!

I’ve just installed 2908 under CrossOver 17.1—they now want GBP48 for a year’s subscription (without updates or support) for me to access the latest version 17.5, which is more than I can justify!—but ClamXAV anti-virus etc. immediately quarantined Qt5Core.dll as a Trojan.

Any suggestions? Is ClamXAV being overenthusiastic, or do I have a problem?

Mark

I know this has dropped below the horizon, but an update to ClamXAV and a re-install of 2908 64-bit has worked.

The good news is:

(1) The footnote markers now seem to work, and, even more interestingly, you don’t need to put a space after the marker as you do in Mac v,3 for them to work properly with Chinese;
(2) V.2908 is now exiting cleanly under CrossOver for Mac.

:slight_smile:

Mark

Thanks for the update, Mark! The over-zealous security software has been a problem for new releases before now, but we’re hoping we may be able to avoid that being such an issue in the future. I’m glad you were able to get past the issue with the re-installation, and to hear that the shutdown is going cleanly now.

The footnote markers are still not all in place with compile, etc. , so don’t be surprised if you run into some quirks with them yet. I don’t know your workflow at the moment, so it may be fine, but just be aware they’re definitely an in-progress item! :slight_smile: