[JH] Synopsis notes showing wrong item Beta: 2.9.9.3

Synopsis and notes sometimes do not track to the item used.

I have notebooks with some subdocuments beneath them. I sometimes make a note in the folder about that section. I do this in notes in the inspector.

If I work on 5 or 6 of the documents, then when I return in the binder to the folder the Synopsis and notes display for the last sub-document I worked on, and I can’t get the synopsis or inspector notes I wrote a couple hours ago. These notes are important. If I open and close scrivener or mess around, then they come back. This time, I got them back by copying the document link. I was going to get the link for the folder and the document it was displaying and see if they were the same. After that, the folder displayed my notes properly.

I suspect a caching issue.

This problem has continued in rc 4. It is VERY frustrating. I think I have a way to reproduce it.

In binder, a folder with 4-6 documents beneath it. Each say a page or two long. Some images. Doubt any of this is essential. Then in binder I click the folder. Then drop down and work a few keystrokes or just mouse clicks in a document. Then Click the folder in Binder. The Inspector synopsis and notes remains on the previous document and does not show the synopsis and notes for the folder.

Binder looks like this:

  • Folder
    – document
    – doc 2
    – doc 3
    – doc 4
    – doc 5

Now work on doc 4 for 10 seconds.
Next click on folder in binder.

For me, inspector still shows synopsis and notes for doc 4.

More info: Nothing was written in the folder. It really was a folder. My view is corkboard view in binder.

Can anyone reproduce this?

I tried, and cannot.

Have you tried re-indexing?

And is this just one project, or several that show this behavior? Does it do this on a brand new project?

Also worth noting that the inspector is designed to follow the editor, not the binder, thus when you load the corkboard, the inspector should show the metadata for the item selected on the corkboard, and will show the container’s metadata if there is no selection. Now, if there was no selection on the corkboard in step 1 when you loaded it from the binder, switching via the binder to one of the other documents and back should not change that, but it could be what’s happening.

When you see this issue, is the inspector showing the title for the folder or for the document that goes with the notes/synopsis you’re seeing?

That is what it does not do. So, when there is a container with no document attached to the container. And the container has 3 or more documents beneath it. When I work on a few of the documents and then return to the container in the binder, the view switches automatically to the corkboard view, and leaves the metadata / synopsis, notes for the last selected document. The corkboard shows the documents. How do I get the synopsis and notes for the container? I can’t select it from the corkboard as there is no document. This problem of not showing the containers inspector data began with rc 3.

The 2nd problem is that it is inconsistent. I may try a few times and not be able to replicate it. I haven’t been able to figure how to replicate it consistently. But it happens often. Possibly selecting in corkboard view helps. Also, it isn’t always the last one . So, I have a container with 6 documents. I selected the first one in corkboard. then in binder moved to the 2nd, 3rd, and 4th. Went back to the container in the binder and it switched to the corkboard view and showed the notes for the synopsis for the 3RD!! document.

Then I switched to srivenings view and selected the container and it showed the inspector for the 1st document.

RWFranz - I haven’t messed with the indexing yet, as it works 2/3rds of the time, so I wouldn’t suspect an indexing issue, more like a window or pane refresh issue / caching issue.

To show the metadata for the container that is loaded in the corkboard or outliner view (that is, whose contents are visible on the corkboard/in the outliner), you must have no selection within the editor. Clicking into an empty area of the corkboard or Ctrl-clicking the currently selected item within the editor should clear the selection, causing the inspector to switch to showing metadata for the container itself.

If you can find steps to reliably reproduce this, please let us know! I have not so far in attempting to repeat what you’ve done, but I understand you said it was not always occurring. Editor selections for a given container should be remembered, so in the above scenario, where subdocument 1 is selected on the corkboard for the container, reloading the container via the binder click in the last step should have shown subdocument 1 still selected on the corkboard.

Presently, loading a Scrivenings session from the corkboard typically does not preserve the corkboard selection, so the Scrivenings session loads with focus at the top of the session–thus the inspecor will show metadata for that top item (either the first subdocument or the container, if options are set to show the container text in the session as well–even if it is empty, there will be a place for it at the top of the session where you could add text.)

This part I don’t think is related to the issues of the binder and corkboard selection that you’re describing in the earlier steps. What I’d check for, as you’re going through, is whether there is ever a selection on the corkboard and when that switches. Since it’s not happening all the time, there may be an intermediate step that is triggering that to change when it shouldn’t.

MM
I won’t be working intensely on that project where I have those issues for a couple of weeks. I also understand not being able to fix something you can’t produce. But, I’ll keep the selection guess in mind. As far as I can tell, that’s it. Sometimes the selected item is bright blue and very obvious, but it quickly changes to a greenish color that isn’t as obvious if you aren’t looking for it. But when I was able to produce the problem, and clicked in the corkboard view on emptiness, my container inspector appeared like I want, so I probably have a solution to my problem.

In this project I tend to work on a few sub-documents of perhaps 7 for a while and then complete them and drag them to the bottom using the corkboard and set the status to Done, so what I haven’t done is at the top of the binder. I never even noticed that the done stuff was still selected and when I choose the container in the binder the selection highlighting becomes less obvious.

Anyway, I’ll report if there is really a bug that I find, and it wasn’t just that I didn’t understand the system which seems more likely to me now.