Jumpy mouse or disconnecting keyboard on Macs

If you use a Mac, you may find yourself troubled with a Bluetooth keyboard that’s constantly disconnecting and reconnecting or a mouse (Bluetooth or USB) that makes the cursor jump around so much you feel like screaming.

There are a lot of online discussions that attempt to probe the problem, which seems to be independent of the hardware you’re using. On one, I found a quiet guy who described a simple fix that’d worked in every situation he knew about. The steps:

[b]1. Go to System Preference—General.

  1. Uncheck “Allow Handoff between this Mac and your iCloud devices.”

  2. Restart your Mac.
    [/b]
    I did and all those woes went away. It was like the difference between night and day.

His fix is not only easy, it makes sense. For me, the problem looked like a ghost mouse giving random input to make my cursor jump. Allowing Handoff must mean that OS X treats iCloud electrical noise as if it were mouse input. Turn that bogus iCloud connection off and the problem disappears.

Apple needs to make Handoff far more robust, but until it does, we need this workaround.

–Mike Perry, Inkling Books