Just upgraded - what happened to ⌘K?!

My new version of Scrivener doesn’t seem to allow me to break up a huge block of text using ⌘K with the cursor placed at the break point. (This would also create a new card for the corkboard) What happened?
I don’t even know how to search for this. “break” leads to Line break or Page break - not what I am looking for.

The menu item is Documents->Split-> with 2 options for splitting a document at your current cursor position in a document. It won’t work if your cursor is at the top or bottom of the document, but the shortcut should still be ⌘K. The shortcut will be next to the menu item.

Is it possible that some app has taken over the ⌘K shortcut globally, or did you forget that you re-assigned that keyboard shortcut in System Preferences?

Aha! the command is now option command k, for some reason. Not sure why that is! Maybe I can figure out how to revert it back to command k

Yes, you can fix this back to the way it was, using these instructions. It’s one of the first things I changed when that update was applied, as I have very little use for adding a link and have been using ⌘K for “split” since 2006. That’s a hard habit to break. :slight_smile:

It was changed because ⌘K has, over the years, become a bit of a standard for adding a link and it became easier to change the default than instruct everyone on the above approach.

1 Like