Keeping settings different for manuscript and screenplay


I’m writing both these days and I want to have times new roman for my font in manuscript and a full 8" margins.
But when I open up an existing screen play suddenly instead of courier new and 1.5" beginning margin I have the settings for my manuscript.

Shouldn’t there be away to keep these settings separate?

Yes, documents in scriptwriting mode use the settings indicated in Format > Scriptwriting > Script Settings… and these (unlike the Editor default formatting) are specific to the project. Making adjustments to the formatting in Tools > Options shouldn’t have any affect on script mode documents, and shouldn’t even have any affect on any existing documents, but only apply to new documents you create. How did you change your formatting?

I went into the manuscript and highlighted the font and changed it.

When I opened my screenplay next when I opened a scene it was in the same font as the manuscript, not courier new the way I left it.

Hm, I can’t at all reproduce the problem you’re seeing, so I’m having a hard time seeing what might be causing the issue. Are these script documents and regular documents within the same project, or two separate projects? If the same, are the two both within the Draft (possibly renamed “Manuscript” or such) folder? Are your script documents actually in script mode, i.e. if you select one and load it in the editor, do you see the script elements in the editor footer and is “Script Mode - Screenplay” selected in Format > Script Mode? Sorry for all the questions, but I’ve never seen this behaviour before and it certainly doesn’t sound correct, so I’d like to sort out what’s happening and get it working!

Questions are good if we can solve this problem.

No both are separate projects not even saved in the same folders.

I created a new manuscript yesterday - if I go FORMAT/ There is a SCRIPTWRITING choice listed under it but nothing appears to be selected.

I open my screenplay - FORMAT/SCRIPTWRITING again nothing seems to be selected.

Scriptwriting mode is toggled per document, so you’ll need to ensure that you select and load one of your script documents and then check Format > Scriptwriting > Script Mode to see if that is enabled. Another way to tell if the document is in script mode is by its icon, which will be pale yellow with three “holepunch” dots down the left side if the document is in script mode, and by the information in the editor footer when that document is loaded: for a script document, you will see the currently focussed element on the right and in the center you may see prompts about what the next elements are if you hit Tab or Enter. You won’t see a word and character count, which you would if you were in the standard document mode.

Given that they’re separate projects and that you changed the settings just within the editor by selecting the text and adjusting it, rather than setting new editor defaults in Tools > Options, it shouldn’t really matter whether the documents are in script mode or not, but since they probably ought to be, and since we’re still trying to figure out what’s going on, it’s worth double-checking. If “Script Mode” is not selected for your script documents, try selecting it and note the change in the editor footer and the document icon. (The text itself won’t change, so you’ll just see these outside alterations.) If it now looks as described above, with the elements in the editor footer (probably just “General” in this case) etc., then we’ll at least have ascertained that the script documents aren’t actually in script mode, which will cut influences of script settings and that formatting from the issue.

OK I opened my screenplay.
At the top of “binder” it says “Screenplay” (Which was added by Scrivener when I opened the project.)
However, if I go down to each scene and click on it the bottom editor shows the word and page count.
Still on that scene if I click on FORMAT/SCREENWRITING I can click on “scriptwriting mode” and the word and page count will disappear from the bottom editor.
In addition if I highlight all of the scenes in one act then click on FORMAT/SCREENWRITING “scriptwriting mode” is grayed out.(Which I am taking to mean that all of the scenes are now in that mode.)
If however, I go back and click on any individual scene in that act it will not be in “scriptwriting mode.”
Now thoroughly confused. :frowning:

OK, it sounds like your scenes are actually not in script mode at all. You can only toggle them individually, which is why the command was greyed out when you had multiple scenes selected. By the description of how you did toggle one, right now all your script scenes are just in the regular mode rather than script mode. That means they’re not necessarily using the script formatting defined for the Screenplay format (i.e. the settings in Format > Scriptwriting > Script Settings), but it still doesn’t explain how they were altered by your adjusting the formatting in the editor in a completely separate project. I’ve done some more testing with this but can’t produce a situation wherein something that out of scope occurs–the formatting here is just being done for the individual RTFs within the project folder, so there’s not even a common pool they’d be drawing from. It would make sense if you’d adjusted the default editor settings in Options and were then creating new documents in your screen play project and these documents were likewise not in script mode, since they’d then use that default formatting rather than the script settings, but if you were changing the font directly in the editor in a separate project, there’s no connection between them.

Unless you’re able to cause this formatting issue to happen again and we can better ascertain the exact setup of the files, I think we may have to label this one a freak accident and move on. At this point, I’d go ahead and fix the formatting on the script documents by converting each of them to script mode and then resetting the elements as necessary to apply the proper formatting to them. (Before doing this, open up the Script Settings and make sure each of the elements is formatted the way you want.) Try it for just one document and then close and reopen the project to make sure that sticks, then go through and finish the rest. Make a backup when you’re done by using File > Back Up > Back Up To… (On the note of backups, you may want to check your automatic backups for a version of the project pre-formatting fiasco. Do this first before opening and closing the project any more for the best shot at finding an old enough copy. You can access your backups via the button in the Backup tab in Tools > Options; I’d copy out all the ones for this project from prior to the time you opened it and saw the formatting was incorrect. If they’re stored as zipped archives you’ll need to extract them first before opening the backup copy in Scrivener: either right-click the file and choose “Extract All” or double-click to view the zipped contents and then drag out the project .scriv folder.)

For future documents, if you have a script mode document selected, creating a new document will automatically create it in script mode as well. So once you’ve adjusted the existing ones, it should be relatively simple to always create your new screenplay documents still in script mode. You can always toggle from one mode to the other via Format > Scriptwriting > Script Mode or Ctrl+4.

OK, we’ll put it down to user error this time.

Question: when I wanted to add a new scene in an act I would either right click on the scene above or below where I wanted to add the new scene and then click on “ADD/NEW TEXT” OR from the Pull Down Menu/PROJECT/NEW TEXT. How is it that all of the scenes that I added (New Text) in this “screenplay” that I opened in Scrivener didn’t open as “scriptmode - screenplay”?

It could be that the first time you added a new document, you didn’t have the script mode doc selected, so the new document was not in script mode, and following that of course subsequent documents also weren’t in script mode. It’s also possible they were in script mode but then were toggled to regular mode accidentally via the Ctrl+4 shortcut. I’d think you’d notice if you’d been writing in script mode, making use of the automatic tabbing from element to element, and then started trying to write in a document without that mode turned on, so that you had to format each element by hand as you went. That might argue for having switched the script mode off after the fact.