Keyboard shortcuts copy/paste formatting do nothing

I tried the default hotkey assignments for Format/Copy Formatting [Ctrl+Shift+C] and Format/Paste Formatting [Ctrl+Shift+V].

I also changed the hotkey settings for Format/Copy Formatting to [Ctrl+Alt+C] and for Format/Paste Formatting to [Ctrl+Alt+V].

Those didn’t work either.


Woops! I’d used the Format menu successfully to copy and paste formatting before, but now it doesn’t work.

Actually, playing around, I found that I couldn’t change the font size, either. This was some text copied from the subject line of Gmail email in a Firefox web browser on a PC. I had to cut the text then Paste and Match Style before I had control of the text.

Format handling in general is flaky in this version, whether using copy/paste or Styles. Sometimes it works when applied to selected text of the same format or style, but not to selected text with mixed formats/styles. Sometimes I have to change styled text to “No Style” before I can apply a new style, meaning I can’t for example go from Heading 1 to Heading 2 directly.

Hi Skeptic23,

There is a known bug where text copied from certain web browsers cannot have its formatting changed after being pasted. Is this what you are encountering? Are you able to copy/paste formatting on text that was not copied from a web browser, for example?

Yes Bryan, exactly. I’m getting around it by Paste and Match Style.

However, it’s not just text copied from the web. It’s the fact that the shortcut keys for copy/paste formatting do not work at all. That’s the larger issue.

And the problem with styles involves text typed into Scrivener by hand, a style applied, and then trying to change that style.

We do have an issue that may be affecting shortcuts that use the ALT key, so that may be causing some of the problem. I also see that you posted the default Past Formatting as Ctrl-Shift-V , when the default is Ctrl-Shift-Y. So there may be some confusion there as well.

In trying to Copy/Paste formatting I have been able to use the default shortcuts without issue (webpage text and ALT shortcuts excluded)

Haha, right you are, glad you mentioned. That “Y” looks close enough to a “V” in the Keyboard Options that I got confused.

Unfortunately, it still doesn’t work from my perspective.

Maybe we’re down to a ‘why doesn’t it act like all the other editors I’ve ever used?’ problem and this old dog needs to learn new tricks just for Scrivener?

I went to File/Options/Keyboard, clicked reset all, changed a word to boldface with the “B” button on the tool bar, selected the newly formatted text, pressed Ctrl-Shift-C, then selected a plain-type word, pressed Ctrl-Shift-Y, and it did something, just not what I expected: it boldfaced the entire paragraph.

How do I paste formatting confined to just the text I selected? If I want to paste it to a whole paragraph, I usually select the whole paragraph including the paragraph mark first.