Keyboard shortcuts don't work for Dvorak layout

I use the DVORAK keyboard layout provided by Mac OS 10.5.8. I noticed that when I try to use keyboard shortcuts, only the QWERTY layout keys are recognized, not the DVORAK layout.

For instance, if I want to copy a selection of text, “Command + C” does not work on the DVORAK layout. When I type this keyboard shortcut, instead of copying the selection is changed to italics. That’s because the “C” key on a DVORAK layout is the “I” key on a QWERTY layout. To copy the text, I must type “Command + J” (the “C” key on a QWERTY layout) – not very intuitive.

Is there a way Scrivener can recognize the input from my DVORAK keyboard layout? Thanks.

As a work-around, are there cut and paste icons that I can put on the tool bar?

Try using the Dvorak-Qwerty ⌘ variant; that will give you a Qwerty keyboard when the Cmd key is held down so standard shortcuts like Cmd-C, Cmd-V, Cmd-I, Cmd-B and so on will still work (across the system, not just in Scrivener). Otherwise, you can use the Keyboard Shortcuts pane of System Preferences to reassign all the keyboard shortcuts that you use, but that could take a while.

“Try using the Dvorak-Qwerty ⌘ variant;”

Thanks, but I’m not familiar with that. Could you explain how I do that?

Open System Preferences>Language & Text Preferences, then click the Input tab to add or remove keyboard layouts. There should be several listings for Dvorak, one of which will be Dvorak-Qwerty ⌘. Select that so it’s added to your list (you can uncheck the regular Dvorak or leave it, up to you) and then you’ll just need to switch to that new keyboard layout–you can do it easily via the Input menu in the menu bar, if you have that visible, or using the keyboard shortcut if that’s enabled. I think Opt-Cmd-Space is the default for switching to the next keyboard layout in your list, but I’ve co-opted mine so I’m not positive. It should tell you in that Input pane of System Prefs, though. (Note I’m not looking at this on Leopard, so the pane might be a little different, but the option should still be there.)

Thanks again. But surprisingly when I checked Sys. Prefs, I already had Dvorak-Qwerty “Command Key” selected as my default keyboard layout. So I selected just the standard Dvorak option to see what would happen and WOW, now the Command key shortcuts work properly with the Dvorak keys. Go figure.

Huh. That is…strange. But I’m glad you’ve got it working.