Language after compilation

This topic has been discussed already, nevertheless I want to bring it up again.
I use Scrivener in German, everything is set to German. But after compilation to docx, the language formatting is set to English (USA).
A few weeks ago @Caithness postet a solution which is based on a Macro in Word - this is great, but I don’t use Word but a different Office Suite which does neat spelling correction as well (Softmaker office). So this does not work for me.
Another solution I found at the Mac Forum considered changing the export conversion in Scrivener > Preferences > Sharing > Conversion (Mac) or Options > Sharing > Conversion (Win). And here is the first glimpse to a solution: When changing export converter “ODT” from Aspose to Scrivener and then compile my manuscript to .odt, the language is compiled correctly. Unfortunately other things like page breaks and page layout are completely destroyed, so this doesn’t work at all.
Changing the export converter “DOC” to “RTF” does not change a thing.

So I would ask if you could make it possible to correct this export conversion when using doc or docx as well? Of course I don’t know if this is possible, but I would guess as long as it is possible with odt, it should work with doc or even better with docx too.
Or perhaps it could be possible to simply add the “language” style property to the compilation styles?

Thanks a lot!

(if this is part of the 3.1.5 beta, I would be glad to test it!)

1 Like

Unfortunately I never got a response to this post. New v3.1.5 still can’t compile correct language.
Any solutions?

For now, there’s no solution but to select all text and change the language setting to your preferred language.

1 Like

Or to change it in the format panel of your preferred office tool.
What a shame :disappointed:

I recommend updating each of the styles in your word document. If you don’t do this, you will need to keep resetting the language (if you edit/add new sentences).