Language and smart quotes

My question is fairly simply, and it may well be that the answer is ‘rectify it in Word after compilation’. My language settings are ok in the sense that even though my macOS (10.15.6) environment is bilingual (English/Finnish), Scrivener’s (3.1.5) spelling check works fine in UK English as is intended. But in introducing smart quotation marks, there is an odd glitch. Instead of ‘closing’ the words inside quotation marks with the first quotation mark curving like ( and the second like ), I get both quotation marks like the latter. This may be correct in Finnish, but not in English. Is there any way of rectifying this without turning my iMac into an English-speaking monoglot?

There are options for smart quotes in System Preferences/Keyboard/Text. What are they set to? That’s where Scrivener picks up which to use. You can only turn them off completely in Scriveners preferences, in the Corrections pane.

Thanks. macOS’s system preferences only give me the option of quotations marks curling in the wrong way. Perhaps this is because the system language is Finnish. It offers a whole lot of other options, but not the one that I’d need. Even in Scrivener’s corrections the quotation marks point in the wrong way (i.e. the same as macOS). So I guess the only work-around is to get rid of smart quotes at the manuscript stage and to find-replace in Word after compilation.

I do that anyway—albeit in Nisus Writer Pro—as it saves many other small issues with quote marks/apostrophes.