LaTeX Font Warning: Font shape `T1/phv/sb/n' undefined

After having searched for the above warning, having checked on SE, chatGPT, texfaq, et al. I thought I’d throw out a Hail Mary to those using Scrivener + LaTeX to see if/how others might be handling the above warning, if at all.

I’ve been blissfully unaware till now of just how complex the font system is and how difficult it may be to translate Scrivener fonts to LaTeX. What might seem simple or straightforward at first glance, is simply not.

The above Warning is just a warning, but it occurs so often in my LaTeX .log file, cluttering up the log file, that I thought I’d see if could find a quick fix to clear up the .log file. NOT!

Instead, LaTeX changes the Font shape from ‘sb’ to simply ‘b’ and continues on compiling:

LaTeX Font Warning: Font shape ‘T1/phv/sb/n’ undefined
(Font) using ‘T1/phv/b/n’ instead on input line 7501.

If anyone else using Scrivener/LaTeX has already found a way to eliminate the above Warning from their LaTeX .log file, I’m all ears!

Thanks for reading,
scrive
:thinking:

Well, gosh, I don’t think I can ever beat chatGPT, but …

I know little about fonts and LaTeX as having never had to debug that.

  • are you using the Scrivener Template for LaTeX? I use it with the their default Memoir class
  • If so have you changed anything? I’ve tweaked mine, but never saw this error
  • which Latex compiler you using? I use Texmaker

You didn’t mention doing an internet search. I used google “LaTeX Font Warning: Font shape ‘T1/phv/sb/n’ undefined” and found which looks informative.

I notice your error message is a “warning” and said what it used instead. Is there a problem with what you LaTeX compiler did for you?

I find the Scrivener-provided LaTeX template is excellent and “just works”.

1 Like

Hi rms,

To begin, my understanding of the nomenclature: T1/phv/sb/n is that it stands for:

T1 - TEX extended text (See https://ctan.math.utah.edu/ctan/tex-archive/macros/latex/base/fntguide.pdf)
phv - Adobe Helvetica (See https://ctan.math.utah.edu/ctan/tex-archive/macros/latex/base/fntguide.pdf)
sb - Semi Bold (See fonts - Possible values for \fontseries and \fontshape - TeX - LaTeX Stack Exchange)
n - upright (normal) (See fonts - Possible values for \fontseries and \fontshape - TeX - LaTeX Stack Exchange)

Thanks for your response. Let me take your questions/comments one-by-one.

  • are you using the Scrivener Template for LaTeX? I use it with the their default Memoir class

Yes, almost four years ago, I started with the General Non-fiction (LaTeX) Scrivener Template for LaTeX, and continue to use the LaTeX (Memoir Book) class with what is now the 28.Xth descendant therefrom.

  • If so have you changed anything? I’ve tweaked mine, but never saw this error

Like most authors, the original version of my LaTeX code has undergone a few revisions, so Yes, I have changed quite a bit. That said, without the original General Non-fiction (LaTeX) Scrivener Template, I think it is fair to say I would not have had any idea how to get started using LaTeX with Scrivener.

That said, the fact that you 'never saw this error' (actually a Warning) tells me that it’s not something that is endemic with the Scrivener template.

  • which Latex compiler you using? I use Texmaker

I use TeXShop, a LaTeX and TeX editor, and previewer, for macOS, by Richard Koch at the University of Oregon.

I’d be surprised if the Warning I posted about has anything to do with the compiler I am using. What little I have been able to assess is that the Warning has to do with the particular Font shape (sb - semi-bold) not being available at the time of compilation, not the type of compiler being used. But hey, each day I’m learning more and more about just how little I know and understand about the wonderful world of LaTeX.

Re:

When I mentioned that I had:

I implied having done an extensive internet search, and the reference you posted was the first one from SE (See “Font shape undefined” with LaTeX and isodoc) that I looked at.

However, in the top answer in the SE post, the only fix that was offered was:

...not writing '\bfseries\scshape' in the first place will resolve the warning :)

I would love to not use the Adobe-Helvetica Semi Bold font to stop the Warning I mentioned above. As the Warning appears everywhere in the .log file for my Scrivener-LaTeX project, it profoundly distracts any effort to debug the code.

Unfortunately, I have NO clue how or where I may have used the Adobe-Helvetica Semi Bold font, as opposed to simply the Adobe-Helvetica Bold font.

I’m not even aware of how one would go about searching a Scrivener project file for the presence of a particular font, in this case the Adobe-Helvetica Semi Bold font … Any clues to that end would be greatly appreciated!!

(If you sense a bit of frustration in the tone of my response above, my apologies, as I am faced with the limitations of my own understanding of the entire world of font issues related with LaTeX.)

Thank you again for your response,
scrive
:thinking:

Update: I checked with the Scrivener font palette (P. 410 of the manual) and there is NO (Adobe)Helvetica Semi Bold font that I could see. I only found a ‘Condensed Bold’ in the Helvetica Neue font family that may be what is being interpreted as Adobe Helvetica Semi Bold font on the LaTeX side.

But I also did not see any reference in the Scrivener manual to a utility to search for a particular font within a Scrivener project. If anyone can correct me, I’d be immensely grateful! - scrive

I’m not entirely sure about the Scrivener LaTeX template (as i use Pandoc), but i’d be very surprised if any font information was being carried across from the Scrivener editor itself to LaTeX. In general, fonts will be defined in the the TeX templates. This is separate layer, just a bunch of text files that serve as the template to build the TeX file. The fonts are not shared in the common sense.

Font handling in TeX is an almighty mess, due to the legacy baggage it continues to carry over the last 40 years or so (great backwards compatibility, no so great ongoing experience). I always use XeTeX with my own OTF fonts specified explicitly everywhere I can (to try to bypass the legacy cruft), but it is hard as packages can carry old code along with them. T1 fonts were created in the 1980s and are not used in anything except for TeX anymore!

If you use XeTeX or LuaTeX you can specify your own fonts to use modern OpenType formats that are UTF-8 compatible.

The LaTeX compiler moans about lots of things that don’t seem to seriously impact it. You could try a super minimal document, see if the error is there, then add some content till the error appears. Can you see anywhere in your raw TeX document where this font may be specified, if not it is probably a package that is bringing it in. I did try to create a new document from the Scrivener LaTeX template and I didn’t see that warning, so it is probably being brought in from a package you are using?

3 Likes

Hi nontroppo,

Thank you so much for your comments and discussion on TeX and fonts. I am grateful for your insights. I’ve been working with LaTeX for almost four years and now realize that I may have just scratched the surface. I am amazed that I was able to do so much knowing so little.

After reading your comments, my bottom line is to not sweat the font stuff, and to work around the warnings that appear in the LaTeX .log files.

The issue, however, has raised concerns about my continued use of LaTeX to document my project and research going forward. The question is though if not LaTeX, then what?

If Scrivener had in it’s quiver a General Non-Fiction (XeTeX) Template, or a General Non-Fiction (LuaTeX) Template, I might consider researching those options. But as I mentioned above:

The same applies for both the XeTeX and LuaTeX versions of TeX, as my goal when I started (and continues to be) documenting my research and work, not to learn a new programming language.

When issues such as the LaTeX error .log disrupt progress on my documentation, I’ve had to decide how much of my only resource, time, I can spend on coding. In this case, your comments are pretty clear that trying to understand TeX and fonts is probably not worth the effort to eliminate a bunch of warnings from the .log file.

Thank you again for your comments and discussion on TeX and fonts.

scrive
:thinking:

Personally, I only use LuaTeX these days. It used to be XeTeX until fairly recently, but I must have missed the microtype package, otherwise, I can’t really remember why I would have made the switch. Truth be told, LuaTeX and XeTeX are nearly identical for all effects and purposes and anything using a TeX compiler should also be able to compile using any of these two. So, @scrive, this is not about learning a new coding language, by any means. It is more like picking a different option before hitting compile. Give it a try.

4 Likes

XeTeX and LuaTeX are not different versions of LaTeX, they are different LaTeX engines for how to render a final PDF. The default engine is pdfTeX. You can use the exact same .tex file and render it to a PDF using any three of them.

However, to make best use of Xe|LuaTex you specify fonts slightly differently. Here is the code from my template that allows you to support any engine and optimise for each:

\usepackage{iftex}
\ifPDFTeX
  \usepackage[T1]{fontenc}
  \usepackage[utf8]{inputenc}
  \usepackage{textcomp} % provide euro and other symbols
\else % if luatex or xetex
  \usepackage{unicode-math} % this calls fontspec
  \defaultfontfeatures{Scale=MatchLowercase}
  \defaultfontfeatures[\rmfamily]{Ligatures=TeX,Scale=1}
\fi
\usepackage{lmodern}
\ifPDFTeX\else  
    % xetex/luatex font selection
  \setmainfont[Numbers=Proportional,Numbers=OldStyle]{Alegreya}
  \setsansfont[]{Alegreya Sans}
  \setmonofont[Scale=MatchLowercase]{Fira Code}
  \setmathfont[]{Libertinus Maths}
\fi

We use a standard package iftex that allows to check which engine is currently running then choose the optimal set of packages. CTAN: Package fontspec (called by CTAN: Package unicode-math in my fragment above) provides the simple commands like \setmainfont with a ton of tweakability if needed (but not required). The fallback \usepackage{lmodern} is what pdfTeX will use. But for Xe|LuaTex we can use any font macOS has installed, much nicer typography! Then build the PDF:

latexmk -xelatex -time -f -logfilewarnings -interaction=nonstopmode -pv Test.tex

Simply replace -xelatex with -lualatex or -pdf to swap engine. For your TeXShop GUI, I’m sure there is an option to change the engine. Indeed you may already be using XeLaTeX without knowing it.

4 Likes

Hi nontroppo and bernardo_vasconcelos,

I am always buoyed when I see your postings. I invariably learn from your posts with relevant details to the issues that are perplexing me. Thank you both.

I’m currently sorting through a narly LaTeX issue. I’ll have a look at both of your suggestions in detail as soon as I have a moment to focus on the options you outlined.

Thanks you again,
scrive
:thinking:

1 Like

Hi nontroppo and bernardo_vasconcelos,

Thank you both so much for the details on how to implement LuaTeX and XeTeX. It’s pretty straightforward to:

  • Include above the iftex package and code in my Scrivener project, and to
  • Adjust my TeXShop GUI engine option from LaTeX to LuaLaTeX (for increased memory) or XeLaTeX

But I’m a little uncertain as to how to adapt your command instructions:

latexmk -xelatex -time -f -logfilewarnings -interaction=nonstopmode -pv Test.tex

into my TeX package arara code in the Scrivener Compile... > Project Formats > LaTeX (Memoir Book) > Document prefix > Text Layout that instructs the compiler how to build the PDF file, e.g. :

 % !TeX TS-program = arara
 % !TeX encoding = UTF-8 Unicode
 % arara: pdflatex: { synctex: yes }
 % arara: bibtex
 % arara: makeglossaries
 % arara: makeindex: { style: <$projecttitle>.ist }
 % arara: nomencl
  et al. ...

Apologies for the confusion … Thank you both again for your comments and instructions!

scrive
:thinking:

I don’t use any GUI like TeXShop, so that command is my “alternative” to TeXShop. latexmk is a TeX tool which orchestrates LaTeX / BibLaTeX. I prefer the command-line to a GUI, but that is just my option. You don’t need to use it.

1 Like

Hi nontroppo and bernardo_vasconcelos:

Thank you both for your suggestions and encouragement.

For the last month and a half, I’ve been pulling my hair out with a ‘Runaway text…’ memory error that has prevented me from compiling my project. :scream: :cold_sweat: :exploding_head:

At long last I took the leap of wandering into the XeTeX and LuaTeX unknown, and voila!, I’m finally able to complete a full compile of my entire project on my 10yr old Mac! (I’m still experiencing a few errors on my M2, but this is definite progress.) :grinning:

It took me more than a few hours to figure out how to locate and install the Fira Code font on the M2 (Thank you Homebrew!). And, there’s additional research to be done as I’m also not quite sure if I’ve installed the Libertinus Maths font correctly.

Wonders never cease!

Now I need to reconcile all those alternate versions of the code I created while searching for a solution to the memory issues that can be endemic with LaTeX. (And Yes, I know there likely is/are unmatched parentheses somewhere in my code that precipitated the memory issues.)

In the meantime, apparently LuaTeX was able to expand TeX’s memory to allow my entire project to compile. There’s still the unresolved issue on the M2 to resolve, but this is progress!

Now if I can just find that/those errant unmatched parentheses hiding within my 21K lines of code!

Thank you both again!
scrive
:thinking:

brew install font-fira-code font-libertinus font-alegreya font-alegreya-sans 

Homebrew is totally great for fonts, this will install all the fonts to your OS and thus be usable by Xe/LuaTeX. You can replace the fonts as you like, anything you can install in macOS can be used. The stix fonts are also useful with maths support brew install font-stix-two-maths font-stix-two-text

I prefer XeTeX as it is faster, but LuaTeX receives the majority of ongoing development as this is the “future” of LaTeX, so using it as a base makes sense. Great that it solved your memory issue!

1 Like

I’ve been using Homebrew for a bit … but never for fonts … this is new for me … thanks for the suggestions.

FWIIW, there seems to be some difference between how Homebrew works with my M2 versus my 10yr old Mac with Catalina … I need to check this further, but at first glance there seems to be some difference in the fonts that are available … I need to keep exploring …

For example, it appears that the fira-code font may not be available for my Catalina Mac, but appeared to install fine on the M2. More to come …

Thank you so much for all your thoughts and assistance … I’m just glad to be using Scrivener as a front-end for my project … I never would have made it this far w/o Scrivener, and L&L …

scrive
:thinking:

P.S. One thing that is a bit of a mystery is how long some Homebrew updates can take. On my 10yr old w Catalina, a recent update for pandoc-crossref took well over half an hour (I use a VPN, but even so, my connection is not slow!):

==> Upgrading pandoc-crossref
0.3.15.2a → 0.3.16.0
==> cabal v2-update
==> cabal v2-install --jobs=8 --max-backjumps=100000 --install-method=copy --ins
:beer: /usr/local/Cellar/pandoc-crossref/0.3.16.0: 6 files, 47MB, built in 30 minutes 58 seconds
==> Running brew cleanup pandoc-crossref

Disable this behaviour by setting HOMEBREW_NO_INSTALL_CLEANUP.
Hide these hints with HOMEBREW_NO_ENV_HINTS (see man brew).
Removing: /usr/local/Cellar/pandoc-crossref/0.3.15.2a… (6 files, 46.9MB)
Removing: /Users/leftcoast/Library/Caches/Homebrew/pandoc-crossref–0.3.15.2a.tar.gz… (1.1MB)

On my M2, I am seeing some unusual behavior.

I’ve installed, and re-installed the font-libertinus a few times:

==> Downloading https://github.com/alerque/libertinus/releases/download/v7.040/Libertinus-7.040.tar.xz
Already downloaded: /Users/gene/Library/Caches/Homebrew/downloads/6037df912e33c5d3145e4d3377d30c6df9997326db2e8f5c88de9a4e62205fa3--Libertinus-7.040.tar.xz
==> Uninstalling Cask font-libertinus
==> Backing Font 'LibertinusSerifInitials-Regular.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSe
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerifInitials-Regular.otf'
==> Backing Font 'LibertinusMath-Regular.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusMath-Regula
==> Removing Font '/Users/gene/Library/Fonts/LibertinusMath-Regular.otf'
==> Backing Font 'LibertinusMono-Regular.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusMono-Regula
==> Removing Font '/Users/gene/Library/Fonts/LibertinusMono-Regular.otf'
==> Backing Font 'LibertinusSans-Bold.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSans-Bold.otf'
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSans-Bold.otf'
==> Backing Font 'LibertinusSans-Italic.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSans-Italic.
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSans-Italic.otf'
==> Backing Font 'LibertinusSans-Regular.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSans-Regula
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSans-Regular.otf'
==> Backing Font 'LibertinusSerif-Bold.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSerif-Bold.ot
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerif-Bold.otf'
==> Backing Font 'LibertinusSerif-BoldItalic.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSerif-B
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerif-BoldItalic.otf'
==> Backing Font 'LibertinusSerif-Italic.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSerif-Itali
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerif-Italic.otf'
==> Backing Font 'LibertinusSerif-Regular.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSerif-Regu
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerif-Regular.otf'
==> Backing Font 'LibertinusSerif-Semibold.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSerif-Sem
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerif-Semibold.otf'
==> Backing Font 'LibertinusSerif-SemiboldItalic.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSer
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerif-SemiboldItalic.otf'
==> Backing Font 'LibertinusSerifDisplay-Regular.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusSer
==> Removing Font '/Users/gene/Library/Fonts/LibertinusSerifDisplay-Regular.otf'
==> Backing Font 'LibertinusKeyboard-Regular.otf' up to '/opt/homebrew/Caskroom/font-libertinus/7.040/Libertinus-7.040/static/OTF/LibertinusKeyboar
==> Removing Font '/Users/gene/Library/Fonts/LibertinusKeyboard-Regular.otf'
==> Purging files for version 7.040 of Cask font-libertinus
==> Installing Cask font-libertinus
==> Moving Font 'LibertinusSerifInitials-Regular.otf' to '/Users/gene/Library/Fonts/LibertinusSerifInitials-Regular.otf'
==> Moving Font 'LibertinusMath-Regular.otf' to '/Users/gene/Library/Fonts/LibertinusMath-Regular.otf'
==> Moving Font 'LibertinusMono-Regular.otf' to '/Users/gene/Library/Fonts/LibertinusMono-Regular.otf'
==> Moving Font 'LibertinusSans-Bold.otf' to '/Users/gene/Library/Fonts/LibertinusSans-Bold.otf'
==> Moving Font 'LibertinusSans-Italic.otf' to '/Users/gene/Library/Fonts/LibertinusSans-Italic.otf'
==> Moving Font 'LibertinusSans-Regular.otf' to '/Users/gene/Library/Fonts/LibertinusSans-Regular.otf'
==> Moving Font 'LibertinusSerif-Bold.otf' to '/Users/gene/Library/Fonts/LibertinusSerif-Bold.otf'
==> Moving Font 'LibertinusSerif-BoldItalic.otf' to '/Users/gene/Library/Fonts/LibertinusSerif-BoldItalic.otf'
==> Moving Font 'LibertinusSerif-Italic.otf' to '/Users/gene/Library/Fonts/LibertinusSerif-Italic.otf'
==> Moving Font 'LibertinusSerif-Regular.otf' to '/Users/gene/Library/Fonts/LibertinusSerif-Regular.otf'
==> Moving Font 'LibertinusSerif-Semibold.otf' to '/Users/gene/Library/Fonts/LibertinusSerif-Semibold.otf'
==> Moving Font 'LibertinusSerif-SemiboldItalic.otf' to '/Users/gene/Library/Fonts/LibertinusSerif-SemiboldItalic.otf'
==> Moving Font 'LibertinusSerifDisplay-Regular.otf' to '/Users/gene/Library/Fonts/LibertinusSerifDisplay-Regular.otf'
==> Moving Font 'LibertinusKeyboard-Regular.otf' to '/Users/gene/Library/Fonts/LibertinusKeyboard-Regular.otf'
🍺  font-libertinus was successfully installed!

Despite multiple confirmations that font-libertinus was successfully installed!, when I typeset my compiled LaTeX project, I get the following error:

Package fontspec Error: The font "LibertinusMaths" cannot be found.

This is endlessly reproducible, and there’s not much actionable help online when I do a search for the above error, or simply font "LibertinusMaths" cannot be found.

Any thoughts would be greatly appreciated!

The fastest solution would be to drop the use of the Libertinus Math font. Apart from that, perhaps this could help?

2 Likes

That is not a mystery. brew has pre-built binaries for most systems, but possibly for very old systems the binary (called a bottle, something you can pour directly rather than brew) is not available so brew will compile the software directly, this takes time especially on an old system. In this case pandoc-crossref is written in haskell and so uses the cabal tool for compilation IINM.

Also a simple fix; I actually had a typo in my code above :face_with_peeking_eye:, the name should be Libertinus Math. You can use macOS font book or TeX’s own otfinfo command to find the proper family and postscript names:

>> otfinfo -i (kpsewhich LibertinusMath-Regular.otf)
Family:              Libertinus Math
Subfamily:           Regular
Full name:           Libertinus Math Regular
PostScript name:     LibertinusMath-Regular
Version:             Version 7.040;RELEASE
Unique ID:           5.000;QUE ;LibertinusMath-Regular
Designer:            Philipp H. Poll, Khaled Hosny
Manufacturer:        Caleb Maclennan
Vendor URL:          https://github.com/alerque/libertinus
Copyright:           Copyright © 2012-2021 The Libertinus Project Authors.
License URL:         https://scripts.sil.org/OFL
License Description: This Font Software is licensed under the SIL Open Font License, Version 1.1
Vendor ID:           QUE

For XeTeX and LuaTeX there are some rules for finding fonts, detailed in Chapter 2 of the fontspec docs: https://mirror.math.princeton.edu/pub/CTAN/macros/unicodetex/latex/fontspec/fontspec.pdf - in particular for LuaTeX users:

LuaTEX users only In order to load fonts by their name rather than by their filename (e.g., ‘Latin Modern Roman’ instead of ‘ec-lmr10’), you may need to run the script luaotfload-tool, which is distributed with the luaotfload package. Note that if you do not execute this script beforehand, the first time you attempt to typeset the process will pause for (up to) several minutes. (But only the first time.) Please see the luaotfload documentation for more information.

I tested this mini doc from Bernardo’s link and it compiles fine in XeTeX at least:

\documentclass{amsbook}
\usepackage{unicode-math} % calls fontspec

\setmainfont[Numbers=Proportional,Numbers=OldStyle]{Alegreya}
\setsansfont[]{Alegreya Sans}
\setmonofont[Scale=MatchLowercase]{Fira Code}
\setmathfont[]{Libertinus Math}

\begin{document}

The following equation should be in «Libertinus Math» and it is.

\begin{equation}
\sum_{n=1}^\infty \dfrac{1}{n^2}=\dfrac{\pi^2}{6}
\end{equation}

\end{document}
3 Likes

Sorry, I realise above my otfinfo command will not work in zsh — I use a wonderful alternative shell — Elvish — which has slightly different syntax (in this case using ( ) rather than $( )), so for zsh this should work:

otfinfo -i $(kpsewhich LibertinusMath-Regular.otf)

And somewhat offtopic but for those who use BasicTeX or TinyTeX (minimal installs of TeX Live), you can add otfinfo by installing this package with tlmgr: sudo tlmgr install lcdftypetools

1 Like

As far as I’m concerned, you’ve nothing in any way to apologize for, ever.

If anything, I am the one who needs to thank you for all the assistance you’ve provided … I’m the one asking the off-the-wall questions that go beyond any reasonable expectation … and yet you (and bernardo_vasconcelos) have come through with comments and suggestions that help me get results.

I’ve already mentioned it, but I was really stuck, unable to typeset my project for too many weeks, and your thoughts and suggestions were the only thing that got me un-stuck! A thousand thank you’s. :pray:

As far as the spelling of LibertinusMath(s), there is a bit of a mystery … on my Catalina Mac, TeXShop typesets the project just fine WITH the misspelling of the LibertinusMaths font … and I’m scratching my head as to what is going on here … could there be two forms of the LibertinusMath(s) font? I still need to check the log file to see if there is an answer to this mystery …

On my M2 Mac, the TeXShop typesetter continues to choke on the LibertinusMaths (with an S) font, but has NO issue with the correct spelling of the LibertinusMath (no S) font … although there are other issues downstream from the \setmathfont[]{Libertinus Maths} line of code that I need to resolve.

Very interesting how the two Macs perform so differently with the same LaTeX code. Obviously the operating systems are 10 years apart, but I’m still a bit surprised.

And, I need to give a BIG Thank You for:

So many gems … I have a lot to review to try to absorb into my (now) LuaLaTeX projects! Thank you!!

As an aside, correct me if I am wrong, but what blows me away is how the entire Homebrew universe seems to be maintained by volunteers … My guess is they have day jobs, but I get the sense that Homebrew is a somewhat professional, unpaid side gig. What am I missing?

scrive
:thinking:

Happy to help!

Why your Catalina system works with the wrong font name is a true mystery indeed :upside_down_face:

Note for tlmgr there is also a nice GUI; I think it comes bundled with TeX Live, but can also be installed with BasicTeX or other minimal install: https://amaxwell.github.io/tlutility/

Yes, it is an amazing project with thousands of packages all rolling along with regular updates. They have great tool code (showing off how great the Ruby language is) that automates as much as is possible, but it is still grunt work for the more active core maintainers, they don’t get paid and i don’t quite know what the motivation is.

1 Like

I’ve been working through the many steps to typeset my Scrivener/LaTeX code using the LuaLaTeX typesetting engine …

I’ve located a number of helpful tools to help with the switch to LuaLaTeX.

I was a bit surprised to find that Homebrew has helpful with installing:

for help finding those missing font characters for LuaLaTeX, particularly with the \DeclareUnicodeCharacter code.

I also found helpful LuaLaTeX code:

I use the \pdfelapsedtime timer to find those areas of code that take the most time to typeset.

My guess is I’m somewhere between 1/4 to 1/3 of the way toward completing the conversion of my Scrivener/LaTeX code so that I may typeset using the LuaLaTeX engine.

Thank you for all your help and assistance,
scrive

1 Like