BETA 0.2.9 is now released.

This beta expires on the 30th Sept 2011.

There are many fixes and a few new features in this release. We have made good progress with Scrivener and are getting very close to official gold release.

If you’ve noticed that we seem to have skipped a few versions, well we’ve had a couple of internal releases between the last public release so that accounts for the 0.2.9 version number.

What follows is an enumeration on all the fixes that are contained in this release from the last public release.

Feel free to install this release right over the top of your previous Scrivener installation.
Download is here-> http://www.scrivenerforwindows.com


  1. The Linux release will be delayed and available early next week. If you must continue working on Scrivener after the 15th Aug 2011, you can set your system clock back a few days until the release is uploaded.

  2. KindleGen (i.e. eBook .MOBI format) is not part of the Scrivener installer due to licencing requirements and needs to be downloaded from: amazon.com/gp/feature.html?i … 1000234621 If you agree to the Amazon licence you can copy the KindleGen.exe for Windows or Linux into Scrivener\docformats directory and Scrivener will detect KindleGen and display the .mobi eBook format in the Compile file format combobox. Scrivener will work without theKindleGen executable, and the ePub format is not affected and built in by default. We will look at integrating the download of the KindleGen within Scrivener but we simply run out of time before this release.


  • The installer now caters for the rare PC’s that have never updated and do not have the C++ redistributable runtime dlls. This prevents runtime errors when Scrivener first starts.
  • The Check for Updates functionality has been completely re-written and is functional in this release. There is still an issue were a firewall can prevent Scrivener talking to download servers. Currently firewalls need to be disabled and we’re investigating the best way to overcome this.
  • The Help>Keep Up to Date functionality has been mostly implemented. What’s missing is more verbose explainations for subscribe and unsubscribe rather than just success or failure. Also, similar to update installer – firewall detection is required.
    *In the Options> General Tab having “Automatically name untitled documents upon saving” enabled doesn’t appear to be working. I have tried disabling it and turning it back on.
  • Draft, Research, and Trash still appearing in search results…
    *…empty search still returns all contents of the binder, etc. It should not be possible to run a search with no search term, but Windows Scrivener lets you do this if the operator is “Exact Phrase” and then gets some buggy results by pulling up everything in the binder including Draft, Research, and Trash, which should never be returned by a search or able to be put into a collection (which can happen here if you save the search).
  • Once you choose Hide “Getting Started” from the options menu, it’s just checked off–that’s probably fine, it will be clearer if it just switched to Show “Getting Started”
  • The category Getting Started is missing a space; it reads "GettingStarted
  • Creating a tutorial project: The pop-up message says "“Because you will make the tutorial project, you will work with a copy which will be saved to your hard drive” which is somewhat unclear; just use the same text as the Mac version, which starts: “Because you may make edits to the tutorial project”.
  • Footer icons, except for the inspector, are too close to the top of the footer–they should be centered vertically
    …Meta-Data dialog icon should be 3232 in top right.
  • There is currently no way to change colour of search results for collection - this should be an option in Options:Appearance
  • There is an issue though when hovering over the keywords icon in the main toolbar: unlike the others, it gets a grey overlay.
  • For new projects, all the columns are still open by default; this is too many. It should just have Title, Synopsis, Label and Status. This really annoys users as it takes a while to individually turn off each column, it’s much easier to turn the ones
  • When I closed Scrivener and deleted the tutorial project in order to try again, on clicking “Open” on the tutorial project from the start up window, I get a warning saying
    “Could Not Open Project: Documents File is not writable. Auto-saves need write permissions to your project.”
    When I close the warning, then I get the Tutorial message and everything continues normally.
  • The “new document” icon in the binder footer still looks like the wrong version (the correct 16x16 icon doesn’t have the T in it, I believe).
  • Tutorial is opening on Step 2: Header View (even though Start Here appears selected in the binder). That’s just an issue with what was loaded in the editor when the project was saved, but obviously it should start at the top so we need to fix that.
  • “Completing the Scrivener Setup Wizard” - Since the installation is finished at this point, wouldn’t this text make more sense as “Scrivener Setup Complete!” or similar?
  • Still some text in the license that’s showing up blocked. Copying the text and viewing in Notepad, it all looks fine, so it’s just the display in the installer.
  • There seem to be a few paragraph spacing issues in the license–most paragraphs are double spaced but in places they’re single spaced. Also some new paragraphs start indented with an extra space (e.g. “No advice or information” in section four) whereas most do not.
  • “The corkboard still seems to be using the texture from 1.x, rather than the brighter, crisper texture used in 2.0.” - I know this was marked changed for 026, but comparing the two it still looks like 1.x’s texture, so could you please double-check that you’ve got the right one from the Mac 2.0?
  • Typos in the Getting Started description for the Interactive Tutorial: “An interative tutorial” (should be “interactive”) and “Also avaliable from” (should be “available”)
  • the Text Statistics pane uses the Project Statistics icon
  • The menu says “Customize Toolbars…” in the plural but the panel says “Customize Toolbar” - it should be plural as well.
  • Collections: placement of the color chip should be slightly further left so it’s not appearing to touch the edge of the tab.
  • What size is the Scrivener icon that’s used in the left of all window titles? It looks a little blocky to me but it may just be that I’m viewing it on a tiny screen. Just double-check that it’s the appropriate size and not being sized down from a larger image.
  • BUG: I created the tutorial from the start-up window, clicked through the dialogue and chose a location. I saw the flicker of the project window outline but it vanished, and Scrivener closed with it. When I relaunched Scrivener, it automatically opened the tutorial (as most recently open). I deleted the tutorial and tried again with the same result–the outline of the project window flickers briefly and Scrivener closes.
  • Compile: The “Format As” and “Compile For” controls should be aligned at the left-edges.
  • Line up the right edge of the “Save…” button so that it is in line with the right edge of the list of options, and the let edge of “Load…” with the left edge of the list:
  • Whether or not the Compile options are expanded or collapsed should be remembered between sessions.
  • The “Folder” pop-up choosing control should be wider, and if the text of the selected folder won’t fit then it should be truncated with ellipses after it.
    *When using the rectangular rather than rounded style of card, the lines should go all the way from left to right - they are supposed to look like real index cards.
    *PDF - There should be last page/next page arrows. Plus remember page bwhen clicking away from PDF doc in binder – i.e. in session memory of last location.
  • Synopsis doesn’t wrap until you’ve double-clicked in it and then clicked away. Example: Open the Tutorial and view Part 1: on the outliner. You see only the first few words of the synopsis followed by “…”. This column should always wrap so the whole synopsis is visible. (This is especially important since in the corkboard the size of the synopsis area is limited by the index card, so the outliner is the only view where users can be assured of seeing the whole synopsis at once.)
  • “(Alt click to select or deslect all)”:
    • Should be “Alt-click” (hyphenated).
    • You should be allowed to select rows in the contents table, and Alt-clicking on a tickbox in one of those rows should tick or untick only selected documents.
  • There’s no option yet for saving outliner and corkboard settings or for preserving all meta-data appearance options this is extremely handy for switching layouts in the outliner.
  • — Related to this, the search term and perimeters for saved search collections should be displayed in the search field when that collection is being viewed: e.g. a saved search for “beta” in the “title” field should show “beta” in the search text field when viewing that collection and the drop-down menu should have “title” ticked. Currently saved searches in Windows have these settings cleared, so it is not possible for the user to know how the collection is being created. It also means that adjusting the perimeters automatically switches the collection to the results of an empty search (since the original search term is not in the text field).
    • note that the information is obviously saved somewhere, since the saved search updates properly according to the originally saved terms, it’s just not being properly displayed and is thus not able to have its perimeters updated appropriately
  • Still missing the document icons to show when there’s a snapshot (with the dog-earred page). Mac’s look like this
  • Modified date is not changed on a file unless meta-data is altered. To see this, open the inspector, load a document, note the date, and type a bit in the editor and then let autosave run. The date doesn’t change. Then check or uncheck “include in compile” in the inspector and the date instantly changes.
  • Modified date adjusts in outliner when it shouldn’t, just by clicking on it in the outliner. Load a folder into the outliner with the Modified Date column visible, and note the dates. Click on one row, then click a different one. The Modified Date on the first row changes as soon as you click away.
  • With no documents selected and the focus in the binder, you can choose File>Export and go all the way through saving, though nothing happens. The options in the submenu (Files… and Comments & Annotations…) should be grayed out if no document is selected.
  • When the focus is in the binder, with or without a selection, items in the Scrivener Link menu should be grayed out
  • Print Current Document should be grayed out if no document is selected
  • It’s still possible to lock the inspector on one split and then close that split and have the inspector locked on the closed split. The inspector lock should be broken if the editor split it is locked to is closed
    To see this:
  1. Open a project with split A and B
  2. With the focus on split A, lock the inspector
  3. Maximize split B (ie, close split A)
    The inspector is still locked and is showing the document that was in split A. Any subsequent changing of documents does not update the inspector, since they’re loading in what is technically split B, even though it’s now the single editor. What should happen here is that the inspector gets unlocked once split B is maximized in step 3.
  • Gear icon in the keyword header (in inspector) looks like it was resized down; it’s slightly fuzzy.
  • In the Project Targets panel, with the settings at 0, the progress bar continually, ah, progresses. I think if the targets are 0 there should be no activity, as a user might want to only set one or the other but will have to set both in order to avoid the distraction. (video to demonstrate what I get when opening the Project Targets panel fresh in the Tutorial: screencast.com/t/6PCIS4f5iLlk)
  • Keywords are automatically assigned a color when created, but Scrivener appears to only choose from a limited array of colors: a few shades of blue, a few shades of green, and black.
  • “Pressing buttons in the footer bar turns the white while held down, which is a bit odd - it looks as though they’ve lost colour. Shouldn’t they turn darker, or blue, or whatever the standard is on Windows?” - At any rate, it doesn’t seem consistent within Scrivener, as other buttons turn darker–specifically consider the footer buttons in the inspector. I’d go ahead and make the other footer buttons the same.
  • If a document title is too long for the editor header, the header should show the beginning of the title and truncate with an ellipsis. Currently it displays from somewhere in the middle to the end.
  • “In the corkboard, the drop area is a bit narrow. If you have four cards in a 3-across grid, when you drag one of the top three cards and try to drop it at the end, on the right of the fourth card, you have to drop it right next to the last card. If you don’t, and move the cursor too far over to the right, the drop line disappears. The drop area should be a bit more lenient, as in the Mac version.”
  • Courier in the format bar: According to the format bar, the new default font appears to be Courier New. I selected the text and changed it to Courier via the format bar; the font didn’t change in the editor but the new font name stuck even after switching documents. When I closed and reopened the project, however, it reverted to Courier New. Looking in Options, the default font is actually Courier. So this still seems to be a little off–the format bar is now reporting “Courier” as “Courier New”. (If I select the text it calls Courier New and choose F4 to bring up the font window, there it reports the font as Courier.)
    ‘HKEY_CURRENT_USER\Software\Scrivener’ KEY.


  • When importing a .html or .htm file from disk (as opposed to as a webpage), images get stripped out, appearing as the empty box with a question mark (broken reference link). Can this be fixed? (The same action works fine in the Mac version, and the images are inserted properly into the text.)
  • Images are often stripped out when using Import>Webpages as well (some on a page will get embedded, some will display as a broken file path)
  • Import>Webpage and dragging and dropping from the brower’s address bar into the binder don’t do the same thing. The former seems to save the page (often losing images in the process) and import that whereas the latter seems to simply supply a link to the online page, using the editor as a browser–if the computer is disconnected from the internet, that “imported” page no longer displays.
    Both these methods should produce the same result, and once the page is imported, the user should not need to go online to see it again.
    With import, many of the images don’t come through (some do, however, toward the bottom) but the text is available even after you disconnect from the internet. With the drag and drop, the entire webpage is viewable as in a browser but only if you have internet access.
  • Imported webpages should display their clickable url in the editor footer; clicking it should open the page in the default external browser. Once conversion of webpages to text is enabled, the link should be automatically stored in the document references as “Original Link” (and no longer appear in the footer).
  • Open>Original URL in Browser is still opening the imported file in the browser, not the original URL
    • Note that it does work as expected on a webpage that was imported via drag and drop (rather than Import>Webpage), because this method doesn’t really import the file; this is incorrect, however, as the two methods should produce the same result
  • The Open in External Editor button should be available in the footer for imported webpages
  • Import>Webpage is taking an extremely long time and the program goes temporarily unresponsive during the process. After the import, clicking on the document in the binder to load it in the editor again takes a long time and gets a Not Responding message in the title bar. I’ve attached performance specs for one of the the computers I tested this on (just printed off a page, I can gather anything else you’d like); Win 7 Pro 64 bit, standard account. (Drag and dropping a webpage from a browser into the binder and then loading it again later is nearly instantaneous, by comparison.)
  • Documents>Convert>Formatting to Default Text Style should be grayed out when non-text documents are selected, since this command does nothing on them when you run it.


  • Index cards when using the rounded theme should have light gray lines, not red and blue, and there should be an option added for blue and black lines when using square cards.
  • Missing option for placing the pin label indicator in the right or center when using square card theme
  • When “Cards Across” is set to “Auto”, the “Size to fit editor” option should be grayed out, as it doesn’t do anything in that case
  • Cards across menu in the Corkboard Options is missing “Other…” which should bring up a panel for Corkboard Layout allowing the user to enter a number (Display [ ] cards across)
  • Main toolbar options missing Layouts, Project Replace, Typewriter, Customize, Colors and the Flexible Space and Space options.
    • as mentioned earlier, since items can be placed in either the main toolbar or the format bar, you’re going to need two sets of icons for all of these so that nothing gets resized
    • also all the items in the menu itself in this panel need properly sized ions
  • The drop-down menu for the “Add” button doesn’t list a keyboard shortcut for “Existing Files…” but since one exists, it should be here as is done for adding web pages
  • “All” keyword search is still not working (I think you’re aware of this)
  • Search results should be listed in binder order; currently they come up seemingly random, probably ordered by their ID numbers
  • Missing the ability to click the header of a collection in the binder and load the collection in Scrivenings, outliner, or corkboard
  • Missing ability to convert imported webpages to text to make it editable.


14th Aug 2011

Thanks, Lee

Cool beans…everything appears to be working fine in wine/windows at the moment. Need more coffee to do anything else.

You rock.

YAAAYYY!! You’re my HERO!

Cool. On minor thing I thought you might like to know about: The download and install went with out a hitch. I unchecked the “open readme file” option but left the “start Scrivener” option checked when the installer told me it was done. Scrivener didn’t launch.

I launched it by clicking on the shortcut when it became apparent nothing was going to happen. Scrivener seems to be working fine. Like I said, minor issue, but I thought you would want to know about it. My have just been a fluke.

I am running on Windows 7

Well, keep up the good work, I will let you know if I find anything else (but I doubt I will)- Lunarclipper

Scrivener launched for me after I quit the readme window - did you leave the readme window open?

Will the templates ever be fixed? I have been having severe issues with compiling, formatting and layout being completely off. And as if that wasn’t enough, the character/location templates within it are also in an unusable state.

EDIT: The first described problem can be fixed by editing the lvl 1 text document formatting (in the compile options), removing title and page padding. As for the second, it looks like juxtaposed indent marks (show ruler to make them visible), which I have no idea how one would go about sorting out.

Could you please clarify something for me please about future plans.

Why not red and blue for rounded cards? I like using red and blue and my cards to have round edges? Why does this need to be changed, and please can we have the option to change back to current configuration if we so wish.

Great release so far… Already changed a few shortcuts :slight_smile:

Same. Unchecked the “Open readme file” but left “Start Scrivener” checked. Nothing happened. I had to click the shortcut for the program to open. So far everything looks great besides that, though.

Windows 7 here also.

Thanks for all the hard work, Lee!

There’s one thing that’s been an issue throughout all the betas. When you change the background for Fullscreen mode and then go to change the zoom on the view the range of numbers in the scroll menu is blacked out until you put the mouse over the values. The same thing happens with the paper position menu.

Using Windows XP, I unchecked the readme option but left “Start Scrivener” checked, and it did launch. So it might be a platform difference?

The comic book script template is completely broken in beta 029 :frowning:

I cannot switch to “Panel description” format and type a panel description. Tab does not work, if I choose panel description from the menu, it reverts to “panel number” once I start typing. :frowning:

I realize you must not have many customers using the comic template, but is there any way this can be fixed before a month and a half, or is there a work around I am missing? I’m thinking I’m otherwise going to have to revert to 026 and set my computer clock back in time? I don’t see how else I can edit my scripts in progress made with the template.

Here’s a youtube clip showing the problem:


I’ve tweaked the comic book script template a bit to make my own version, but I confirmed that this behavior occurs in the default template as well. Completely uninstalling and reinstalling didn’t help, either.

Incidentally, the template doesn’t respect bold formatting if selected for “panel number” in the options. This was previously reported, but its gotten worse in 029, previously you could hit backspace then start typing again and you’d get the bold formatting, now you never get it.

Looking great!

…but my beloved navigational keyboard shortcuts seem to be broken in Beta 029.

In Beta 026 I could use ALT+SHIFT+SIDE ARROWS to navigate do the next/previous document in the outline, while mantaining the focus on the main editor (see here).

I was hoping that in this version these navigational shortcuts would be working in fullscreen mode as well, but they don’t seem to be working in either of the two modes. :frowning:

Can someone confirm?

I applied Beta 029 without problems; the readme file appeared. At the same time I got a warning from my anti-virus/firewall application, which I gave approval to, but Scrivener didn’t start when I closed the readme. This has been consistent (but I can’t confirm 100%) through various new releases. My machine runs Window 7 (64 bit) with Zone Alarm Extreme (V 10.0.241, all bells and whistles turned on, including System Guard). Windows UAC is off. I wonder if the interruption by the anti-virus is enough to halt the launch of the application?

Interestingly when I installed Beta 029 on my laptop (Windows 7 (32 bit), Microsoft Firewall, Microsoft Essentials anti-virus, UAC turned on) the readme displayed, and Scrivener started automatically. I received no warning from the anti-virus/firewall software, only the UAC prompt at the beginning of the install.

Edit: Scrivener was installed under admin accounts on both machines. I use admin accounts for day to day use too (slapped wrists, I know, I know).

Will you be extending the NaNoWriMo winners’ coupon code again? The code currently expires on September 9, 2011.

NM…I’m an idiot. I had a setting wrong but I found it.

Please ignore this post. :slight_smile:

I’ve noticed something and this may be me looking in the wrong place, but the past number of betas, I haven’t been able to find an option in which I can change the default font and size for when I make a new document. It sets the font to either Courier New or Microsoft Sans Serif in size 12. I prefer to use Verdana, size 10. Before, I was able to find the setting for this, but now I can’t find it.

I use a Windows Vista laptop.

Where can I download 029 please :question:

The instruction in your post…

Feel free to install this release right over the top of your previous Scrivener installation.
Download is here-> scrivenerforwindows.com

leads to the 026 download page which returns a 404 error.

Also the update command on my 026 beta returns…

Connection failure

The remote content is not at the server (similar to 404)



Regarding my post about downloading 029…
I worked it out!
I went to the 026 download link and changed the URL to refer to O29 instead of 026 :smiley:

literatureandlatte.com/scriv … taller.exe


literatureandlatte.com/scriv … taller.exe

Elementary! 8)