$levelN_title losing underscore before processing in header & footer on compile to PDF

The “<$levelN_title>” works fine if I put it in my main document or as a prefix on a section layout, (I’ve tested multiple numbers.)

When I put it in the header or footer, instead of processing to show that level title, I’m getting “<$levelNtitle>”. Ergo, my interpretation of the bug. :slight_smile:

I’ve tried the various auto-search and replace settings (both in compile defaults and on compile), and those don’t touch it.

To replicate this error:

  • Select something with multiple levels for Compile.
  • Select a PDF format.
  • Go into Edit Format… > Page Settings > Header and Footer Text.
  • Use the “<$levelN_title>” in the header and/or footer area.
  • Compile.
  • You should then see “<$levelNtitle>” in the header and/or footer.

According to the complete placeholder list under the Help menu:

$levelN_title is listed under Document Variables, and so is not available in the headers and footers. I’d like to use the Document Variables in headers myself, which is how I found out. :frowning:

Ah. Missed that.

Still makes me wonder why the underscore gets stripped. Hmm.

Thanks! :slight_smile:

Because underscores and asterisks are used to create underlined, italicised and bold text in headers and footers.
All the best,
Keith