[LH#3430] Beta 14, Scrivener crashed and won't open

This has actually happened before - the second day after I had upgraded to the newest beta. I resorted to a clean reinstallation and it worked.

Now, after repeatedly crashing if I tinkered too much or for too long (3 to 4 minutes) with the compiling project settings, Scrivener has got fed up and refuses to open.

I get the initial window with the logo, the information of the beta (I click OK), then it gets past the font point all the way to getting the project I was working on - and that’s the last I hear from the program.

I can open a different project if I double click on it directly - but doing the same to the project I was working on gets me a very uncooperative Scrivener (it just stops and goes away).

Can anyone help me on how to get Scrivener to open this project? At least for me to export the last changes I’d made. :cry:

If you send me an archived copy to tiho at literatureandlatte.com, I might be able to help you and prevent it from happening in the future.

Do you mean a copy of the file in question? OK, then. Thanks. :slight_smile:

Thanks to Teresa, we found a problem caused by some of our recent startup project loading optimizations.

If you happen to experience the same problem please follow these steps:

  1. Navigate to your Files\Data project sub-folder and delete the “docs.checksum” file inside.
  2. Load your project in Scrivener as usual. It might take longer than usual but it should load.
  3. Run File > Save And Rebuild Indexes. This should create valid “docs.checksum” file

To avoid this problem from happening again, please switch to Corkboard or Outliner mode before closing Scrivener. Closing Scrivener in Scrivenings mode, sometimes crashes Scrivener upon shutdown, causing a crash upon next start up too. This has been fixed and the fix will be available in the next update Beta 15. We will try to release the update sooner than later.

Hi, I got a similar problem, which seems to be Dropbox related. Opening the project from the normal desktop is not a problem, opening it from Dropbox crashes the scrivener (generates minidumps). Is this related or an entirely new problem?

Edit: Deleted the checksum file and it worked. So could be indeed related.