[LH1604] Line Numbers obscure text


When I view line numbers (View|Text Editing|Show Line Numbers) they appear over the left side of the text instead of to the left of the document and obscure the left edge of the text.

Sorry if this is a duplicte report, but when I tried searching to see if “line number” was a topic, the forum would not let me search for a phrase, it searches instead for the word “line” and the word “number”. I was unable to tell if this has already been reported or not. There were 864 hits and I’m not about to look at all of them to see if one of them is the same.

Hello! Thanks for posting this. Can you please let me know what options appear when you look at File > Options > Appearance > Main Editor?

Thank you for your help in this.

Here is what I had

With your question as a hint I have changed the value of Editor Margins from 10 to 70 and the problem is solved. Not a bug, user experience level issue!

I’m not sure it isn’t a bug. I enabled line numbers and wasn’t happy that they actually touched the letters in what I was writing, so I bumped the default margin to 30. That seemed to fix the issue until I closed the program and then opened it again. Now the numbers were once again touching the letters.

Hoping to fool it, I reduced the margin and now the numbers overlap the letters. I can’t find any way to control the size of the area the numbers take up, so now I’m stuck. I’m afraid to make the margins wider as that might cause me even worse problems if the issue does it again.

Here is a screenshot after I reduced the margin size back to 20 and my settings. If this is operating as intended, it’s not clear how to regain control of the line numbering width.

Thank you for your help. This is indeed a bug and has been filed.

View > Text Editing > Show Line Numbers

the bug is still present




Implementing a feature similar to Notepad++, where the line numbers and the cursor/line indicator are prominently separated from the content, would be a practical approach. This would create an indented space between these elements and the content, eliminating the need for users to manually adjust their work, which is very time-consuming, as a workaround.

Thanks, I’ve merged this with the existing bug report. Please refer to the post above which contains tips on how to avoid it, that do not involve actually modifying the text formatting, as it seems you are suggesting doing.

As for just doing it like Notepad++, we probably would, if we were writing a plain-text coding editor in the same toolkit. The similarities are very much only skin deep here.

1 Like