[LH2306] Can't change font size after copy/pasting from certain apps

I’m running Scrivener for Windows Beta on a Microsoft Surface Book (the original, not 2). I’m having trouble changing the font size of text that I copied and pasted from some other apps.

I copied and pasted text from an email (from gmail open in Chrome) into an empty Scrivener text file. It was size 10, and I tried to change it to size 12, but after clicking on 12 in the drop-down, the size didn’t change, and the number stayed at 10.

I deleted the text, deleted the text file, and made a new text file, then repeated the process. Still didn’t work. I quit Scrivener and opened it again and then tried to change the font size, and that time it worked.

I tried to repeat the steps that got me to the bug in a new project. The same thing happened again. Then I tried some other copying and pasting: Chrome websites (not email), Discord, and Steam all yielded a similar bug, except that for all three of those, when I pasted the text, the font showed up as size -1 and wouldn’t change. Copy/pasting from Word, Visual Studio, and File Explorer didn’t cause the bug. So maybe it has something to do with being online? That’s the correlation I see there.

I hope this helps! And to anyone encountering this bug, just restarting Scrivener after the text is pasted worked for me.

Thanks. This has been filed.