[LH2533] Can only assign template folder when folder is nested under Research

In Scrivener 1.x, my Templates Folder was a root folder on the same level as Draft (i.e. not nested at all). In the Interactive Tutorial for, the “Sheets” folder (which is what we turn into a Template Folder) is nested under Research, and it is the only folder able to be selected as a Template Folder under Project Settings > Special Folders.

To test this, I made a new project from the “blank” template (i.e. without presets). I cannot assign any folder in the project as the Template Folder:

I create a second project from a Project Template (I used the “Short Story” template, which I think is a 1.x template) that does have a Template Folder assigned, but on the root (un-nested) level. The templates work (templates have the T logo, Ctrl + T, Ctrl +N work, and the “New from Template…” command works), but the Project Settings > Special Folders still doesn’t recognize it as a Template Folder.

However, going back to the newly-created blank project, as soon as I nest a folder underneath the Research folder, it can be assigned as the Template Folder. Nesting the folders under other non-Research folders doesn’t allow it to get recognized as a possible Template Folder.

I converted an old 1.x project to the beta, and sure enough, only folders I’d shuffled under Research were selectable as a Template Folder in Project Settings > Special Folders.

I’m on Windows 10 64-bit Home, sole user/admin. Version

Thanks, this is filed, On upgraded projects, the folder continues to behave as the template folder even though it is not shown properly in the Project Settings, so if you don’t need to change it you should be OK to keep working with those settings.

Thank you, Aurion. I’ve been wracking my brain over this today!
Problem solved. :smiley: