[LH2888] Stop right click from opening in current editor?

Is there (or will there be) any way to stop a mouse right click from opening a document in the current editor?

I can use right-clicking to open a binder document in a copyholder or quick reference panel. Great feature, except when I want that, I don’t want the current editor to also jump to that document–but I don’t have any choice. I would rather have the right click only open the context menu.

(I know I can set Binder Selection Affects to “None”, but that then makes it more difficult when I do want to open a document in the current editor.)

This is a bug and has been filed. Thanks!

This seems to be still happening. Right-clicking on a document in the Binder automatically opens that document in the editor.

I came here to see if this was a feature that can be turned off somewhere, and came across this here thread instead.

(Windows 10, Scrivener, 64-bit.)

It’s not really a “feature”, more a side-effect of how the tree view works. I suspect if it were easy to fix, it would already have been done.