[LH3166] Issues Compiling: Order scrambled using Current Selection -- Scrivener 3 for Windows

Odd problem occurring. When I compile the entire manuscript, the parts, sections, and scenes all show up in order. But, if I try to compile “Current Selection,” the entire order of the manuscript is completely scrambled. Anyone else seeing this? Any way I can fix it?


Thanks for the report! It doesn’t seem to always happen, depending possibly on the size of the selection, but I am able to reproduce it. In the meantime, two ways you might get around this:

  1. If all the selection are within containers (e.g. you’re a few “Chapter” folders), select just the containers in the binder, then tick the option in the compile contents to “Include Subdocuments” when compiling the current selection. That might be subject to the same bug, but in my quick tests it seemed to retain the binder order properly when selecting a few folders with a lot of subdocuments.

  2. You could create a temporary “Compile Me” collection with your selection, then select that collection from the menu in compile rather choosing “Current Selection”. That retains the collection order. You could also use the collection as a filter, so e.g. keep it set to compile the Draft, but then click the funnel icon to apply a filter and include only documents within the “Compile Me” collection. That will keep the binder order and hierarchy while still only including the items that are within the collection.