[LH3211] Text Scale in Composition Mode

When I start up Scrivener and go to full-screen composition mode, the text scaling does not match what is selected in the drop down. For example, if it’s set to 150% in the menu, the text itself is not 150%. Selecting a different scaling, then going back to 150% sets things to the right size, and everything is fine again. It’s just not correct when I first open composition mode.

I’m using beta on Windows 10.

Could you provide steps for reproducing this starting from a blank project? I haven’t been able to reproduce this, moving in and out of composition mode and switching the editor zooms in the main editor and composition mode, so there’s probably a particular step I’m missing in testing this. The composition mode editor’s zoom settings are separate from the main editor splits, but it doesn’t sound like that’s the issue–rather, the control bar in composition mode is reporting an incorrect zoom for the text when you first enter composition mode, yes? If you can share a way to trigger this, I’d be grateful!

Thanks for the help. After doing some more testing, it seems to only happen to me when I’m trying to view multiple bits of text. Like if I’ve clicked a folder (my chapter) containing multiple text documents, and then enter full screen from there. This problem does not seem to happen if I choose an individual piece of text and then go full screen.

Ah, thanks, that was the missing piece. I think this may just be another symptom of the issue of the editor zoom applying differently to Scrivenings and single text documents, complicated by the way items are loaded in composition mode. I’ve filed the bug.

Great, glad to be of assistance!