[LH3468] Scrivener Windows 14 Beta Bug - Default font not persisted

Hello Scrivener Devs,

Here’s what I’m seeing. Windows 10, Scrivener 14 Beta. Set the default style to Segoe UI 10. Applied it across my project. Checked. Project texts looked good. Exited and reoepned Scrivener and texts were back to Arial 10. Tried applying style change manually to texts. Looked good. Exited and reopened scrivener and texts were back to Arial 10.

The default style (Options> Editing > Formatting) is set to Segoe UI 10. That has persisted. However, no matter what, it seems like texts with a style setting of No Style default to Arial 10 on reopen.


Thanks. This has been filed.

Bob, can you please upload one small Scrivener project with one document and text inside after setting and saving the text with Segoe UI 10. In my tests the font loaded properly upon restart and I assume the post-script name of the Segoe UI font is for some reason not recognized. Have you installed any custom version of the Segoe UI font? Does it happen with any other default font that you set or only with Segoe UI? Thanks!

A number of us have been having that problem. See [url]https://forum.literatureandlatte.com/t/comparison-to-other-word-processors-and-writing-tools/68/1].

I can set No Style to any other font but Segoe UI, and that setting will persist. However, if I set it to Segoe UI, at any font size, after rebooting the computer and reloading Scrivener, I will see Arial when I type (at the moment).

It’s currently using Arial because I’ve reset Windows to use Segoe UI as the system font (Windows 10’s default). If I set the system font to something else (such as DejaVu Serif Condensed), Scrivener will use Calibri as its default (I know this because I tried it).

But this doesn’t happen to everyone.