[LH3571] Recent Issues with Compiling and Exporting Files

I installed the latest windows version after reformatting my hard drive last night. V16 Windows Beta

I can no longer export files nor can I compile anything other then what is in the manuscript section.

I have installed and reinstalled 3 times in the lat 24 hours, and some people are suggesting that I am the one at fault but I am not doing anything different then I have in the past.

Now I can export stiff one file at a time, but when you have a large file, doing it one piece at a time is annoying and it takes forever.

So what gives?

At least two pieces to this.


Confirming an Export problem.

During EXPORT (to .docx), I select the Draft/Manuscript folder, I do NOT check the box for “do not export subdocuments”. It says 4 folders and 55 documents will be exported. Click the button to do the export, and it says, “no files were exported.”

I think this is a bug. Perhaps export to .docx isn’t completely implemented?


The other, I cannot confirm, because I can compile just fine.

I managed to compile an entire project to .docx (Word format), including research files, etc. If you’re compiling to some other format, that might not work the same way. Here’s how I do it:

a. – Select the files you want in your compiled output. This could be as easy as Ctrl+A in the Binder. That would select all of them. If the project is large, wait until it finishes.

b. – Click compile (or, Ctrl+Shift+E).

c. – Top of the Compile Window, select your target. I choose Microsoft Word (.docx) for a variety of reasons. You might want something else. .docx is editable with WordPad, LibreOffice, and many word processors other than Word.

d. – Second column, bottom, click on Assign Layouts; be sure your section types are assigned properly. No assigned layouts can mean nothing in the output (did that a couple of times, too, some time ago). Be sure to click on “Show Unused Section Types.” Many of them you may assign to the same layout. “As is” might work if you just want your text as it is in the project.

e. – Third column, top, where it likely says “Manuscript”, click on the arrow and select “Current Selection.” If that’s not there, there’s a bug. It’s there in mine.

f. – Third column, left, top checkbox. Alt-click to clear or select all the little boxes below. Note, this may cause the Compile dialog box to show SAVE instead of COMPILE (a minor bug, but worth mentioning). If it does this, go ahead and save, because you’ll want it again, right? Open the Compile dialog box again and click Compile.

This works for me, and should give you Compiled output in Word format.

If that doesn’t work, there’s an issue.

You’ve reinstalled several times, so the install is likely fine (as long as it’s not commingled with Scrivener 1.9.x; that can cause serious issues).


Extra tip. If you need an export everything at once, to something like RTF format, use Sync to External Folder. Be sure to check the box “Sync all other text documents in the project”.

The output formats available are Plaintext, Rich Text, Final Draft, and Fountain (Screenplay Markup). I’d like to see HTML, also, but not implemented. When importing, non-manuscript import is into the Research folder, so stuff your non-Manuscript stuff into Research, and everything will be as expected (that includes Project Notes and Bookmarks, which is a bit odd).

Have any of rwfranz suggestions helped you? Or are you still experiencing this problem?

The issue with exporting multiple files has been filed.