[LH3685] Crash. Don't do this...

I managed to crash Scrivener, and I can duplicate it.

This involves a conversion from Scriv 1.9.x to 2.9.x.

  1. Open Scrivener.
  2. Use File Explorer (or some equivalent; I used MultiCommander, and then duplicated this with File Explorer, just to make sure it wasn’t the File Management software causing this), double-click on an older version file (v 1.9.x). I’ve got a few laying around, and I tried several. Each produced this result. In my case, double-clicking in File Explorer produced a slight blip of something, but did not invoke Scrivener to open the file (not sure how to force this to happen; it knows that .scrivx is a Scrivener file).
  3. Then use Scrivener to open the file directly. It’ll ask you if you want to update the format, but then it hangs.
  4. Watch the blue wheel spin, at ~10% of CPU (per Task Manager) forever.

Use Task Manager to end the task. It’s not so broken that it takes the system with it.

Hi rwfranz,

I am not able to replicate this on my machine, so there may be extra circumstances not listed in your steps.

Does this issue persist after a computer restart?

Also, do you have 1.9 installed on this computer?

Any other information you can think of may also be helpful to track down this problem. Thanks!

Haven’t checked yet. Maybe.

No. It was at one point, though.

Honestly, I have no idea. I wasn’t thinking of crashing the thing when I did it, but I think the file explorer process isn’t functioning correctly; when I open one of those files, it should just open Scrivener and go.

But… with Scrivener already open… oh, wait. Forgot something. Open Scrivener, and open the “Open Project” dialog; then do the thing with File Explorer. Then continue as I mentioned.

And, lest someone think this unreasonable, the dialog box for opening a project and the interface for File Explorer are remarkably similar, and if I don’t find the file I’m looking for in one, I might switch to the other, and double-click. And then, oops, that’s Explorer, not Scriv, and… well… Crash.

On further investigation, this is a general bug (or at least a problem; it might be a “bug” per se), not just affecting conversions.

When you use the Open Project function and have the “exploration” window open, if you try to open a project using File Explorer (or an equivalent), Scrivener will crash.

I rebooted, tried again (this time with a v3 project), and duplicated the problem.

I thought, maybe this is a Windows issue… tried with LibreOffice the same thing. Same problem? No. With that program, if I select a file with the “Open file” window, and I attempt to load something with the same NAME, it crashes (bug will be reported; it shouldn’t).

But in Scrivener, I didn’t even load a file, simply used the “Open an existing project” from the start dialog box, didn’t load anything (leaving the window open), and then opened a project using File Explorer. The project loaded (sort of – i could see in the thumbnail that something was open and it looked about right), and Scrivener crashed.

Thanks! That was the missing piece. This has been filed.