[LH3896] Line Numbers

There is an inconsistency using line numbers.
In ‘View-Text Editing-Page View’, the line numbers are well to the LHS. No problem.
In 'View-Text Editing-NOT Page View, the line numbers overlap the text. First character obscured.

Interesting.
When I show line numbers, they’re in the left side frame, and they’re not line numbers. They’re paragraph numbers.

Here’s pics of the screen in both modes. (note, both are below paragraph count 100. Above 99, things get more interesting, and show a different bug)

Scriv_line_numbers_PV.JPG

Here’s what happens at 1000 (not using fixed-width editor):


Note that you can’t see half the hundreds column, and you can’t see the thousands column at all.
I doubt that many will write that many paragraphs in one document, but the problem is evident when you’re above 99; only half the hundreds column shows.

Several bugs here: Line numbers aren’t line numbers. If they were line numbers, then every line would show a number, not every paragraph.

In legal pleadings, every line is typically numbered, regardless of whether it’s empty of text, and regardless of whether it’s a new paragraph.
See https://www.google.com/url?sa=i&rct=j&q=&esrc=s&source=images&cd=&ved=2ahUKEwif4ofXi_XmAhVWpZ4KHbOfAvAQjRx6BAgBEAQ&url=https%3A%2F%2Fwww.expertlawfirm.com%2Fcase-study-orange-county-dui-dismissed%2F&psig=AOvVaw0ZVGKUcU07R5xI5eYBvT1Z&ust=1578610249157562 for an example.

So there are bugs here.

  1. Line number number paragraphs only if there’s text in them. Most documents that are line numbered number every line regardless of whether there’s text in them.
  2. Line numbers overflow the area they’re assigned when NOT using a fixed-width editor.
  3. “Line numbers” do not number lines, but instead number paragraphs.

Note that line numbers do not overflow their assigned area in a FIXED-width editor.
However… the other two problems still persist.

I managed to reproduce the OP’s problem, where the line numbers obscure the text. Reduce the margins in the editor to zero (0). The greyed box for the line numbers uses the margin space. I believe this should be automatic – and the left margin should be changed depending on many numbers are being used. Perhaps this should be a checkbox (for those who don’t find it annoying).

So, fourth bug:
4. Line numbering column should automatically add margin space so it doesn’t obscure text.

For the OP, a workaround: add margin space (Options | Appearance | Main Editor (5th option on left in appearance tab) | second line on page). 20 points is sufficient without a fixed-width editor. If you’re using a fixed-width editor, you’ll need 40 or more.

This is added to show a shot of the margins issue.
Scriv_noPV_ln_noMargins.JPG

This may happen whether or not you’re using a fixed-width editor. I noticed it in a fixed-width editor, after I squished it (larger inspector column), and reduced the margins to zero. and when I removed my normal 20 pixel margin width in a non-fixed-width editor, I saw this.

You’ll notice the word “father” (second line) has 2 letters and part of the third obscured. The entire left two letters of the document are obscured by the grey border area.

Also, 5th bug. “Line” numbers do not print.

There is a known issue with the line numbering bar not taking into account margin settings. It means you cannot use smaller margins if you intend to use this feature, until it is fixed.