[LH4161] Beta 28 Win 7: Crash on compile when only a single subdocument is selected.

Windows 7 Enterprise Service Pack 1
Beta 28, version
Replicated across multiple Scrivener projects and multiple files.

Open project.
Go to File > Compile
Go to “Compile:” (the little drop-down menu next to the filter symbol at the top right of the compile dialog that says “Draft” by default)
Select Draft>Folder>Single File
(i.e. drill down through the selection menu until the last possible layer and select a single file at the bottom of the tree. It does not seem to matter how many layers deep it is )
Select “Compile” (I have it set to Word Docx, I changed no other defaults in the compile.)
Dialog opens for me to save the file. Give it a name and proceed. Scrivener does a rapid shut down. No compiled file is created, Scrivener is closed. (No data loss on reopening.)

I noticed that if a folder is selected in the that drop down, the files in that folder appear listed in the compile dialog files list pane, However, when a single file is selected as above, the name of the file appears in the drop-down but nothing shows below in the compile dialog files list pane - that pane is empty. (See image: imgur.com/a/OtBxF9V - note that a file named “1.5.4. Is the S…” is selected in the drop-down, nothing in the pane.)

I tried doing compiles in the same projects with multiple files selected, including the individual files involved in the crashes above, and it worked fine, so it does not appear to be to do with a property of a particular file; it appears to be simply the fact that only one file is selected.

I also tried selecting just one file by unchecking all the others in the compile dialog files list pane, leaving just one checked, with “Draft” selected in the drop down above the pane, and this worked fine too. So it appears to not be a matter of only compiling one file; it appears that it is a matter of one file being selected through the drop-down.

Thanks. This has been filed.