[LH4313] Problem Copying Inline Annotation


In split screen, I just tried copying a paragraph that included a couple of lines set as inline annotation from one part of the screen displaying the original document to another part with a new document, which led to the annotation text being red, but the border around the inline annotation being placed several lines further down.

Repeating the process gets the same result. Deleting the inline annotation in the new document, selecting the text anew and setting it to inline annotation again leads to the same result as well.

[attachment=0]Bug Copying Inline Annotation.JPG[/attachment]

Couldn’t find anything like this, so I hope I’m not double posting.

Best, Anna

ETA: It doesn’t happen every time. I just copied another paragraph with a shorter inline annotation and that was copied correctly. The border that was added too far down stays there even when I write ‘behind’ it without affecting the new text.

Thanks for the report! In the source text, what is the line spacing for the paragraph containing the annotation? Is that set to an exact amount or a multiple? Are you seeing this most often when pasting as a new paragraph into your end text vs. when pasting into an existing paragraph? (That would also suggest line spacing is an issue, since paragraph settings like that would be lost if pasting into the middle of an existing paragraph.) I was able to reproduce this with an exact line spacing, and we do have an open ticket related to various text decorations like this not drawing correctly related to the spacing, so I expect this is part of the same problem, but I’d like to include any other specifics you may have observed!

I’m sorry, I did not see this reply before now.

I just came back to see what I reported originally because I’m now working in split screen mode and haven’t copied anything but still see a lot of misplaced (and thus unchangeable) inline annotation and footnote marker. I also just realised that the page view document (left side in screenshot) I had open when I changed to split screen did not open as page view in the second window (s. screenshot). This might have something to do with it?

As to your questions in case it’s still relevant: My line spacing for the whole document is and has been “1.0x 0.0/6.0” Does that answer that question?
As for pasting into paragraph vs pasting into end text - I only noticed it that one time. I just tried both and both worked fine.

[attachment=0]Problem Inline annotation and footnotes marker in split screen.JPG[/attachment]