[LH4521] Automatic backups STILL not working

It seems like my bug report of March 4 has been ignored? Not a single response.


And the problem has survived two updates now. As of version, automatic backups do not work.

They used to.

I have options set to backup on project close, as you can see…

It used to be that if I opened a project, made no changes, and closed it, no backup would occur. That was fine. Otherwise, closing a project always created a backup.

The only way I can create a backup now is File/Back Up/Backup Now or Back Up To.

So there’s been some improvement because on March 4 File/Back Up/Backup Now wasn’t working. Now it is.

Please fix this.

Automatic backups have always worked for me since I began using the beta, which was 3rd or 4th quarter last year. They’ve never not worked for me.

This doesn’t invalidate your experience, but it does indicate the problem is not universal. And the fact there there seems to be only two reports points, in my opinion, more to something specific in your environment than a widespread problem.

Also, I question your verification method. I don’t always see the pop-up, yet when I go to the backup folder, the backups are always there.

Since you didn’t explicitly mention it: If you go open the backup folder from Settings, is the folder empty? File > Options > Backup > Open backup folder


One other item to check: you can have a per-project override to the backup folder location. On the project you are using, is that filled in and thus the backups are going to a different location than expected?

Backups work here, and have for some time.

Make sure the path for your backup exists and can be written to by Scrivener.
Make sure the path for the project backup (in Project Settings [Ctrl+shift+F12]) is set to where you want it (or, if you don’t want a separate project backup directory, unset).
Make sure the project is not excluded from automatic backup (first checkbox in Project > Project Settings > Backup).

I think those are the only settings in Scrivener that govern automatic backups. However, Windows might have some settings that affect Scrivener (directories might be locked or have strange permissions or the like.

Whether or not you’re running Scrivener as admin can also adversely affect your experience, depending on where you have those backup directories set to – if you’re trying to write backups to a directory that requires Admin access, that’s going to be a no-go. This is one of the reasons I recommend people use folders under their user’s home directories (preferably under Documents) rather than at the root of a drive if possible; the root permission inheritance can be really hard to untangle, even if it does make paths smaller and easier to manage.

Well Jim, I question your questioning my verification method. My verification method was not as you assumed. I actually go look for a backup file. No file. So I really don’t care about the little panel and progress meter. I was just reporting what actually happened and what I saw in case it might be informative. It wasn’t a request for editorial.

And yeah, your response was invalidating. Especially since my machine is brand new, fresh copy of Windows 10 Home, everything otherwise running great. So if Scrivener can’t work flawlessly on a clean machine, how is that my problem?

And at the same time, YOU DA MAN, because despite your tone and trivializing, you accidentally led me to the culprit.

I never use the File > Options > Backup > Open backup folder button, since I use another way to verify the creation of files no matter how they were created. But I did try it at your prompting and discovered the problem.

And it is Scrivener’s problem, not user error.

I had changed the location of my backup folder from a "D:" drive designation to an "E:" drive designation when I set up my new PC.

Scrivener couldn’t find the no-longer-existing folder during an automatic backup, nor during a Back Up Now, but of course, with Back Up To you specify the folder location, which I did, so I could manually backup to my E:\ drive location. And Scrivener remembered that location.

So this is very strange. Scrivener keeps track of the backup location in two separate places. Scrivener does not tell you it can’t find the backup location, neither in an automatic backup nor during a Back Up Now. It says absolutely nothing about the fact, just pretends it doesn’t know what it means to do a backup, or that you never told it to do one. It only tells you about it when you click the Open backup folder button.

Well, now I’m good, it’s working, and you still have a bug to fix. Prolly low on the priority list, but a bug nonetheless.

And while I’m still mildly pissed, I’d like to point out to you guys that it took SIX weeks and TWO bug reports to get even ONE response out of you about a problem which is by no means trivial. Not like the way the CTRL-SHIFT-8 to show where you are in the binder keeps changing and getting less and less visible and useful instead of more. Or a shitload of other things like that which I don’t have time to bitch about, lol. For example, a problem with comments I reported last year, got fixed, returned again, where you can delete a comment but if it was created while a whole paragraph (including the ever-invisible paragraph mark) was selected, the comment keeps resurrecting. Things like that.

Glad you figured out your problem, skeptic23, but I’ve got no bug to fix, as I’m a customer, just like you.

Sorry you found my tone trivializing, that was definitely not my intent. I actually made no assumptions, I was just going by what you wrote in the bug report.

I specifically had you press the button, because a) you didn’t mention actually looking in the folder, and b) to confirm the path. Glad it worked out. :slight_smile:


Fair enough man, and yeah I now see the “I’m just a customer” signoff. I guess you’ve been confused for a tech before. So my comments weren’t rightfully to you, but damn! Six weeks with no response. They’re directed at someone. And they still have a bug to fix.

Not alerting to a non-existent backup location indeed sounds like an error, one that is fairly easy to fix.

However, Back Up To opens a separate file dialog resource that is provided by the OS (passed through Qt), It is pretty standard behavior that those dialog resources remember the last location that you invoked them against (at least during the same run of the program), depending on what type of resource you open it. I would not expect that dialog to be tied into the Scrivener default (or the project-specific default) backup location, because the whole point of that dialog is to immediately make a backup somewhere else.

This has been filed. Thanks.