[LH4604] RC7 - Local links within web pages now misfire

Hi - Scrivener RC7 has curtailed a very powerful and useful capability: clicked links in HTML docs no longer load in Scrivener’s own panes. If they’re external http:///, they display in the default browser; if they’re local file:///, they now “open” uselessly in Windows File Explorer.

There’s a new checkbox in Options: Behaviors > Navigation > Allow limited navigation in web pages . Please, what does that mean, and why the change? The checkbox has no obvious effect; there’s no documentation for it, and I’m really hoping we can restore the same behavior we’ve relied on all through the beta cycle. Back context button and Meta Refresh all worked like a dream in the web pane through RC6. RC7 is way too late to scuttle a capability so essential.

My research material is in the form of a local wiki, and the ability to navigate through it in the secondary pane, and across projects, is, for me, a huge part of what makes Scrivener Scrivener. The research informs the writing. I don’t want to traverse these docs in Firefox or File Explorer. I need 'em in my writing environment: in Scrivener’s left pane.

Thanks for any insights and support on what seems like a major wrong turn in the design.

Rgds - Jerome

Update: I did a mass convert of my indirectly displayed HTML docs from the Meta Refresh approach to the Research Files as Shortcuts approach, and everything works splendidly and more quickly than before. With the shortcuts working, the “Allow Limited Navigation in Web Pages” setting replicates the previous default behavior, and my research wiki is back on.

The bug on copying Windows Shortcut “docs” from project to project does need attention though:

RC7 - Dragging doc of type “Research File as Shortcut” between projects creates a dead document

Otherwise, all good. Just had to modernize the docflow a bit.

Rgds - Jerome

Update 2: I had it right the first time. This is a real bug. RC7 ignores our initial toggle for Allow limited navigation in web pages , and treats the setting as if it were turned off.

If the toggle is initially checked, we must uncheck it, select Apply, check it again, and select OK before our local html links open in Scrivener. Otherwise they’ll misfire and open in File Explorer.

I’ve attached a zipped demo project to test and confirm.

Rgds - Jerome

LinkBugDemo.scriv.zip (27.7 KB)

Thanks, I’ve filed the bug of the “Allow limited navigation in webpages” option needing to be continually reneabled. The other bug regarding copying imported shortcuts between projects is also on file.

Regarding the webpage navigation, although it seems like you’ve got it working aside from the bug, the Windows user manual hasn’t been updated with this yet, but here’s the relevant bit from the Mac version for anyone interested:

I wonder whether, for the sake of clarity, and for the sanity of grammar-obsessed writers (the two of us who are still standing), the sentence fragment I’ve underlined in the quote from the manual might be attached to the sentence before it:

Thank you for considering my humble yet anxious request.
<thinks_he’s_funny>Of course, I realize that this might be just a bit of Mac laid-back, too-cool-for-school styling. I still think it ought to be edited for the more anal retentive Windows world where I live.</thinks_he’s_funny>

Hahaha ahhh no, that was my failure when copying and pasting from a PDF with footnotes and trying to clean it up. Somewhere I dropped part of the sentence. It should be:

Sorry about that! :smiley:

:smiley: No biggie. It’s a little comforting to know that even MM is capable of error, actually. :laughing: