[LH4777] Question: How do I get my cover art into the cover file?

In the template(s) you provide, there is under front matter-> ebook a specific file for the cover.
Your file has the example cover picture at the side under the inspector as well as in the file itself.
How do I get my own cover there?
Under the inspector at the side, I can exchange your cover picture with my own, but it doesn’t show in the file itself - there is still yours.
How does this thing with the sdpecial cover file under ebook work?

Simply add your desired cover image as a Binder document inside the “Research” folder(simple drag and drop inside the Bidner will do) and select it from the “Cover Image” dropdown box when compiling to ePub.

And then what?
How do I get it from there to a valid epub file?

I get this:
ERROR ./tmp/uploads/1604936749856_0000016592/inputFile/coverimresearchfolder.epub/OPS/content.opf
37 106 :Error while parsing file: attribute “properties” not allowed here; expected attribute “fallback”, “fallback-style”, “required-modules” or “required-namespace”

ERROR ./tmp/uploads/1604936749856_0000016592/inputFile/coverimresearchfolder.epub/OPS/cover.xhtml :- - Irregular DOCTYPE: found ‘’, expected ‘’.

ERROR ./tmp/uploads/1604936749856_0000016592/inputFile/coveri
6 33 Error while parsing file: attribute “charset” not allowed here; expected attribute “content”, “dir”, “http-equiv”, “lang”, “name”, “scheme” or "xml:lang

As of RC 19 this isn’t working for me either: I get the following two messages when I attempt a drag and drop of my cover file ( which is a PNG; does it need to be JPEG instead?):

"Please note that text files that are imported will be converted to RTF for editing. This can cause certain attachment data, such as images and footnotes, to be lost for some text file types. Also note that the manuscript folder does not support media files. Media files should be imported into the Research folder."

Clicking OK then brings up.

Cannot import files from within current project. The set of files being imported contain files that are within the current project folder. These files will not be imported.”

Click on that image cover, then go to

File → Import → Files

And paste your cover that way. Worked for me. :slight_smile:

[strike]Well, for me, after selecting my cover I get a message about “Text files that are imported will be converted to RTF for editing,” Clicking OK changes nothing. (I tried with both a PNG and a JPEG file.),[/strike]

You meant literal Paste??!!

After which the default cover needs to be selected, then right-clicked and Cut. ?

(IMO, this is byzantine for such a universal function. And if it’s a simple " select the existing default cover and then replace it with a Paste action, then why the need to go through the menu’s “Import → Files” command?)

SELECT the image cover document in the Research folder in the Binder. The Draft folder cannot contain and import images. You have a wrong selection when you attempt the import.

As I noted in my earlier comment in this topic, I am unable to add the file for my cover to the Research folder.

(Also, the default cover of the provided template is in the Front matter—which makes utter sense to me—whereas placing the actual/replacement file elsewhere… does not.)

When I click OK on that message, my cover appears in the folder directly under the default template. All you need to do then is delete the original

Yes, this sounds great, and when I look at my binder I see the cover image I finally got to show up … however, after compile the Kindle Previewer shows the default cover image from the template.

Hmm. I got adding a cover image to work, on Epub3 and Kindle, but it’s not ‘Simply’ done as proposed, and there is at least one definite bug as you are seeing, along with other issues. I’ve needed to know how for plans, so here’s how I worked through trying it.

  • I attempted to ‘simply’ ‘import’ cover images to Research.

    • I immediately got the false alert about text files, RTF conversion, and potential loss of images.

    • This alert came whether I drag-dropped or Added the images. There was no ‘import’ as mentioned to be found.

    • However, accepting the faux alert got the images actually added to Research, as desired.

  • Then n the Compile dialog, I had to search out the tiny pictorial icon, in the subpanel to the right. When that tab was clicked, then the subpanel showed a Cover Image title, and under that was a dropdown. This defaulted to one of its choices about not having a cover image, but also offered my images when clicked, one of which I selected.

    • A caveat is that you have to check the box for an ‘HTML cover page’ which appears if you have begin by selecting Compile for Epub3 – otherwise there will be no cover page or image at all.

    = Further, I think for any Ebook compile, you have to select something other than the Default for the Format, on the left subpanel of the Compile dialog. Otherwise you get no structuring at all, just your texts mashed together, and no Cover will appear.

  • What are the results, then, if you do as above?

    • Viewers will open if present, showing your book at its beginning, so that you need to click for previous pages to see the cover. Kindle viewer can take a while to open if you have a lot of titles from Amazon, but it does arrive, while a busy cursor properly warns to wait. I had Calibre set for Epub books, and it came up rapidly.

    • Cover images do appear, when you page to them

    • For the Kindle result, the image shows on the cover page at full height, and at its original width. I suspect this may mean the need to make the original image properly at the ebook’s proportions. This is something to learn about, no doubt, in the arcane knowledge of ebook presentations, but at least it does look nice, and maybe over-width covers are ok, to a degree?

    • For the Epub3 result, a bit less happy. The image was quite reduced in size, and hard against the left edge, while centered in its smallness vertically. I don’t see that we’re meant to alter the HTML, so again the key may be to providing an image that is in proportion to the nominal ebook page. As part of the arcane skill set, to understand what that proportion might actually be, since there are many alternate viewer possiblities? But this is probably not in Scrivener’s area to contribute, unless it is…

Ok, there you have it, if useful, as I did at least get the cover images to appear, more or less per official instructions.

I’m sure Tiho will get to the false ‘import’ naming and alert, and then probably in the lore of the forum will have the picture as to how to really get your own pictures to work as covers most effectively. For another day…

[apologies for the formatting, if needed - I could not get actually nested lists to work in the forum]

Refprmatted the above, if it was hard to read…fun with the forum was had…

You have to delete the original cover.

Then you select your cover when you go to compile, it’s one of the icons on the top right.

Not strictly true. You can have multiple cover images and in the compile window select the covers tab and select the cover you want. Options include first image in the folder or specific image. I’m on iPad at moment do can’t give the specific steps, but you should be able to follow.

Yes, that’s how it’s appeared in the Compile interface, and worked for me.

Hence my careful notes above, about identifying that tiny symbol tab for the images, and how you actually get the ‘dropdown’ to choose which to use of your list.

I’m trying add a cover to a Mobi (from Ebook format) compile. Despite reading this long thread I’m still not clear how to do it.

Q1 - Where should the image live?
One cannot put an image in the Manuscript folder, yet that’s where my template has a “Front Matter” folder, which behaves properly for the text in it. I was able to “Insert Image Linked to File” onto a page, but that wouldn’t compile.

I created a folder called "Front Matter"in the “Research” folder and was able to drag my jpg file there
The image did not appear when attempting to select in the cover panel in the compile window.

Q2 - Is the Cover Panel Working Properly
In the dropdown menu I have only two choices

  • “First Image in the Front Matter Folder”
  • “No cover image”
    I’m unable to click to select an image despite what’s being said in the thread.

The Front Matter folder should live at the top level, co-equal with Draft, Research, and Trash—not inside any of them. This is how it’s placed in the Fiction templates.

Hope this helps!

That makes all the difference. Thank you.