[LH4796] Text cut off in Scrivenings

The last two betas have a new problem… the text is cut off even when there’s no reason for it. Note how far the the blue bar at the top goes.

I’m seeing the same thing, but only in projects that were imported from Scrivener 1.9.

I’ve tried converting the documents to default text and that didn’t help.

ETA: But, I realized we’d been using folders instead of text documents in our original structure and when I converted those to text documents, the cut off text stopped being a problem.

So maybe this only applies to folders for some reason.

Okay, now that is interesting.

I have several levels of folders. Under the “Draft” section, I have a top-level folder for this book, which has some inline chapters (text files), and some folders, which in turn have text files.

If I view a specific chapter in a nested folder, all looks well. But if I view it as the folder, where it runs the chapters in that folder serially on-screen, I get the cut-off text.

I can demonstrate this easily, and would be happy to do a Zoom screen-share if it will help.

(Not related, but another interesting thing is that ProWritingAid’s extension wants to sprinkle these odd characters at every line: )

Glad to know I’m not the only having this cut off text issue. I thought I was going mad for a while.

Thanks for the report. This came up in the previous beta and some adjustments were made for the current RC14 release which seemed to fix the problem, but if you’re still getting this it sounds like only some of the symptoms were corrected. Beyond the requirement of being in Scrivenings mode (what you’re describing when having a container selected to show its subdocuments’ texts in the editor), the editor zoom and editor margin settings may both be factors. Could you try adjusting these to see if or how it affects the cutoff? The zoom can be changed in the editor footer or via the View menu; the editor margins are set in File > Options under the Main Editor section of the Appearance tab.

It may also matter whether you’re using the regular or non-HiDPI version of Scrivener. I’m assuming the former, which is the one the auto-updater installs, but please let us know if you downloaded the non-HiDPI version instead.

If you can create a small test project to zip and upload that demonstrates the issue, that would be a great help also. You can use File > Back Up > Back Up To… from within the project to zip a copy that can be attached here or sent to win3beta@literatureandlatte.com (with a reference back to this thread).

Hi, Jennifer. The problem reproduces easily between 90% and 125% zoom. I don’t see it above that, but that’s pretty big. It’s also hard to verify because changing the zoom, even when the editor is massively-wide, reflows and rewraps the text, which seems odd.

Version: Beta (1155038) 64-bit - 30 Dec 2020
I did nothing to choose an HDPI or non-HDPI version.

I am running 4K monitors.

Demo project is attached. Open up the “Summer Job” folder and you should see it on the first line.

@MimeticMouton, did this give you what you needed?

Sorry for the delayed reply! Thanks for the project. This looked fine with the default program preference settings, but by setting the editor left/right margin to 0, I can see the text getting cut off on the right side in Scrivenings mode. It’s only occurring for me on the righthand side–is that what you’re seeing? (With a 0 margin the text is certainly right up against the left edge of the editor, but not cut off. This is different from what I was seeing in earlier testing on a similar report, whereby the text could actually be shifted right/left sometimes from a trackpad scroll or in typing and might cause the left side to appear cut off a well.)

Increasing the editor margin fixes the issue; how much an increase depends on the zoom level, but on my screen at least, a 20pt left/right margin is enough show all the text at 125% for both the regular and fixed-width editor settings. For a lower zoom, 10pt is sufficient. If you haven’t, try playing with that setting under the Appearance tab of File > Options and see if you can find something that allows all your text to be visible–that would help confirm the specifics of the bug as well as give you a workaround until it’s fixed.

Yes, I’m only seeing the cut-off text on the right.

Sadly, even after looking, I have no idea how to change the margins for all current documents. Those controls seem disabled. I haven’t even found it in the manual. The closest I’ve found is Documents - Convert, but this looks like it would reset a lot more than just margins… such as wiping out italics?

What’s the magic trick? 8)

In File > Options, select Appearance, then Main Editor from the list on the left. There’s a Left/Right margin setting and a Top/Bottom setting, both of which affect the editor globally. It’s basically padding around the box, separate from the paragraph formatting (tabs and indentations, which could be affected by the conversion tool).

Same issue here, impacting on Files as well as folders. Switching the padding to 0 seems to fix it; in-text margins ensure that the letters don’t bump the window edges.

The new beta does not solve the problem. My settings were 10 pts; setting it to 30 does solve it, but going back to 10 pts it reappears.

The workaround seems to be to set the right margin of the text - File, Options, Editing, Format - such that it is well inside the text area.

@Zornhau, from my screen shot a few weeks ago, you can see it’s already well inside.

Having the same problem in RC15, on folders in scrivenings view (does not reproduce when viewing the texts within that folder individually). It stops if I zoom in to 175% but reappears on zooming out. Changing the editor margins makes no difference.

Confirming that this continues in RC16.