[LH4923] Scrivener 3 for Windows -- styles compiling to Word

After days of work, I have finally created a template that exports to DOCX exactly as I want it – basic fiction manuscript format, of course. My only obstacle now is that the styles I’ve set up in the compiler do not translate into the DOCX, which is a problem for two reasons: 1) it creates a flat document with no outline capabilities, and 2) it makes styles very hard to change in Word if I can’t easily select all chapter headings, for instance.

To be honest, I find the whole compilation/style process in Scrivener to be a bit obtuse – there are so many layers of style, for instance! – so I’m probably missing something obvious. But as far as I can tell, I’ve done everything I can to translate those styles to Word, and they’re just not going. (I have created sections in the project, styles in the compiler, assigned styles to those sections, etc. I’ve used new style names, like Chapter, and existing style names, like Heading 2. Still nothing. Any advice would be lovely!

If it would be useful, I can upload my .scrivx template here, but I’m not sure if the compile settings will go with it?

Styles carry over to Word on the Mac and they should on Windows as well.

Uploading the .scrivx (Binder index) file would be useless. Zip the .scriv project folder instead. Compile formats carry over if they’re saved to Project Formats (see the attachment). If they’re saved to My Formats, they’re available to all projects on your device but are not embedded in any specific project, so they’re not portable.

[attachment=0]Project Formats.png[/attachment]

I’m not sure what’s going on, but it sounds like there may be some potential over-complication getting in the way, given how you describe things, because in general practice it should be fairly straightforward:

  1. You style something in the editor, it comes out that way in the file. So like any word processor there.
  2. Or, you make a style in the compile settings (for headings, as a common example), and it comes out that way in the file.

The only slightly more complicated variation is a combination of the above, and where one might consider things to be having “so many layers of style”: that is if you create a style in your compile settings that changes how a style looks from the project. But that’s it though, just one single layer of override, which is where I wonder if maybe there somehow an unnecessary degree of potentially conflicting settings getting in the way. I’m having a hard time thinking of how that could be done though.

Of course two “is it plugged in” level of things to check are: make sure you have Include styles information in exported file enabled in the Styles compile format pane (upper right corner; gear button), and Do not include stylesheet information is disabled in the Sharing: Export settings tab.

For hierarchical headings, the only thing that works is “Heading 1”, “Heading 2”, “Heading 3” and so on.

I’ve attached a simple test project that does two levels of hierarchy, and has a couple of custom styles coming from the editor text. As you can see I don’t need layers of styles anywhere. I could if I wanted to, add an override for “Highlight”, but I don’t need to.

One small disclaimer is that I only compiled using RTF, which is all you really need for Word and most word processors really. DOCX adds unnecessary third-party conversion complication between these two programs—though it should be handling styles fine.

You would definitely need the entire project (like how I attached) to include sample content and compile settings. The .scrivx is kind of useless by itself for most things.

Here is the Styles pane option Ioa mentioned above.

[attachment=0]Screen Shot 2021-03-02 at 17.50.59.png[/attachment]

Ah, I think I figured out a lot of my problems – two more questions, though, both of which I doubt are possible in Scrivener.

First, is it possible to assign a style to section separators? (For instance, separators between scenes should have a Heading style, so they appear in the hierarchy rather as body text.)

Second, is it possible to change styles based on structure? (For instance, in a novel that has parts, parts should be Heading 1, chapters heading 2, and scenes heading 3. But in a novel with no parts, the headings should be decremented – chapters would be heading 1 and scenes heading 2.

Alas no, for both cases.

Separators only use whatever formatting preceded them, they don’t acquire the style and have no settings for applying one. If you can get away with the more limited logic, you might try using the “Prefix” or “Suffix” tabs in Section Layouts. These full formatting fields allow for the assignment of styles. Where they are weaker is in getting separators “between” things, without always spamming “before” things.

The second matter sure would be nice, but it’s a bit tricky given how Scrivener was designed. Suffice to say, it’s probably something we could improve but it would take some thought. Here is link to a discussion on the matter, if you are curious and want to read more.

Sorry, another question:

I think I’ve got everything worked out, but in my Word document, I have the expected Heading 1, Heading 2, Heading 3… but all the other styles come in from Scrivener with a _0 after them. So Title in Scrivener becomes Title_0 in Word, Epigraph becomes Epigraph_0, etc.

Is there any way around this?

EDIT TO ADD: I’d like to point out that these aren’t just duplicates of pre-existing styles in Word – for instance, I have Epigraph Source and Epigraph Source_0, and I’m 99% certain there’s no Epigraph Source natively in Word. Also, the various permutations – so Epigraph Source and Epigraph Source_0 – are identical styles, so it seems like Scrivener is duplicating them for some reason?

The _0 added to some style names is a bug, which has been fixed and will be available in the next update.

I have read through this thread and followed the advice and - it doesn’t work for me.
I have formatted a few paragraphs using the Scrivener-supplied styles. I use the Paperback format for my Compile to Word. I’ve ensured that Include styles information in exported file is enabled in the Styles compile format pane (upper right corner; gear button), and Do not include stylesheet information is disabled in the Sharing: Export settings tab. The “styled” paraghraphs in the Compiled Word file conform to the style (correct fonts/indents;typeface etc BUT those paraghraphs do not show up with those Style names in the Word Style box. Furthermore, those styles aren’t there in the Word style box (which just has the bog standard styles that Word uses). Using Windows 10 with Scrivener and Word within Office 365.