Limits to Compiling?

I have used Scrivener for a number of manuscripts and haven’t come across anything breaking in all the time I’ve used it. Some little bits of things I just had to figure out, but my latest work seems to have maybe found a bug or something, I don’t know.

I’ve compiled incorrectly before (well, poor text size, fonts… etc) and have a file with over a thousands pages. After correcting, it was much more manageable. With my current work, it is my longest. With all of the files selected (51 chapters) it compiled all but the last chapter, and in the last chapter it only compiled the first 2 pages and missed the last 5 pages. The total PDF is 567 pages (without the last 5 pages.)
I removed all of the other chapters and compiled only the last chapter and it compiled just fine. So, there is not something breaking in the text. All other settings remained the same. This is also without front or back matter. Just the chapters.

Is there some sort of limit or something else I’ve come across?

Did you compile to PDF, or did you compile to PRINT and used print to PDF?

There is no limit, no. (Or at least none that I ever heard of.)
But compile to PRINT is buggy (at least under Windows). It does exactly what you just described.

If that is not the case, what if this time, using compile current selection, you compile your last chapter plus say, the one or two just above it ?

This is from the time I had selected the last chapter… I had all of the chapters selected prior to this.

This is the first time I’ve had an issue with compile that is not my own doing and wrong settings or something. I assume that other people have been able to compile longer manuscripts. I am hitting 155,900+ words in this.

The PDF manual itself has 757 pages in the Windows version, and a whopping 910 for Mac.

BTW, you know you don’t have to mess with the included in compile status of your documents when running tests, right? Just use current selection with the proper binder selection. It’ll be way less trouble for you.
There are also the filters. image


One thing I would try if I had to deal with this situation, is that I would move the problematic document up in the binder order, and see what happens when I compile the whole manuscript.
If you end up missing part of the “now last” document, you’ll know the problem is not document related.
If on the other hand the problem seems to follow what was otherwise your last document, you’ll know the problem is with that specific document.
In which case you might want to strip it of all formatting. As in, copy its content to a new document using paste and match style, then test it (make sure the original is not included in compile), and if all goes well, move the original to the trash and reformat the new one.

I moved the chapter above the previous and now I have 2 less pages. But it did not skip the chapter. I now have the 51st chapter in full… but 2 less pages of the total current. It complies more than 2 pages of chapter 50, which would be the last, but when I have 51 as the last, it only gets 2 pages of it for a total of 567 pages.

I then duplicated 50… copied all from 51, ‘Paste and match style’ after select all (did one deleting the content first and one pasting over) still no difference, 567 pages.

So, what you are saying is that you always systematically get no more or no less than 567 pages no matter what you do ?

If so, try duplicating a couple of documents that are OK, then compile with those as extras. – Do the number of pages change? Is the output missing even more pages toward the end?

Then do the same compile again, with the extras, but this time without the problematic document. Do you this time get a higher page count ?

What are you using to view the PDF afterwards ?
Can it display the whole of the manual ?

No, I may I get 567 per normal.
When chapter 51 is ‘50th’ in order and 50 is the last chapter, I get 565 pages.

Yes, have been able to view all of the manual before.

→ Zap gremlins ? Have you tried that ? It is in the text tidying sub-menu, if I am not mistaken. (I am not a Mac user, and we Windoze users don’t have that wonderful function.)

Else, try compiling to PDF but with another compile format?
Also compile from the same compile format as before, but to something other than PDF. See if the compile is complete or not. (?)

I duplicated chapter 51 and it stopped at 2 pages into the last chapter… so it got to 574 this time… I am super confused.

Put the binder back as it was (ditch duplicates and put everything back where it belongs) and try Zap Gremlins

Refer to the bottom of Page 725 of the manual.
Or search for “gremlins”. There is only this one instance.

lol, sorry, I didn’t realize that was a real thing. But, alas, these gremlins are unzappable or gremlin adjacent.

Do me a favor.
Redo that part where you’d copy the body text of your last chapter using paste and match style (Not just paste…), but this time do it in a brand new document. Not in the duplicate of another.
Make sure that the original of your last document is NOT part of the compile before testing a compile.

Nope. Still same thing. I even emptied the trash just in case.

Forgot to mention I was able to compile to Docx and it got everything.

I can’t further help. Sorry.
At this point you need a Mac wiz.

Although you could try what I initially told you not to do:
Compile to print, and use whatever Mac offers (if any) as a printer’s surrogate to rather output a PDF.
If you are lucky that’ll work.

Ok, thanks for the trying. So frustrating to not know what is happening. Still feel like somehow a bug, but not even sure what it could be.

By definition if it is indeed a bug, there is just nothing you can do.

So… yeah, there is a weird bug… I took another project that is 39 chapters. Duplicated enough to get to 51… and only get 2 pages of the last chapter.

So now you know the problem is not with your projects, nor their documents.
Likely something with the PDF converter. (And that I definitely can’t help with.)
I’ll tag @xiamenese, perhaps he’s around and knows what to do…

Well, I removed all the extra and it only go 2 pages of chapter 39… still playing with some other settings to see if there is something I could have done, but doubt there is a setting to stop compiling early.

Try other compile formats.
Not RTF Docx and such. I mean, compile formats, left side of the compiler’s dialog.