Line and Paragraph Spacing cannot be changed

I have my default paragraph setting to include 12pt spacing after the paragraph. In some cases, I wish to change this. This is no longer possible; I open the Line & Paragraph spacing settings, make the change, and nothing happens.

It also fails to change line height multiple. When I return to the settings, nothing has been saved. I have tested this in two different projects and even created a new blank one.

I have upgraded to the Big Sur public beta, but this was problematic before that. (I was on the latest Catalina). 2019 MBP. Latest Scrivener 3.1.15.

Are you trying to make these changes in an existing text document, to change particular paragraphs from your default, or are you trying to change the default paragraph settings? Are you able to see the changes in the text when altering the Line & Paragraph settings, but then the spacing reverts at a later point?

If the changes you’re trying to make are for the default formatting, note that there are two locations that this could be for regular document text: Scrivener > Preferences > Editing, which applies to new documents in all projects, and Project > Project Settings > Formatting, which, when enabled, provides a new default for that specific project, overriding the global one in Preferences. In both cases, the formatting will only apply to new or blank document ( but you can always use Documents > Convert > Formatting to Default Text Style to “reset” existing documents to that formatting).

If you’re able to spell out the steps you’re taking to change the formatting in a new blank project, that might help track down what’s going wrong.

I cannot change the formatting within an existing document, something I’ve been doing for years.
I cannot change the formatting in a new document in that project.
I cannot change the formatting in a new project.

It doesn’t matter how I go about it; it doesn’t work.

I have other issues with Scrivener as well, such as having a lot of missing document icons in the Binder.

I am running the latest Big Sur beta, so this may be the issue. If so, that needs to be addressed.

The fact that you’re running the Big Sur beta is exactly the issue. You should never use an OS beta for real work, because they are always buggy. The missing icons issue you mention is down to a silly but nasty bug in Big Sur which finally seems to have been fixed by Apple in today’s developer beta 7.

The paragraph spacing issue is down to an even sillier Big Sur bug. Scrivener uses the standard TextKit paragraph spacing panel but Apple completely broke it in Big Sur - you will find the same issue in TextEdit. Apple has still not fixed it. If they don’t fix it for the final release then of course I’ll have no choice but to work around it by replacing it with my own panel, but there is no point putting valuable development time into that unless Apple really doesn’t bother to fix it. And surely they will fix something so glaring… you’d hope.

There are worse bugs, too - such as how text can get cut off at the bottom of a page thanks to another new Apple bug.

You are absolutely right that these issues need to be addressed - by Apple. It would be really helpful if you could file a bug report with them regarding TextEdit. In TextEdit, try using the spacing panel via the Format > Paragraph > Spacing menu. You’ll see the same issue. Report that to Apple - hopefully the more people report it, the more likely they are to fix it.

I am reporting the Textedit bug to Apple right now :smiley:

i’m not fussed about these bugs. now that i know it’s the problem, and has been dealt with, i’m fine. the spacing issues are just aesthetics & i need more practice being less persnickety.

tested on TextEdit & then reported to Apple via Feeback tool.

Great, many thanks for reporting this to Apple! I have my fingers crossed it’s going to be fixed, but if not, it’s probably about half a day’s work to implement my own version of the paragraph spacing panel. With all the other work I still have to do on Big Sur, though, that’s not something I’ll do until the last minute if it turns out it’s really necessary. Now that I have Scrivener running as a Universal Silicon app, it’s full steam ahead on getting it looking good for Big Sur.


Thank you for a very helpful reply. Please clarify if there is any way to set the paragraph spacing for a particular style. I want to have a blank line before the start of Block Quote paragraphs. I see the checkbox to “flatten” the first indent and the second indent, which seems to address the an essential style issue, but is there no way to place a blank line before No Style text and a Block Quote?

you should be able to Redefine the style: Format / Style / Refine. Make the change as you want it, then Redefine.

Yes, to update a style you can:

  1. Apply the paragraph style you want to edit to some sample text in the editor.
  2. Adjust the spacing for the sample text via Format ▸ Paragraph ▸ Line and Paragraph Spacing...
  3. With the insertion point in that paragraph, select Format ▸ Style ▸ Redefine Style from Selection... to update the paragraph style.

You may also want to check this post and following for more discussion on paragraph spacing within a block quote.